Question about Peavey AMPLIFIER, 1000 WPC, DDT, 8/4/2 OHMS => Model PV2000 Car Audio Amplifier

1 Answer

Amplifier won't turn on and sound wont come out of it trying to find out if it is connected right

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 153 Answers

Get a test ligh and check for power at the amp at the remote turn on wire and power wire then check for a good ground connection to the amp

Posted on Sep 26, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My techwood tv will not play sound and the colour is not right. how do I fix this?


see the charts troubleshooting and fix it. God bless you

No sound
  1. Check if the TV and Amplifier (if connected) is turned on and set correctly.
  2. Check if the TV, DVD player and Amplifier are connected properly.
  3. Make sure the TV, DVD player and Amplifier volume are not set to Mute.
  4. There will be no sound output during Reverse Play / Pause / Step / Slow / Search.
  5. If the DTS soundtrack is enabled in the DVD Disc Menu, but you are using Stereo Analog audio, the sound will not work. Try switching the soundtrack to Dolby 5.1 or PCM mode in the Disc Menu.

  1. Disc is dirty or damaged. Clean the disc or try another disc.
  2. Reset the color system of the player or the TV set.
Try a direct connection from the DVD player to the TV set, instead of via other components.

Oct 14, 2013 | Gemini 1 Device Universal Television...

1 Answer

HELP! Dog stepped on remote and now volume on Sony KP53S65 won't work.


test this steps and fix it. God bless you
  1. Check if the TV and Amplifier (if connected) is turned on and set correctly.
  2. Check if the TV, DVD player and Amplifier are connected properly.
  3. Make sure the TV, DVD player and Amplifier volume are not set to Mute.
  4. There will be no sound output during Reverse Play / Pause / Step / Slow / Search.
  5. If the DTS soundtrack is enabled in the DVD Disc Menu, but you are using Stereo Analog audio, the sound will not work. Try switching the soundtrack to Dolby 5.1 or PCM mode in the Disc Menu.

Jul 22, 2013 | Televison & Video

1 Answer

Hi, i have a 2004 dodge ram 1500 with the infinity stereo system. The factory cd player broke and i tried to install a new cd player, i bought the right wiring harrness and conected it. But the speakers...


it sounds like you need to turn on our amplifier. this is simple and easy to do just by connecting the blue/white wire off of the back of the radio to the blue wire on the harness that connects to the factory harness.

Jul 02, 2011 | Car Audio & Video

1 Answer

Panasonic projection tv model tx 43p950x, there is power loss while I turn on the remote and there is no power when I pushed the button on front of the TV. Before it happen I connect an audio cable on the...


separate the power cords between different outlets but they have to be on different curcuits. if you have a surge protector it could be bad you can try another 1.

Apr 12, 2017 | Panasonic Televison & Video

1 Answer

Light on remote wont turn on and it is connected to the amplifier


neg terminal to ground, positivew terminal to 12volt and jump a wire from posiitve to remote wire on amp to see if it turns on

Apr 25, 2010 | Polk Audio PA250.2 Car Audio Amplifier

1 Answer

It comes on but no base sound and wont turn up


You have to fill in the details about what you're feeding it (the source and how IT's set up). It won't just >>create<< bass.

From the manual:

If you used the high-level (speaker) inputs and there
is no sound from any of the speakers:
• Check that receiver/amplifier is on and a source is playing.
• Check that powered subwoofer is plugged into an active electrical outlet and is switched on.
• Check all wires and connections between
receiver/amplifier and speakers. Make sure all wires
are connected. Make sure none of the speaker wires are
frayed, cut or punctured.
• Review proper operation of your receiver/amplifier.

If there is low (or no) bass output:
• Make sure the connections to the left and right “Speaker
Inputs” have the correct polarity (+ and –).
• Make sure that the subwoofer is plugged into an active electrical outlet and switched on.
• Adjust the crossover point.
• Flip the Phase Control switch to the opposite position.
• If you are using a Dolby Digital/DTS receiver or processor, make sure that the subwoofer adjustments on the receiver/processor are set up correctly.
• Slowly turn the Level Control clockwise until you begin to hear the desired amount of bass.

If you used the line-level inputs and there is no sound
from the subwoofer:
• Check that receiver/amplifier is on and a source is playing.
• Check that powered subwoofer is plugged into an active electrical outlet and is switched on.
• Check all wires and connections between receiver/amplifier and subwoofer. Make sure all wires are connected. Make sure none
of the wires are frayed, cut or punctured.
• Review proper operation of your receiver/amplifier.
• Slowly turn the Level Control clockwise until you begin to hear the desired amount of bass.
• Make sure that you have configured your receiver/processor so that the subwoofer/LFE output is on.

Apr 07, 2010 | JBL PB12 Subwoofer

2 Answers

The sound on my sony amplifier sounds too low inside the speaker.


Try getting the suround sound modes off and using straight stereo ,with no delays,or echos,

Jan 12, 2009 | Sony STR-DE595 5-Channel Amplifier

1 Answer

Kicker kx650.4 no sound


Your REM switch or wire is not connected right, Try replacing it or just re-do the whole thing

Sep 18, 2008 | Kicker KX1200.1 Car Audio Amplifier

1 Answer

Improper function


try hooking up your subwoofers in series. then connecting them bridged to the amplifier. as follows: positive from sub#1 into positive of amplifier left channel.. negative sub#1 into positive sub#2. negative sub#2 into negative amplifier right channel. turn the gain down as this will sound pretty loud.

Jul 13, 2008 | Pioneer Car Amplifier GM-5100T - 2CH 760...

1 Answer

No sound from the amp


Make sure that your amp turn on wire is connected from behind the radio to your amplifier. Usually the turn on wire is a blue wire but it can be any. This blue wire connects from the blue/white wire behind the radio to your small connection turn on connector on the amps power connections. You have 3 ( 12V , Ground, Switch or the smallest connector)

 

Also check the amplifiers fuses, and the main powerline fuse as well. If this doesnt work then write back to me.

Oct 10, 2007 | Alpine MRD-M1005 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

119 people viewed this question

Ask a Question

Usually answered in minutes!

Top Peavey Car Audio & Video Experts

Glenn Boucher

Level 1 Expert

3 Answers

yadayada
yadayada

Level 3 Expert

74945 Answers

Tom Chichester

Level 3 Expert

33272 Answers

Are you a Peavey Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...