Question about Boston Acoustics BA735 Computer Speakers

2 Answers

My subwoofer has a loose conection somewhere can it be fixed or can I get a new one?

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 6,831 Answers

I will not say that it is certian that you will ned to buy a new one, first check it out, maybe we can help you to fix it yourself.
If the loos connection is at the speaker itself you can just open it up yourself and solder it again and it should be working fine once again.
If you are not familliar with this kind of technical work just take it to your nearest repair shop. The truth is that there is not much that could really go wrong with a speaker. But don't replace it untill you try to resolve the problem. It will be really cheap if it is only a loose connection or a blown capasitor. Please rate this.

Best regards

Posted on Sep 25, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,653 Answers

Yes it can be fixed if you can get the case off!

Posted on Sep 25, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The bass in my Sony 3-way 6X9 speakers wont work


if these speakers are several years old, chances are that the left one is just blown. could be a loose wire, but if not, it would be cheaper to get new speakers than to get that one fixed

Apr 05, 2012 | Sony 3-WAY 6X9 SPEAKERS Car Speaker

1 Answer

My battery run out of power, so i bought a new one to change, i disconnect and change the new one, may be after 2 hours, i re conect but the radia ask for security code. This beetle is from 2001 in...


Check the car manual. The code for the vehicle radio should be hand written somewhere in the back or on the radio information page. If no there, take the car to any local VW dealership and they will give you the code free of charge.

Jul 23, 2011 | Car Audio & Video

1 Answer

My emergence brake patol dont old when pressd


Loose conection somewhere. Line broken? Pedal loose?

Feb 03, 2010 | 1990 Chevrolet Lumina

1 Answer

My central locking stopped working and i cant get my petrol cap housing open to put petrol in to get it fixed! any ideas? any way of unlocking it manually? i have an audi a3 2001


On some cars you can unlock the door twice and this will release the petrol cap - otherwise you could check for a loose conection somewhere in the fuse box.

Aug 11, 2009 | Audi A3 Cars & Trucks

1 Answer

HELLOOOOOO HOW CAN CONECT MY SUBWOOFER


Your problem is quite simple. The low input is for feeding a lead straight from the output of your receiver IE sub out and the high input is for connecting the sub directly to your speaker output where the alternative is not possible. Hope this helps

Jul 15, 2009 | Wave Audio CS801 Speaker

1 Answer

1 subwoofer stopped working in a box for 2


Hello mccanello55,

You need to remove the subs from the box in order to check the internal box wiring. First, make sure that the wire going from the nonworking sub terminals to the enclosure terminals is OK. Then check the "braided" leads on the back of the terminals going to the speaker cone. If the wiring all looks OK, remove the wires from the sub terminals, and use a multimeter set to the lowest ohm range and check the resistance across the subs terminals. You should read somewhere between 3-4 ohms. If the meter reads infinity (that is no reading at all), then the voice coil is open. If it "pegs" (reads "0"), the coil is shorted.

Either open or shorted means the voice coil is no longer working.

I could not find any replacement parts on Sony's support page, so it's most likely that they don't even repair these. They probably just replace the sub if it's under warranty, and if it's not under warranty, they probably recommend that you buy a new one.

Hope this helps.

Apr 13, 2009 | Sony Xplod (P589) Car Subwoofer

1 Answer

Ashton home theater sub not making any noise


It sounds as if the amplifier for the subwoofer is shot. If the subwoofer has a seperate power cord from the rest of the unit, your amp is toast. If the subwoofer is powered by the same unit that is powering the other speakers it could be a loose connection somewhere.

Apr 02, 2009 | Audio Players & Recorders

2 Answers

When i plug in my subwoofer it has a constant hum


Sounds like you have a bad connection somewhere. Make sure all of your connections are secure. If theres anything that is a little loose you'll get that hum. You might also try replacing your cable too. If it became pinched somewhere it could cause that problem

-Captain Jake

Feb 11, 2009 | JBL PB10 Subwoofer

1 Answer

Woofer,s outer ring is ripped.


To fix this problem, you will need to contact Velodyne.
They may be able to replace the surround or recone this driver.

Because this system has the "servo" control, you need to have the accelerometer conected to the amplifier. With out it, the amplifier will not operate.

Jan 03, 2009 | Velodyne VRP-1200 Subwoofer

1 Answer

I have a Kenwood Subwoofer, SW-305, S/N 00901468, that when the power is one and hooked up there is a loud buzzing sound. No audio comes out of the subwoofer. I have checked and rechecked my conections and...


please try to replace your RCA plug that connects from your input player to your Kenwood Subwoofer..coz it not have open ground or has no continuety in it

Dec 05, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Boston Acoustics BA735 Computer Speakers Logo

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Boston Acoustics Audio Players & Recorders Experts

The Knight
The Knight

Level 3 Expert

74383 Answers

 Grubhead
Grubhead

Level 3 Expert

5151 Answers

Vito Vacirca Jr.

Level 2 Expert

140 Answers

Are you a Boston Acoustics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...