Question about ASUS A8N32-SLI Deluxe Motherboard

1 Answer

ASUS A832-SLI Deluxe Display Errors

Last night I performed a proper shut down of my machine and upon starting this morning, I was greeted by a long beep followed by three short beeps. My display output was not working either, as my monitor was still in sleep mode.

I've tried removing the Graphics Card and I still get the same beeps.

Any suggestions are greatly appreciated.

Posted by on

  • 1 more comment 
  • neckbeard Dec 17, 2007

    Unfortunately, I've tried both of these solutions with the same results. I still get the same beeps and I still have no display.

    I appreciate you fellas taking the time to respond though =)

  • neckbeard Dec 18, 2007

    so i've since replaced the memory, and now the beeps are gone. I am still without display output yet. My monitor is good for sure as it works just fine with my laptop.

    How can I diagnose whether its the mobo or the video card without a display? FYI- The video card's fan runs just fine.

  • neckbeard Dec 18, 2007

    I took my system down to the local computer component retailer and had them test everything out-- it's the motherboard. The RAM, HDD's, optical drives, GFX card and processor all work fine. I'll give Asus a call tomorrow to try and get an RMA in the works.

    I appreciate your help!



1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 1,000 questions.

  • Master
  • 1,226 Answers


remove the memory and gently clean it very well and then connect it back to motherboard. if got long beep then memory damage.(replace memory) if got tree short beeps, clean the video card and connect it after cleaning if got same beeps ( then replace video card) thats only only things. Good luck.

Posted on Dec 17, 2007

  • Emelio Navaja
    Emelio Navaja Dec 17, 2007

    You can transfer your memory to another DIMM /Slot beside the originally situated.

  • Emelio Navaja
    Emelio Navaja Dec 18, 2007

    Most of the video card gives tree short beep if it is not fixed well, damage in some circuit on it. even the fan mobo fan is working but only tell there. on the other hand if you diagnose all and still no display. maybe video card slightly detect by the system that is why no beeps happen. The most practical way to diagnose is try your mobo to other computer or try other workable video card your system. good luck again.



1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Need audio installer asus m2n-sli deluxe

If it is: M2N - SLI Deluxe:

if: M2N - SLI Deluxe/Wireless Edition

select your OS

Aug 06, 2010 | ASUS M2N-SLI Deluxe Motherboard

1 Answer

5N32 SLI SE Deluxe board no POST

Check your power supply voltages. All of them!

You can find a list through google for connector pins.

Look for ATX power connector.

Apr 26, 2010 | ASUS P5N32-SLI Deluxe Motherboard

2 Answers

Wont transmit to monitor

Try a different video card frist off,make sure card is seeted in slot good,and check connectors to monitor and board...Cheers

Nov 28, 2009 | ASUS M2N32-SLI Deluxe/Wireless Edition ATX...

1 Answer

ASUS A8N-SLI Deluxe Its sudenly shut down and not coming back again only fan is working

Try resetting the CMOS, to get the procedures on how it's done on your PC's motherboard, please refer to the image below.


Please reply if this has helped you. Thanks.

Oct 24, 2009 | ASUS A8N-SLI Deluxe Motherboard

2 Answers

A8N-SLI Deluxe asus motherboard wont boot

first you want to make sure
the power supply works, they can stay on for a week then die, then work again , then die

then disconnect the cd rom, and see if it still has the same problem,

next could be the processor , this would be the cheapest part next in line,
processors get warm when they work
if not , you would replace that before motherboard

you can also disconnect the hard drive a while
to make sure there are no config errors

Jul 21, 2009 | ASUS A8N-SLI Deluxe Motherboard

1 Answer

Constant restarting with my asus p5n32-sli deluxe motherboard


These boards have reknown faults, usually regarding Bios errors and memory slots on the motherboard. try removing ram, and trying in different slots. Or if your using a matched pair of memory modules. use 1 only in slot A1 or B1. Finally is to check the bios setup, to ensure that all the bios defaults are set.

If this advice resolves your problems, please rate as fixya.

Many thanks mike @ compurepair.

Nov 16, 2008 | ASUS P5N32-SLI Deluxe (890552603794)...

1 Answer

After a BIOS flash 2nd LAN is not working

I would try this uninstall the lan card driver shut down the machine, remove the lan card from PC. start the machine let it strtup fully then close down the machine again and put back in the lan card and reinstall the driver.

Dec 09, 2007 | ASUS M2N32-SLI Deluxe/Wireless Edition ATX...

1 Answer

Describe your ASUS A8N-SLI Deluxe nVidia video card

Yes, you do. Your board was built with the idea to use 2 graphic boards to get great video

NVIDIA® SLI™technology revolutionizes PC performance by combining multiple PCI Express GPUs in a single and scalable system! Gamers and hardcore enthusiasts know that dual GPUs mean increased, supercharged 3D graphics and performance

Dec 09, 2007 | ASUS A8N-SLI Deluxe nVidia nForce4 SLI...

1 Answer

What causes ASUS A8N SLI Deluxe chipset fan and RAID failure

Don't bother with another ASUS chipset fan...
just get hold of a Zalman ZM-NB47J Northbridge Cooler. :thumbsup:

i've been running one of these for a month or so because my chipset fan started to rattle, and make more noise than usual crying2.gif

i haven't had any trouble with passive cooling, maximum motherboard temp is 39C.
i run all my drives on the nvidia controller, and it's overclocked a bit too.

plus you'll enjoy the silence :thumbsup:

Oct 27, 2007 | ASUS A8N-SLI Deluxe Motherboard

1 Answer

Asus A8N SLI RAID showing both drives as "degraded"

This problem usually occurs if: 1) The computer never finished booting 2) A sticky button on you keyboard (F8 or Control Key for win98) 3) Less Memory for windows xp and ME. Try checking if all the memories as well fixed on the board and are being read. 4) Corrupt system files. 5) Incorrect bios configuration (Try changing the bios settings to optimum performance of fail safe to confirm that. All the best.

Aug 25, 2007 | ASUS A8N-SLI Motherboard

Not finding what you are looking for?
ASUS A8N32-SLI Deluxe Motherboard Logo

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top ASUS Computers & Internet Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18419 Answers

Alun Cox

Level 3 Expert

2678 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Are you an ASUS Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides