Question about Kenwood eXcelon KAC-X812D Car Audio Amplifier

2 Answers

My amp stop putting power to the subs

I have a kenwood excelon kac-x812d 1600 watt amp. i have it hooked up to one pioneer premier 12. i got in the car one morning and my amp just wasnt pushing any power out. the amp turns on but the fan isnt spinning and the subs arent hitting. any advice?

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Habit-Forming:

    Visited the website for 3 consecutive days.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 119 Answers

Reprint or replace by the sounds of it.

Posted on Nov 30, 2014

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Expert
  • 54 Answers

Your amp is blown up

Posted on Sep 25, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Best subs for the kenwood x812d


Try and match the rms output of the amp to the speaker , if the amp puts out 150 watts RMS make sure your speaker is at least 150 watts RMS.

Feb 03, 2014 | Kenwood eXcelon KAC-X812D Car Audio...

1 Answer

Kenwoodxw1000f shut off after 10 sec


the problem sounds like your new sub is drawing to much power and your amp can not handle it. bridging the amp is a good way to get the full power out of your amp. But it isnt always suggested, my solution is to get a bigger amp. I install stereo systems for a living, and i tell my customers that it is smart to get an amp about 100 more watts then the rms rating of your subwoofer.

Feb 13, 2010 | Kenwood eXcelon KFC-XW1000F Car Subwoofer

1 Answer

Unwanted bass coming out of my subs


there has to be sumthn hooked up wrong bc i have had same problem with my 12' subs but it was simply a matter of my rca jacks but sense you have checked them try rewiring the speakers if that does not work then your rca module may be burned out within the amp..iso then check the amp by taking the cover off and making sure nuthn is burned on the inside.or if any wires are loose or touching.

Feb 24, 2009 | Kenwood eXcelon KAC-X812D Car Audio...

3 Answers

Adjusting wattage on kenwood kac 9103 class D mono amp


That amplifier is 900W x 1 @ 2ohms.
If your subs are 4ohm SVC wired Parallel, resulting in a 2 ohm load, each sub will only see 1/2 of the rated power. (450W ea.)
Your gain (sensitivity) setting should be between 75% and 85% to max. You will be fine.

Jan 02, 2009 | Kenwood KAC-9103D Car Audio Amplifier

1 Answer

My Kenwood KAC-X1R hooked up to (2) Kicker Solobaric L5's


first get a deck with 4 volt pre outputs or more that will help a lot then a battery in the back will help like a 1000cca or more

Dec 30, 2007 | Kenwood KAC-X1R Car Audio Amplifier

1 Answer

Need help


It should be better to use the Pioneer GM-7200M Amp with your subs.

For 8 ohm setup hook up this way:
Amp out+ to Sub1 +
Sub1 - to Sub 2 +
Amp out - to Sub2 -

For 2 ohm setup hook up this way:
Amp + to Sub1 +
Sub1 + to Sub2 +
Amp - to Sub1 -
Sub1 - to Sub2 -

Nov 09, 2007 | Kenwood KAC 6201 Car Audio Amplifier

1 Answer

My KAC-X812D amp is stuck in safe


From what you are explaining here, it suggests that there is an internal problem with the amp (Blown mosfets, pre-amp etc.) I suggest taking the amp to an authorised service centre.

Aug 28, 2007 | Kenwood eXcelon KAC-X812D Car Audio...

Not finding what you are looking for?
Kenwood eXcelon KAC-X812D Car Audio Amplifier Logo

Related Topics:

298 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...