Question about Phoenix Gold XENON 12d2/12d4 X12D2 Subwoofer Car Speaker

1 Answer

I unplugged my old subs and plugged the phoenix gold in but there isnt any sound.

Posted by on

  • Christopher Walker
    Christopher Walker May 11, 2010

    Did you have sound prior to swapping subs?

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 84 Answers

What are all the ohms. u can run two 12d2 together but u cant run them all three togeether if u need more help let me know bertman285@hotmail.com

Posted on Oct 05, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

No sound from subs


You need power to the amp. If the light on the amp is not on then your amp is the problem. Get power to it.

Nov 10, 2013 | Phoenix Gold Xenon-400.1 Car Audio...

1 Answer

I just got 2 phoenix gold octane r 10" subs and i was wondering what kind of box and how big it needs to be


YOUR MAUAL SUGGEST PROER BOX SIZE FOR THE SUBS. IF YOU DONT HAVE ONE LOOK ONE UP ONLINE SORRY MAN CAPS STUCK.

Jun 30, 2010 | Phoenix Gold Octane-R 10/10d Car Subwoofer

1 Answer

Amp not working, subs just thumping


U either have a bad ground inside your amp or radio or your rca's on the amp are loose

Feb 09, 2010 | Phoenix Gold RSD600.1 400W x 1 Car...

1 Answer

Phoenix gold ti 12d sub gets hot shuts off amp


Depending on your location most places will replace certain things. You may try and see if your sub has any type of warranty. But yes I do believe it would be consistent with a voice coile being bad.

Oct 27, 2009 | Phoenix Gold Ti12D Car Subwoofer

1 Answer

Please help


That depends on what impedence the subs are. If they are 4 ohms each then just parallel them to the amp + to + and - to - on both of them that will give you a 2 ohm mono load which is fine for that amp.

May 31, 2008 | Phoenix Gold Octane-R 5.0:1 Car Audio...

1 Answer

Wiring my subs to my amp


bridge it and rear channel if you need to know how to bridge let me know

Feb 07, 2008 | Phoenix Gold Octane-R 15.0:1 Car Audio...

1 Answer

Sub Wiring


if you wire the subs in parallel you would achieve 2 ohms which would theritically double your rms, sadly this isn't the case what with wire resistance and such you might get around 270 rms still not that bad. to wire in parellel you run a positive off the amp to the positive on one sub then run a wire from the first subs negative to the second subs positive the run from the second subs negative to the amps negative and bam 2 ohms but be warned this will put more stress on your amp and cause it to heat up faster. peace bro and best of luck

Dec 14, 2007 | Phoenix Gold XS6600 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Phoenix Gold Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Mark Skinner

Level 2 Expert

77 Answers

hoyzee1

Level 2 Expert

150 Answers

Are you a Phoenix Gold Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...