Question about Bissell Powersteamer 1694 Upright Vacuum

1 Answer

The tank lid isn't sealing to the machine, leaving a gap between the lid and machine and therefore not drawing the water back into the tank

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 67 Answers

Your missing the gasket.

Posted on Sep 24, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How much dirty water should end up in the recovery tank? I'm not getting back but a fraction of the water that goes out BACK IN... It's a heated model. Is the water evaporationg or is something wrong?...


About 3/4 of the water dispensed should be extracted. If not, there are a couple possibilities. If the float assembly in the lid of the dirty water tank has a mesh filter on it, be sure there is a gap of about 1/2 inch between the top of the filter, and the bottom of the lid. Without this gap the recovery of dirty water will be prematurely stopped. Another problem could be that the pick up nozzle is not making good contact with the carpet. This occurs if the machine has been dropped on it's nose and the screws holding it firmly in place have broken loose from the plastic.

Apr 30, 2011 | Hoover F5866-900 SteamVac Deluxe Wet/Dry...

1 Answer

Re hoover 5914-900/the yellow ball keeps automatically sealing almost as soon as turned on/the mesh filter appears to be clear


Be sure to leave a gap of about 3/4 of an inch between the top of the filter, and the lid of the tank. Without this gap, the ball will shut off the suction prematurely.

Apr 04, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

My machine is only a few months old and has worked perfectly until now. I cannot get the machine to pull the solution back into dirty tank. I have tried the suggestion with the lid and that did not help....


If you are sure the lid is in place, another reason for lack of suction is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Apr 01, 2011 | Hoover SteamVac F5914-900 SpinScrub...

3 Answers

Having trouble


Make sure that the lid for the recovery tank is locked down all of the way around. Sometimes it doesn't catch on the back. There also may be a foam filter inside of the recovery tank lid. Make sure there is at least a 1/4 in. gap from the top. One other filter is from the bottom, it has a red frame, pull it out far enough to clean it. One other thing is the duct installed in front of the recovery tank, if not, no suction.

Jun 21, 2008 | Hoover F7431-900 SteamVac Vacuum

1 Answer

Lost Suction


Usually when there is no suction, one cause is the lid to the recovery tank is not on all of the way in the back. Also if you have that foam filter on the underneath side of the recovery tank lid, it needs to have a 1/4 in or so gap from the top of the filter to the top of the lid. Some models also have a duct that sits in front of the recovery tank, and if it isn't there, you have no suction.

Apr 20, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Upholstry attachement


The hose end should have a duct on it that you insert in front of the dirty water tank. It must be down all of the way so it will seal. This is where your suction starts from. Acouple of other reasons could be the dirty water tank lid is not locked down all of the way around, the back end isn't locked. If there is a foam filter on the bottom of the dirty water lid, there mustbe a gap between the top and the filter.

Mar 07, 2008 | Hoover F5832-910 SteamVac Supreme Vacuum

1 Answer

Hoover steam cleaner


One thing to check is the filter on the inside of the dirty water tank. It must have a 1/4 in. gap from the top to the top of the filter. Also make sure that the lid to the dirty water tank is on and sealing all the way around the tank.

Jan 09, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Won't suck up the water


This happens when the filter on the inside of the lid for the dirty water tank is pushed all of the way up. You need to leave a 1/4 in. gap from the top to the top of the filter. Or the lid for the dirty water tank is not locked down all the way around.

Nov 14, 2007 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

How to use


This happens when the filter on the inside of the lid for the dirty water tank is pushed all of the way up. You need to leave a 1/4 in. gap from the top to the top of the filter, or the lid for the dirty water tank is not locked on top of tank.

Oct 28, 2007 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Hoover SteamVac 5863-900


This happens when the filter on the inside of the lid for the dirty water tank is pushed all of the way up. You need to leave a 1/4 in. gap from the top to the top of the filter, or the lid for the dirty water tank is not locked down on th e tank.

Aug 28, 2007 | Hoover SteamVac F5914-900 SpinScrub...

Not finding what you are looking for?
Bissell Powersteamer 1694 Upright Vacuum Logo

Related Topics:

73 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

Brad Brown

Level 3 Expert

15557 Answers

Jim Thurston

Level 3 Expert

670 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...