Question about Soundstorm D400.2 Car Audio Amplifier

1 Answer

Soundstorm 1600 Watt Car Amp

I have had this amp hooked up before but this time it says protection mode and will not work itis impairitive thatI getthis to work if I do I get an entertainment center for helping out my friend.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Disconnect all speaker wires and signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

Posted on Dec 15, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I hooked up 2 capacitors into my amp and every time I put power to it the amp shuts off and 10 seconds later a red light comes on for 5 seconds and the amp don't turn on, basically it goes into protect...


Well, I have no idea why you would have two capacitors on a 500 watt amp but, did you charge the capacitors? Have you tried the amp without the capacitors? What size power wire are you using?

Sep 20, 2010 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Protect mode


Protection circuit.
Checek the wiring of the amp and speakers, don' forget to look for shorts at the speakers. Make sure no wires are touching each other

Apr 30, 2010 | Volfenhag 1600 WATT CHROME AMP AMPLIFIER 2...

1 Answer

FUC% the protection light


i had a similar problem with my amp (although a different brand). Check you ground connection and make sure it's not grounded to metal with paint covering it. This is NOT a solid ground connection. You must remove the paint then reconnect it. Without a solid connection to ground, it cant run for very long without going into protection mode. Hope this helps

Jul 27, 2009 | Soundstorm Force F2800 Car Audio Amplifier

1 Answer

Speakers cut off when bass goes up


probably the amp going to safe or protect mode judging by the fact that you have 3 subs wired to it i would say it is not 1 ohm stable try disconnecting 1 sub and see if it still happens this will be running a 2 ohm load rather than 1 if it stops happening then you need to figure out a better wiring configuration that will work with your amp.

Jul 03, 2009 | Kicker ZX400.1 Car Audio Amplifier

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

Soundstorm amp


do you have a model #?
The MAX PRO is the only one rated @ that power.
Let me know, and Ill look it up!

Jan 08, 2009 | Lanzar Vibe 218 Car Audio Amplifier

1 Answer

Can u help me


The amp probably has shorted outputs. Do you want to try to troubleshoot it and repair it yourself?

Nov 22, 2008 | Soundstorm D500.4 Car Audio Amplifier

1 Answer

Mmat amp 1200 watt


If the amp is in protect mode, it probably has shorted output transistors.

What model amp is it?

Aug 20, 2008 | Car Audio & Video

1 Answer

My Amp


sounds like the sub that throws it into protect mode is cross wired pull sub out and make sure they are wired right make sure ground from sub goes to ground on box and do same for power wire

Jun 11, 2008 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Soundstorm D400.2 Car Audio Amplifier Logo

Related Topics:

223 people viewed this question

Ask a Question

Usually answered in minutes!

Top Soundstorm Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

hoyzee1

Level 2 Expert

150 Answers

Jim Goldsmith
Jim Goldsmith

Level 3 Expert

2005 Answers

Are you a Soundstorm Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...