Question about Jensen A600HLX Car Audio Amplifier

3 Answers

Subwoofer amplifier turned engine on, saw green light, booming no problem but then almost a short time later like maybe 10 minutes driving, red light came on with no longer the booming. what's wrong?

Posted by on

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Check the actual wiring of your subs. Your impedences may be wrong for your amps and if this is so continuing to do so will cause damage to both. I am an installer.

Posted on Dec 22, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

I have the same problem. Some days, it will work great. Other, most days, it'll work for a while, then at higher volumes, it will cut out and go into protect mode for a few seconds, play for a half-second, return to protect, and this simply repeats unless the volume is turned lower.

Posted on Mar 03, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

This could cause from different issues.

1. Check if there's any voltage leading from your ignition to the remote cable on the AMP. If you have voltage on the ignition check the fuse that connect inseries on the remote cable.

If the fuse ok you might have other problem in the Audio Output stage.

Good luck.

Posted on Dec 13, 2007

  • John Brown
    John Brown Dec 13, 2007

    Please note Subwoffer amplifier and car stero are very sencetive.



    Make sure all B+ cable are properly insulate before applying voltage to your unit.

    Also your speaker wire are proper insulate.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a sapphire subwoofer model PS 3 b. When


theres no input signal. the green indicates only when it detects incoming. check your amplifier.

Oct 03, 2014 | Televison & Video

1 Answer

Amp not switching on again after switched off for 10 minutes


It sounds like amp's short circuit protection is kicking in. you more than likely have a couple of blown speakers. This drives output to close to 0 Ohms and its shutting down. If it;s not that , the problem is internal and you would have an out put Transistor or a capacitor about to fry.
suppose you could go in and go over solder joints, but don't hold your breath. Next time dont turn it up so loud

Sep 08, 2017 | Lightning Audio Strike S2.600.2 Car Audio...

1 Answer

Why does the red light click to green without the speakers on?


That system responds to signal input, ie an electrical signal present on the input, in order to turn on the internal amplifier. If it is turning green without any input from the source, it could require service. It may be responding to static electricity...

The speaker should go to sleep after ten minutes or so, turning from green to red again.

Jan 13, 2011 | Infinity Overture 2 Speaker

1 Answer

Is there a on of switch and is the green or red light to be on


There is no main AC power switch on the BU series; it's in standby mode whenever it's plugged in.

When playing music normal LED color should be green. After no signal for 10 minutes or so it will turn back to Red (Standby)

Nov 23, 2010 | Infinity BU-120 Subwoofer

2 Answers

2 12" subs + 600W amp. Turn on, goes boom once, then red light


Is your gain all the way up? If it done this before, sounds like your over working the amp. Make sure your subs ohm load is capable with the amp load to. If they are 1 ohm and your amp is only 2 ohm stable, it would beat for a lil bit then go into protection mode to. Check your wires too.

May 13, 2010 | Insignia 600W Bridgeable Amplifier with...

1 Answer

Amp works for a few minutes


too much power. turn your amp down a bit and let er rip.

Oct 01, 2009 | Sony Xplod 1100 Watt Max 10" Subwoofer,...

3 Answers

My red light on my amp is on and wont go out


Unfortunately I think you need to get it repaired or replaced .When a protection light will not turn off it is generally caused by an internal short and needs one or more replacement parts for it to come alive again.
-Dynami

Apr 03, 2009 | Insignia 600W Bridgeable Amplifier with...

Not finding what you are looking for?
Jensen A600HLX Car Audio Amplifier Logo

Related Topics:

91 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jensen Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4991 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

The Knight
The Knight

Level 3 Expert

75846 Answers

Are you a Jensen Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...