Question about Echo Indigo Stereo Output Device for Laptop Sound Card

1 Answer

I can't get it running

I think I have installed the drivers properly but when I try the io I can't get any sound out of it and nothing shows up on the Indigo io Console. The sound just comes out of the laptop speakers or the old mic socket. I would be very grateful if you could help

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 5 achievements.


    An expert who has written 50 answers of more than 400 characters.


    An expert who has answered 200 questions.

  • Expert
  • 382 Answers
Re: I can't get it running

What is your computer and operating system, tell me this, and I will get you on your way...

Keep me posted.

Posted on Dec 16, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have windows 7 and it is a 64 bit operating system, when i plug the dj io into my usb connection and try to install the drivers it comes up as not recognising the hardware and keeps saying that the...

Good day,

Is your Numark DJ/io soundcard comes with a software cd/dvd. You need to install it first in your system to use it. If you have no cd. Try downloading on the product website for the software. Tnx

Aug 18, 2011 | Numark DJ/iO Sound Card

1 Answer

I have windows 7 and it is a 64 bit operating system, when i plug the dj io into my usb connection and try to install the drivers it comes up as not recognising the hardware and keeps saying that the...

Make sure you got software with this program that is 64 bit compatible,i heard Numark just released 64 bit support for DJ/IO and your card supports multiple outputs

Mar 14, 2011 | Numark DJ/iO Sound Card

1 Answer

No audio devices installed

Did you try another available IO/SLOT on the motherboard? If so, go to the realtek website and download latest driver for that model number. Install audio card then update the driver using the new version. I hope this helps.

Jun 23, 2009 | Packard Bell (030069) Sound Card

2 Answers

Io/2 will not install on my i mac

driver compaq evon610c de video

Jan 16, 2009 | Alesis iO | 2 Sound Card

1 Answer

Echo indigo io recording problem

dont plug mic into output, it is input

May 24, 2008 | Echo Indigo IO Sound Card

2 Answers

Alesis io on a dell vista inspiron machine

I have one of these io/2 boxes and they are great, shame windows doesn't keep the drivers for long, and crashes on resttart so ythe box will not load at all.
The solution is to do a destructive uninstall.

To do thus, you need to carefully drag the device out of your laptop, and away to a safe place, and then smash it to pieces with a hammer. In this way you will totaly remove the need for any drivers.

lol... seriously, i dont know how to fix this issue. I think my box is broken, i'm sending it back, i dont think alesis have thought this box through enough.

May 01, 2008 | Alesis iO | 2 Sound Card

2 Answers

Problem with Windows XP recognizing Creative Sound Card

It sounds like a software problem. Though you did the right thing by entering the bios & disabling the onboard sound. That should have been enough. Did you uninstall the old intergrated sound drivers before adding the 24bit card? Just about all the drivers & upgrades for your 4600 through Dell is Creative software & thats why your having a tough time. I would put everything back to how it was. Re-enable the intergrated sound & reboot! Run system restore & check that every thing is running right!! Look at this dell web site for the sound drivers you have at this link:
If you must, install a upgrade for your intergrated sound. Just so you can uninstall it after a reboot. Re disable the sound in the bios. Do not install your new card yet. While back in windows device manager you should be missing a PCI device. Shut down install the new sound card. Hopefully windows will want the drivers & all runs fine. If still no it could be a bad card (i know what your thinking but it's possible). The only thing left is the regestry is using the wrong PCI device.

Dec 26, 2007 | Creative Labs Sound Blaster Live! 5.1...

2 Answers


Why because some audio drivers may not be properly installed even it is installed from the motherboard drivers. why because some Bios doesnt allow this. only solution to solve this issue. Try downloading latest driver for your sound card model.
thank you !

Dec 20, 2007 | E-Mu 0404 Sound Card

Not finding what you are looking for?
Echo Indigo Stereo Output Device for Laptop Sound Card Logo

Related Topics:

68 people viewed this question

Ask a Question

Usually answered in minutes!

Top Echo Audio Cards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Sudeep Chatterjee
Sudeep Chatterjee

Level 3 Expert

3267 Answers

Teet Bergmann

Level 3 Expert

565 Answers

Are you an Echo Audio Card Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides