Question about Logitech X-540 Computer Speakers

1 Answer

None of the speakers in the shystem work. Amplifier seems dead

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Prodigy:

    An expert who has answered 500 questions.

  • Expert
  • 619 Answers

Hello there!

Well, here we got a few things to check
1) Type os sound card you got, 5.1 , 6.1 7.1??
2) Depending on your system windows Xp or Vista? adjust in control panel , the speaker mode, for above configutarions. example: for 5.1 surroung sound .
3) verify if you on bios disable the on board sound, back conections , and the mixer is enable, and nothing on mute. **
that's it!
Open Sky

Posted on Sep 20, 2009

Testimonial: "Thank you for the advice. Due to another commitment I will not be able to look at the PC board until Wednesday. It does sound as though it could be."

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My speakers just stopped working. No power when I turn know to turn on and increase volume


Ir you are lucky it will be your power supply that's gone dead. Use a volt meter to see if the power supply is working or try to find a power supply with the same characteristics (voltage, polarity and amperage). If that doesn't work, the amplifier may be busted. If so you'll need new speakers.

Apr 18, 2014 | Bose Companion 2 Computer Speakers

2 Answers

Back Speakers don't work.


Change the radio if it looks worse than the speakers. Or, go buy some junkyard speakers and try them out. If none of this works, sell the car.

Apr 01, 2014 | 2000 Jeep Grand Cherokee

1 Answer

Flextone 3 one speaker not working


Then you either have a blown amp or speaker. Turn the amp off and move the wires from the speaker on the working side to the other speaker. If the other speaker works, you have a dead amp channel. if it does not, move the wires from the speaker on the non-working side to the other speaker. If that works, you have a dead speaker. Dead amp channel means take it to the shop. Dead speaker means buy a new one from Line 6 and install.

Mar 08, 2014 | Line 6 Flextone III Plus Guitar Amplifier

1 Answer

One side dead


hi zm_16dec,

Right chanel fully dead , output transistor burnedout ,

Without knowing the make and model of your amplifier

all i can advise is to replace the unknown part number of

the transistor.


Look for the working left channel output transistors and

replace the bad transistors in "pair". These may include

other components but check on it as well.


Check the speaker system, especially where that channel

is connected.Inspect speaker wires or cable up to the speaker

itself.


Amplifier wont blow without reason.It could be from the wirings,

speaker or volume settings of the unit.

Thanks for choosing Fixya for assistance!

Dec 24, 2012 | Audio Players & Recorders

1 Answer

Bose 321 power woofer buzzes but produces no audio sound


I assume the other two speakers are working fine. Contact Bose and ask them. Could be a simple fuse. Sounds like a fried speaker driver, but do this first. Take the back off and check the power amplifier for a blown fuse. If none, disconnect the power amplifier. Reconnect the speaker cabinet w/o the built-in power amplifier to a known good amplifier to see if the speaker works. If it works then you know its the built-in power amp that's fried. Contact Bose for a replacement or better yet buy a another one with a higher RMS watt capacity. Wattage ratings in other than RMS are worthless. JBL and Cerwin Vega produce high wattage units. You need to keep the volume lower to avoid the problem in the future.

Aug 27, 2012 | Bose Audio Players & Recorders

1 Answer

99 A6 Subwoofer and Amplifier


I have a similar problem on Audi A6 2.5 tdi year 2000, is just that my subwoofer is working fine, but the rear speakers have no sound and the rear satellites on the same ciruits are working just fine, I cannot explain this! I have taken apart the rear speaker and teasted with an ipod and one is working fine but the other is dead! I don t know if there is any connection, or there is a filter for the rear speakers and if one speaker is dead there will be no sound on the other speaker! but as i said on the same cables satelites are working well!

Mar 16, 2010 | 1999 Audi A6

1 Answer

The stereo in my 2001 mercedes slk 320 produce no


hello,good day,try to check your number 14, for your left and rigth speaker amplifier control module,also try to check the fuse in your amplifier,ty

May 12, 2009 | 2001 Mercedes-Benz SLK-Class

1 Answer

Behringer EP2500 amplifier channel crackling noise


Got asilimar problemwit a behringer europower pmh 3000.
my

The Right channel began to crack up and drizzle now it seems completely dead.
Changed the cables both of input and seapkers , still the problem stays the same. Any suggestion before brigning for a month at the repair shop? And get out with a 200-400$ bill ?

Apr 28, 2009 | Behringer EUROPOWER EP2500 Amplifier

1 Answer

Sanyo Audio component system 685, ran well until moved to another room. Plugged in and turned on unit. Used different copper antenna wire to hook up one speaker. Maybe cause of problem? The sound came on,...


It seems that the wire you used may have had a defect in that the two speaker wires may have touched each other and caused the amplifier to over drive and burn out . If you reverse the speaker that is not working to the other channel, it will work proving that the amp is dead and in need of repair.

Sep 07, 2017 | Kitchen Ranges

1 Answer

Car radio


HI BBunk,

Sounds like the dead speaker took out the amplifier output too. You may need a new head unit.

Nov 13, 2007 | Elliott's Car Radio 50C564797 Car Speaker

Not finding what you are looking for?
Logitech X-540 Computer Speakers Logo

Related Topics:

195 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

Michial Gueffroy

Level 3 Expert

1138 Answers

kakima

Level 3 Expert

102366 Answers

Jerry Umali

Level 3 Expert

979 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...