Question about Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My amp for my car has a steady blinking power light for about a minute then immediately blows the fuse?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 16 Answers

This one should be quite easy to troubleshoot. Start by disconnection every wire on the amp, including the RCA's. Connect the ground, then the 12v power. The light should still be off. Use a jumper from the main 12v in to the remote in. The light should come on. If it doesn't after doing exactly this, or if you still have the same problem- internal amp problem.brian.small@bobstgroup.com

Posted on Sep 13, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1995 Toyota Camry AC blew 10 amp fuse causing it, fan, electric windows, door locks to quit working. I replaced 10 amp fuse. Now AC light is steady for a few seconds, then blinks and soon blows fuse.


This fuse powers the control system and compressor clutch. Odds are you need a new compressor clutch, but you can try a slightly larger fuse--no more tham 15 amps. If the light still blinks, have someone check the amperage at the clutch. Clearly, the clutch should not be consuming more than 10 amps. The diagram is at the link below.
http://www.revbase.com/BBBMotor/Wd/DownloadPdf?id=1210

Jul 30, 2017 | Toyota Cars & Trucks

1 Answer

Amp blow fuses immediately when power is switched on


There could be so many things wrong with it, but personally I find the most likely problem is the power supply.

Mar 15, 2015 | Peavey TNT 115 1x15"" 600W Bass Combo...

1 Answer

Power Problem with 2Wire 2701HG-B


Sounds like a startup self test. All wireless devices go through a power on self test. Does it connect? You can connect to it and go online? I rarely turn mine off, only in a electrical storm.

Nov 22, 2012 | 2wire (2701HG-B) Wireless Router

1 Answer

Brake light fuse keeps blowing in my 1997 Suburban only when towing trailers.


If the fuse blows on different trailers then it's all down to the vehicle. You either have incorrect wiring on the vehicle, a short OR the fuse is not of a high enough value to cope with the additional brake lights? You could try removing all the trailer bulbs EXCEPT the brake lights - e.g. if it's trying to power up the indicators too? That would stop the fuse blowing...... OR remove the brake bulbs from the vehicle & see if it operates the trailer without blowing...... Check the total wattage of ALL the brake lamps & see if the fuse is actually of a high enough rating? Be aware though that increasing the value of the fuse could cause damage elsewhere! As a rough guide a 25 watt bulb will pull around 2 amps at 12 volts - so 4 bulbs may pull up to 8 amps & clearly blow a 5 amp fuse! If in doubt take it to an auto electrician...... The wiring needs to be correctly protected!

Apr 02, 2017 | Cars & Trucks

1 Answer

I have an Alpine MrP-M500 that is not giving off sound. The light is diming, and blinking meaning it is in "safemode." ive done everything, new fuses, ground is good, wires are good, sub is good. I got it...


yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Jan 25, 2010 | Alpine MRP-M500 Car Audio Amplifier

1 Answer

When I hook up my kenwood kac-7201 the power light


leave power connections hooked up disconnect rca and speaker wires if they still blow more than likely problem with amp

Dec 31, 2009 | Kenwood KAC-7201 Car Audio Amplifier

1 Answer

Flashing red light on ice maker control


Hi

I have Kitchen Aide refrig. Resently, we had a power surge which seems to have done something to the ice maker control. immediately after it stopped making ice. It has since started to make ice but very slowly. Before the controller blinking red light blinked and paused steady. Now, it blinks two red and pause steady. Is this repairable?

Thanks

Jul 16, 2009 | Whirlpool Refrigerators

1 Answer

I have a 25 wat fuse in my power wire connected to my amp and i keep blowing it. should i put a bigger fuse in it?


Hello grabert205,

You do not say if the fuse blows immediately upon powering up or while the amplifier is operating. If it blows immediately, I'd check the power and ground.

If it is blowing the fuse while operating, I'd try a 30A and see if it holds. At maximum output of 100 watts times 4, the amplifier needs about 31 amps of current at 12.8V. So driving it hard could certainly blow a 25A fuse.

Hope this helps.

Jun 13, 2009 | DHD LCD-9444 Car Audio Amplifier

3 Answers

Toshiba 57H81 Flashing Red Power Light, Blown Fused F850+F852


Solved by resoldering some solder joints!!!!!!!
********
Toshiba Model 57H81 Rear Projection TV - Purchased 11-09-2001

Problem: Toshiba 57H81 Flashing Red Power Light, No Picture/Sound, Blown Fuses F850 + F852

Symptoms January, 2009:

  • Upon turning on set I got flashing red power light and nothing else.
  • Removing plug for one minute and plugging in results in:
    • Audible click, steady red power light for 2 seconds then slow flashing red light
    • Pushing power button results in steady red for about 2 seconds then slow flashing red light, no other set activity
  • Removing power cord for several hours and plugging back in made no change
    • Audible click, steady red for about 2 seconds then slow flashing red light
  • Possible related note: Over past several months occasionally the entire screen would flicker momentarily and at other times be problem free for weeks.
  • Fuses F850 and F852 found blown

Repairs Made:
  • PD0074 DEF/CON Power Board
    • There are two main power supply capacitors in this set. They are C-809 and C-810. One their negative lead on the printed circuit board re-soldered leads and nearby contacts. I’m told that because the factory left out a printed circuit board eyelet, the connection will come loose over time. When I called Toshiba customer service they said there was a known solder joint problem causing blinking red light.
    • Replaced blown fuses F850 and F852.
      • I actually installed a fuse panel on the inside of the cabinet and routed the fuse connections here instead of ordering the special fuses and replacing them on the circuit board.
      • Had to use a 5 Amp SLO-BLOW for F850. Fast blow does not survive power up. Get the red blinking light.
      • Used a fast blow 2 Amp for F852.
  • PD0073 SIGNAL Board
    • Re-soldered Q751 + Q752 STK392-110 Convergence Amps
    • Re-soldered adjacent pads that looks suspicious

Total Cost to Repair about $10
  • Twelve hours of my time over three days to research issue, disassemble set, make repairs, add fuse panel.
  • Already owned Service Manual and Circuit diagrams from a different 2004 repair.
  • Less than ten dollars at Radio Shack for fuses and fuse panel. Already had wires, etc.
  • Some solder. Already owned de-soldering tools, etc.
  • Visited both local authorized Toshiba factory service repair facilities. One said repair would have to include replacing Q751 + Q752 STK392-110 Convergence Amps with ST392-180, and realigning set for a total of $500+ and it would be more if they had to order a power board. NO THANK YOU! Other shop said $65 for site visit and $30 to make an estimate that could be applied to repair.

Jan 04, 2009 | Toshiba 57H81 57" Rear Projection...

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

83 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8140 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...