Question about Pioneer Car Audio & Video

1 Answer

I have two of the same amps. Each powering one subwoofer. Through trial and error, Ive found that one amp works with both subs. The other amp doesnt work with either, the power light is also slightly dimmer. I tried switching rca plugs and get nothing still. Im thinking its just not working properly which is a possibility but id like to think its just me.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,896 Answers

One amp may have the circuit protection circuit on. You will have to turn power off for an hour, check connections, and restart. I like to leave the fuses out until it is all connected. If you have a big enough amp, you can certainly power two subs with it. Two amps ran from origianal amp is not a good idea anyways. It will soon be burned up.

Posted on Sep 09, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

8" compact subwoofer not working it was installed


post more information about your amp. its likely the vibrations moved something in the amps, or buttons.

Oct 10, 2013 | Alpine Swe-1000 8" Compact Subwoofer...

1 Answer

Hi Ive brought a Sony 2dx-gt590ui and sub and amp got it all wired up but the sub only works on radio can you tell me what Ive done wrong???


You can try to connect the remote power wire at amplifier to main power with a jumper wire if sub works with cd and other sources.Then check remote wire from behind radio or you can simply connect remote power wire to a another switched power source from fuse panel.Just make sure its a clean dedicated power source from fuse box and make sure it turns off amp..Goodluck

Sep 23, 2011 | Car Audio & Video

1 Answer

Hi i need some help i have a sub and amp in a ford fiesta 2001. ive chanced cd players to a ridspeed dv720. my sub was working fine with my old cd player but now ive put the ripspeed in it doesnt work. i...


You can use a "Y" cable to combine the two RCA cables to the one out. You will need a 1 male to 2 male cable. That will solve the signal problem. Is the amp functioning properly. I would check that first. Make sure your wiring is correct. Hope this helps

Aug 25, 2011 | Car Audio & Video

1 Answer

Subwoofer not getting max bass


try using a ohm meter and if its not making what the factory specs are its most likly it will keep loosing more and more power then stop working which is what ive had happen to me before

Mar 11, 2010 | Fusion RE-PK2120 900W Bass Pack: Amplifier...

1 Answer

My 10 in subwoofer in my srt 4 neon doesnt seem to work need help


do u have sound but no light?

I ran my neon straight from the power from the amp so soon as accessories comes on they light up!

Run neon wires positive to the amp directly p.con & negative to negative on ur sub outlet!

Mine had the same prob & it was trial & error & that set up works for me & a few mates have done the same!

May 01, 2009 | Kicker 01C8VR4 Car Subwoofer

1 Answer

Subs sound terrible (Ive tried so many things)


NO it won't be your battery. Sounds more like your deck.

Jan 22, 2009 | Jl Audio 12W3 Car Subwoofer

1 Answer

My amp was bad so i replaced it now my sub does not work i checked the wiring that goes from the amp to the speaker and everything seem to be ok then i put another speaker thinking it might be the sub and...


It doesn't sound like the wiring from amp to sub is your problem.

Is your amp getting a power light ?
Are you sure your remote wire is hooked up properly ?
Check both ends of your RCA cables

Jan 05, 2009 | JBL GT150 Car Subwoofer

1 Answer

Infinity ps-10 powers up but no boom


Try hooking up a different signal input to your powered sub, another stereo or even a dvd players audio output to the sub will work for a test. Just make sure the subs gain is down before starting. If it still not producing sound, the subwoofers amplifier is bad. I hope this helps.

Oct 10, 2008 | Infinity PS-10 Subwoofer

2 Answers

Car sound system. only sub is giving off sound. other 4 speakers dont work at all


Could be bad outputs from the back of your head unit or also could be bad rca cables. Make sure the amp is on and powered.

Dec 13, 2007 | Kicker CompVT CVT654 Car Subwoofer

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

12 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pioneer Car Audio & Video Experts

Michael Kovalik III
Michael Kovalik III

Level 2 Expert

117 Answers

The Knight
The Knight

Level 3 Expert

73619 Answers

yadayada
yadayada

Level 3 Expert

74945 Answers

Are you a Pioneer Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...