Question about Kenwood Excelon KAC-X811D Car Audio Amplifier

1 Answer

Pioneer GM-6200F amp appears to have blown, but fuses are intact

I have a Pioneer GM-6200F (approx 3 years old) in my 2003 Toyota Matrix, powering 4 stock door speakers. I also have a 2 year old Pioneer GM-7200M amp powering a pair of 10 inch subwoofers in a vented box. Tonight the audio to the 4 speakers went out suddenly when listening to loud music, but the subwoofer was still producing audio. I am assuming there is not a problem with the standard Toyota AM/FM/CD deck. I checked the two 25A fuses on the GM-6200F amp, which seemed fine. Under the hood I was expecting to find a pair of 30A fuses but found only one. Since I wasn't sure if the other one had fallen out or was merely never there in its slot, I took a new spare 30A and installed it but that did not resolve the issue.

Is it possible that a fuse could be bad but doesn't look blown? I would have swapped out both fuses on the amp to test if it wasn't in such a horrible location under the passenger seat. Could the amp have just died without anything going on with the fuses? Also, there is another larger fuse right by the car battery, which is also intact.

Thanks for your help.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 86 Answers

I have used Pioneer before but have not run
across this before.sounds like you may have
drove it a little to hard, and and zap one of your amps inside.Take the top off and look
around and smell.
Maybe This Will Help

Posted on Sep 09, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Red light on on amp


take speaker wires off amp if the lit is green then speaker are hooked up wrong or blown.

Mar 29, 2014 | Pioneer GM-5200T Car Audio Amplifier

1 Answer

2010 matrix, turn signal and heater blower stooped working at same time...hazard light ok.


If the car is under warranty (3 years/36,000 miles I think) have the dealer check it. You might have a blown fuse, and most owners manuals show the location and amperage of the fuses for the various systems. Generally speaking, a fuse should not blow unless something is overloading that circuit, so you might have something like water ingress shorting wiring or a heater fan motor drawing too many amps...start with the fuse.

Dec 18, 2011 | 2010 Toyota Matrix

1 Answer

My subwoofer was taken out of the trunk to change a tire disconnecting the wires from amp how do i reconnect? I have no idea what goes where


who wired it for u? red is positive or + and black is negative or - the extra smaller wire usualy blue is for the remote.

Apr 08, 2010 | Pioneer GM-6200F Car Audio Amplifier

1 Answer

Pioneer GM-6200f amp no audio - flashing light


Hello! Yes, It certainly looks like the output power circuit has blown.

I wish I had better news.

Guru................saailer

Jan 12, 2010 | Pioneer GM-6200F Car Audio Amplifier

1 Answer

Pioneer GM-7200M 800 Watt Amp shut off and wont turn back on.....


Hiya, first check by triggering or powering the amp manually by putting a voltage at the trigger. Just use a jumper from power. If the amp comes on then check the feed from head unit. Loose wire, inline fuse near the head etc.

If it still doesn't come on the hate to say its gonna have to go in for repair. Could be anything inside from protection, blown track etc.

Hope that helps

Jul 27, 2009 | Pioneer GM-7200M Car Audio Amplifier

1 Answer

Pioneer GM-7200M power problem


Check your GROUND wire might be touching something and making bad contact.

Jun 09, 2009 | Pioneer GM-7200M Car Audio Amplifier

1 Answer

Radio and cigarette lighter outlet not working on 2003 matrix


There are 2 fuses that powers the radio, cigar lighter, etc.
They are: the 10 amp "GAUGE" and the 15 amp "CIG".
Look under the dash, on the driver side. The "CIG" fuse is the one that you need to replace.
It is in the middle of the fusebox, bottom row. again, a 15 amp fuse.
Please advise if you need additional information.

Hope this helps, and Thanks for choosing FixYa.

Nov 16, 2008 | 2003 Toyota Matrix

Not finding what you are looking for?
Kenwood Excelon KAC-X811D Car Audio Amplifier Logo

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4861 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...