Question about Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Car amp not working it powers up

Car amp wired up have power to amp so it turns off and on when i turn on car have rca plugs in have tried to adjust amp still no luck

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 96 Answers

Dble check ur rca wires and speaker wires to the amp and behind the radio

Posted on Sep 09, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Stays protection mode, how can i fix this?


Disconnect all speakers (at the amp terminals) and the RCA's leaving just power, ground, and remote connected. Does it turn on now without going to protection? If so, plug in the RCA's. Still good? If so, you have a shorted wire or bad speaker. If it still stays in protection, the amp is faulty. Have it repaired or replace it.

Dec 22, 2013 | PLANET Audio Rxd2400 Car Amp

1 Answer

New in dash reciever, have sub woofers, they turn on but are not working


There are a number of issues that could be going on here. Go down this check list.

1. Check to make sure your head unit is getting power
2. Make sure the volume is up and that you do not have the unit on mute


The following list is if you have an amp (I assume you do if you have subwoofers).

1. Make sure the RCA cables are plugs to the correct outlet RCA's on the unit.
2. Make sure the RCA cables are not crimped at any point on the way back to the amplifier
3. Make sure the power and ground are good on the amplifer and that the remote turn on is functioning (this will turn the amp on).
4. Make sure the RCA cables are plugged into the right place on the amplifier.
5. Check the gain levels on your amp. This is a dial next to the RCA input. You will need a small flat head screwdriver to adjust.
6. Make sure the subs are wired correctly. If they are wired to the wrong ohms load they may cause the amp to go into protection.


If this doesn't help, you may need to get more specific in your next post.

Aug 18, 2011 | Car Audio & Video

1 Answer

Kenwood kac-749s amp power indicator flashing red. what does this mean and what can fix it?


Either there is a short in the in the amp or hopefully just the speakers or wires going to the amp. disconnect any speaker input output and turn your amp back on(you will only have power, ground, and remote wires plugged in at this time) and if the red protect light goes away, then there is a problem with the input/output speaker wires, this includes your RCA's. If it's still flashing red then there may be a stray wire shorting to the amp in the speaker outs, other than that your amp may be fried. By the way, if it works without any speakers connected, including RCA's try connecting one component speaker at a time starting with your RCA's(if using them), speaker in, then speaker outs. If it turns into protect mode, note which speaker/RCA it was and replace or repair the short.

Jul 11, 2011 | Kenwood Car Audio & Video

1 Answer

Amp stopped playing riding down the road, power light turned off. came back on when i unplugged the rca's and cuts back off when i try to plug them back in.


Faulty RCA cables, Or worse possible solution is if your amp stopped playing when it was pumping at high volume, you may have blown the RCA connectors inside your head unit Or inside your amp. If possible try another known good working amp with the wires you already have, If same happens, try different RCA cables. If problem persists after trying these, Its your head unit RCA connecters or amp RCA connectors. To rule out your amp connectors, try your amp in a friends car if possible, to rule out your head unit, try another good known working amp in your car with the wiring you already have

Mar 03, 2011 | Kicker ZX300.1 Car Audio Amplifier

1 Answer

Got this amp from a friend and want to wire it up to my Sony head unit. The HU does have pre-out in RCA plugs. please help. I have tried it with: RED - stereo Amp Rem In YELLOW - 12V BLACK - -12V...


Senshin,
Red- 12 volts switched (ignition)
Yellow- 12 volts constant
Black- Ground
Blue/white stripe- remote amp turn on/ power antenna
If you have any orange wires there for the Illumination dimmer. (head unit dims when you turn the lights on). The white and gray are front speakers and purple and green are for the rear, solid being + and black striped being -. (gray and purple are right channels)Make sure that the RCA plugs go to the input side of the amp. I hope this helps, Ray

Oct 11, 2010 | Metra 705512 Ford Prm Snd Amp Plug Wiring...

1 Answer

Were do i plug in the RCA cables from the amp to a factory radio? do i need any sort of adapters if my stereo dose not have inn or outputs? and where do i hook up the remote from the amp?


Most factory radios do not have RCA outs, but most will have a remote wire. Usually used for a power antenna option. Your remote wire from the amp could be hooked to the power antenna wire on the factory radio and it would work great for turning on the amp. As for the RCA inputs on your amp, you will not be able to use them without RCA outs on your factory deck. Although most amps offer a high level input alternative and will use the standard speaker level out on your factory deck. This means the rear channel speaker wires from your factory deck will be used to feed the signal to the amp. You will have to check the instructions and manufactorer recomendations for the amp you are trying to hook up. Have fun and good luck!

Mar 09, 2010 | Stingpro ST444 1850 Watts Complete...

2 Answers

I am trying to hook up an ancient Kenwood KAC-801 amplifier. The original input cable has 1 red, 1 black, then another smaller awg white (1) sharing a common with another small awg yellow. Applying power...


Yes, keep in mind that the amps have a constant power (the large red wire) and need a remote signal to tell them when to turn on/off. This wire connect to a switched 12v from the ignition or radio blue wire (if aftermarket)

Nov 01, 2009 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Car amp turns off when RCA wires are plugged in.


Hello joshua_m_moe,

A short or ground on the RCA cables or too high of an output level from the head unit could cause this. First, try it with the amp gain turned all the way down. Then, replace the cables with a known good pair. If the problem is still there, it's probably coming from the head unit. If there is another pair of preamp outputs, switch to them. If the problem still persists, I'd suspect the head unit.

Hope this helps.

Sep 18, 2009 | Power Acoustik TS1440-2 Car Audio...

1 Answer

When i connect my power wire to battery my deck cuts off and when i disconnect cd player works


This is your receiver going into speaker protection mode. this could be one of a couple of things based on what you have stated. The obvious would be that your amp is pushing too much power for your speakers. You can try a couple of things. 1st is check your watts for your amp and speakers and adjust your gain accordingly(may need to adjust how much your putting out). If it is turning off with the gain turned all the way down, then that's not the problem. Try disconnecting the RCA cables, then hook up to the battery and see if your amp comes on. If it does, you have everything hooked up right for the most part. Doing this will make sure your getting power to your amp.

If you get power with the RCA jacks unplugged, you might make sure that whatever speakers are hooked up to the amp are disconnected from the factory wiring. Those are some things to check based on what you wrote.. Could you be a little more specific with things like what kind of speakers and deck you have, how many speakers you are running, describe what happens when everything cuts off, etc.

Jul 19, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Noisy/buzz


Usally a ground loop isolator will fix that problem. It plugs into the RCA's between the radio and the amp.

Try to reground the amp in a different spot.

Or run a refrence ground from the deck to the amp next to the remote turn on wire. (still keep your main amp ground hooked up)

DO NOT run your power wire next to the RCA's, that will induce a field which in turn can cause that buzzing sound.

Jun 03, 2009 | Crate SPA1600 Power Amplifier - SPA Series...

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

Related Topics:

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4869 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76682 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...