Question about SimpleTech 250GB USB2.0 7200 RPM External 250 GB IDE Hard Drive

13 Answers

Simpletech 500 GB drive won't work (repost because not solved)

Hi I am reposting because the problem isn't solved. Someone posted a 'solution' but it was really a question, and I rated it, which I didn't know took it off the 'unsolved' list - so am reposting my problem which one other user also said they had.

I have a 500 GB not a 250. I plug it in, connect the USB, turn it on, the blue lights flash for a second and the drive whirs a bit and then I get a blinking red light it blinks 9 times and then nothing. The drive had been crashing, I couldn't copy files from it and it wasn't recognizing all files, I started to recover files from it with R-Studio but the files stopped being recoverable. Any way to bring this back to life? I have tried on two computers and different usb ports so I don't think it is the USB ports. One computer is XP Media Edition and the other is Vista Home Professional.

Posted by on

  • 13 more comments 
  • 427 fairlane Dec 11, 2007

    I have a similar problem, I have only had my 500GB hard drive for 1 week & it crashed, I turn it on and all I here is a "clicking noise" out of it! I transfered aboout 20GB of Data on it. How can I recover my Files I have on it?

  • donbrewer44 Dec 29, 2007

    Already tried on two different computers one was a laptop. I do have another laptop I can try but it's an even less powerful XP machine.



    Sounds like Simpletech is simply crap.

  • donbrewer44 Jan 29, 2008

    Solution is no solution in this case. I tried all USB ports front back and side.

  • Anonymous Feb 02, 2008

    Simpletech 500 GB - Yep - same problem. Mine worked great for about 3 weeks before it died on me - a 300% improvement over the other fellow who's drive only worked for 1 week. Still, not a very practical time frame for long-term storage!!!

    I'll try to give them a call and see if they have an official explanation - only for sheer amusement value of course. I think we've just been duped out of 100 bucks.

  • szprof Feb 21, 2008

    I have a 250 GB. It worked for about ten days, and when I turn it on, the blue light flashes, but no whirring. I was able to power it up fully once and transfer my data off, but I haven't been able to again.

  • makelemonade Mar 11, 2008

    - Same thing here! I have the 320GB version - but same Nine blinks and will not show up on my desktop (mac oSX) or in disk utility. Seems to power up just fine - was everyone able to retrieve their data when this occured? I am about to spend $500 bucks to get it looked at - any other ideas??

  • ray-ray1971 Mar 30, 2008

    Hello-I have teh same problem. I have the Simpletech 500 gb hard drive (external). It worked well for a couple of months. Then after I did an update on Leopard-it won't even get recognized on my desktop. I am running Leopard, and it did work on it for a while as I have used time machine before. I have looked through disk utility and such-but I cannot figure it out. An icon does not even appear ANYWHERE on my mac-so basically it is like I have not even connected it. My Mac does not even see it.

    Anyone have any detailed suggestions??

    Thanks in advance.

  • Anonymous Jun 27, 2008

    Same problems. Tried using the USB cable from my flash card reader and it worked perfectly.

  • Anonymous Jul 20, 2008

    simpletech 500 gb does not turn on says it needs a driver

  • Anonymous Jul 20, 2008

    harddrive turns on lights for 5 seconds and does not run the disk. spindle motor is jammed or burnt. this is most of your problems this hard drives are known to not have good enough motors to turn and read the imformation on the disk. I have been hours on the net reading on this problem. they start by not reading sectors then all goes. don't take my word, but I made some research as I have lost 180 gigs worth of music and videos this sucks.simpletechpinifanina 500 with hitachi desksta

  • Anonymous Jul 22, 2008

    I have the exact same problem, except on a mac. Tried it on two different computers and nothing.

  • jwdriggs Oct 14, 2008

    I have a 500g hard drive that does the same thing. It turns on the blue lights go around once and then a blinking red light. My computer make the noise like it sees it but it is never able to read it. I have pic and home movies on here I need to get off. Any help??

  • Anonymous Dec 21, 2008

    Same issues as posted.

    I took the time to read all the posts. The fix listed works great.

    Remove out the 2 visible screws

    Pull the tag and it will reveal the other 2 screws...remove them

    gently hold the case on both sides and lift with a little force...be careful there are wires attached to the top of the case.

    Remove the 2 side panels and loosen the 2 set screws that hold the drive...the drive will slide forward and detach from the back panel



    resecure the drive to the back panel put all components back and secure the drive



    plug it back in and it should work...well it did for me

  • darkestheart Feb 02, 2009

    I own a simpletech 250 GB external hard drive and it was good for the first 6 months. No problems or anything. Then all of a sudden it just doesn't regognize anything. I plugged it into many different computers (apple and pc) sometimes it likes what its in and other times the computer recognizes that its there. But just doesn't show up in the My Computer. I tried the troubleshooting and i do everything it says and still nothing. Code 10 too. I don't know if the files are saved or what. I hope so! I got some very important pictures and stuff on this thing!

  • Anonymous May 09, 2009

    It smells like burned plastic, after 20 min of use it stopped working. It's simply crappy

×

Ad

13 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 4 Answers

I had a similar problem with a SimpleTech 250g Pininfarina USB drive.
I went through the drivers, the power supply, the USB cables, and the various
computers, USB cards and Operating systems.
Finally I opened the case and found the disk drive was mounted too far
forward, causing the IDE connector to barely touch. I loosened the mount screws,
slid the drive back towards the connector, tightened everything down and it works.

Posted on Apr 22, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I thought that I lost all of my documents after reading these posts. I saw someone's post about something being disconnected inside. Didn't want to open it and not return it.

I tipped it on its back and shook it a little and my computer automatically recognized it.. no driver issues... worked perfect!

Now I am going to restore my docs and return it. Hope that helps someone! Thanks for posting - I would never have figured it out!

Posted on Feb 01, 2009

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Heat. The problem is simply heat. This thing gets too hot.

Take out the 4 screws underneath and take the plastic top off. Two screws in the back and two screws in the front under the foil. This voids your warranty. The cover is a little stubborn, but take it off first from the back and then a good firm tug to get it off the front.

Make sure it has been off and disconnected from your PC before you do this. Re-connect and viola!

Save the pplastic top to keep dust off when it is not being used.

Considering this has worked for me ever since a year ago I'd say this is the solution. If taking the cover off is unacceptable to you, I'd consider getting a laptop type fan to place this thing on and see if it does the job.

The slick paninfarina cover with its cool light just doesn't allow enough air to circulate around this thing and it just gets too hot.

Mine is the Simple Tech 500 GB external HD model.

Again, this voids your warranty, but the warranty is only good for a year anyway and a replacement will only do the exact same thing.

Posted on Nov 14, 2008

I am also having this problem with my SimpleTech 320 GB drive. The explanation from the techs was that the 320 GB drive required more power than two USB ports could give it, and so I need to get an external power adapter. What a design flaw - to make a drive so big that you can't even use it.

Posted on Oct 15, 2008

**** simpletech

Posted on Oct 12, 2008

FUUUUUUUUUUUUUUUCK SIMPLETECH

U GOTTA PUT IT IN A FRANGA AND SHOVE IT UP YO *** CHILDREN

IM OUT

Posted on Sep 30, 2008

I have a 1tb simpletech and none of my cpus recognize it guess im going to take another 1 back this is my second

Posted on Jul 08, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I just bought the 1TB model same issue. Sees the drive but you can't drag copy to it. You can save to it but not drag. You get a message saying not enough space.  The techs at simpletech try to send you to apple and claim they have it there and works just fine.
Take the drive back quick!

Posted on Jun 18, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Simpletech 500 GB - Yep - same problem. Mine worked great for about 3 weeks before it died on me - a 300% improvement over the other fellow who's drive only worked for 1 week. Still, not a very practical time frame for long-term storage!!!
I'll try to give them a call and see if they have an official explanation - only for sheer amusement value of course. I think we've just been duped out of 100 bucks.

Posted on Feb 02, 2008

Thanks Mr donbrewer44 it will works fine, when i pluged it at back of my system..
thanku very much for ur postings

Posted on Jan 26, 2008

Take it to another computer, possibly a laptop. My laptop seems to see it right away and it works fine. I don't know why, but I'll not be suckered into buying another one. My Acomdata has not given me one bit of probelm.
I have threel of the SImpletech, and most of the time, they blink a blue & stop. The front USB port does NOT provide enough power on my Desktop. Format stops at 48% repeatedly. My little 160 Simpletech wont even power up using a front USB port, it has to go into the back one to even get recognized. Its 'double' USB cable does not even work (it's supposed to provide enough power. Boo). Hope it works for you. They'll get the msg back at HQ only when sales go down. Until then...why should they even care?

Posted on Dec 29, 2007

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Get a USB cord with an extra power plug. Plug them both into two separate USB ports and it will come right up.

Posted on Mar 11, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I'm having the same problem. I have a 250 GB and it won't power up. It worked for about a month. I have very important files saved on their, if I can't recover them it will be a complete disaster for me.

What can I do?

Posted on Apr 22, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hi I am looking for a user manual for SimpleTech 500 GB external hard drive Model # 96300-41001-160


Did you try looking on the internet ? Usually the manufacturer has free manuals downloads

May 03, 2017 | SimpleTech Computers & Internet

2 Answers

How do you repost something


Hi there, the easiest way to repost something is by clicking *share* - It is beside the comment button.

Jul 08, 2011 | Facebook Social Network

1 Answer

Someone posted something that I'd like to repost to my profile page. How do I do that?


if you mean in facebook. You can only repost website links and videos. But if you would like to repost a comment, then just copy and paste it to your profile page.

Mar 24, 2011 | Computers & Internet

1 Answer

My simple human sensor Soap Dispensor will not


Hi, you have this question in the wrong park of the site. But I did a quick google search and believe I may have found an answer for you. I'll copy and past what I found for you here. If this doesn't solve the issue you should probably repost this question

"In the spot where the soap dispenses, there is a very small plug which controls the flow which you need to gently pull out and release (not break off) in order to break the vacuum seal. This information is not included in the regular instructions, but rather is written on a small 2-inch square piece of paper in the box. I was getting very frustrated because I had "primed" the soap dispenser at least 30 times and nothing had come out. I noticed the small plug, and while looking through the box again found the small piece of paper with the additional instruction. After that, it worked great! I use a generic version of Soft Soap, and we find the lowest setting dispenses more than enough soap."

Mar 04, 2010 | SimpleTech 250GB USB2.0 7200 RPM External...

1 Answer

Six month old Simpletech 500 GB ext. drive not recognized


I had the exact same problem. Solved by removing Simpletech drive from the 'flashy-box'. Unplugged drive from internals and threw the 'Pinnaferrina' case away and installed it on my motherboards extra sata plugin site (if it has one). If you open your computer case it should be labled on the Motherboeard as such. Mine has four. On the first attempt when I started the computer i Had no OS system showing on first boot-up. Shut off computer and power and shifted SATA (RED Cable) to another Sata plug on Motherboard and it booted right up and I had the drive back. You will need a longer Sata cable than the attached to the Simpletech drive and a power cable that matches the one on the Simletech . Forget looking for the drivers on the net and the Simpletech web site was no use.

Oct 10, 2009 | SimpleTech 500GB SIMPLEDRIVE EXT HD-USB...

2 Answers

External no longer recognized


Right click My Computer, Properties, then click on Device Manager.
Select Disk Drives then on tab menu Action, Add legacy hardware. Go through the setup and use CD's that came with Hard Drive otherwise search company site for drivers.

Oct 05, 2009 | SimpleTech 500GB SIMPLEDRIVE EXT HD-USB...

1 Answer

SimpleTech 500 GB external hard blinking red light


I got one with the same problem. I opened up the case and hooked up the hard drive to a generic usb to sata adapter that i picked up on ebay and it works fine now if a bit clunky looking.

Sep 10, 2009 | SimpleTech 500GB SimpleDrive Pro External...

2 Answers

I have a 500gb simpletech hard drive that I have lost the power adaptor. I need to know what size to buy.


The simplest way is to ask SimpleTech
Your Part number: PRO500Q
Customer Support Phone Number Tel: (949) 477-7700
(6:30AM-5:30PM PST Mon-Fri)

or send them a tech support request at...
http://www.simpletech.com/webspeed/webtech/indextech.php

Aug 11, 2009 | SimpleTech 500GB SIMPLEDRIVE EXT HD-USB...

1 Answer

Simpletech 500 GB Hard Drive not working


The red light is an indicator of drive failure. The fall it took, especially if the drive was on at the time, could easily cause the drive to break something internally so that it will not function. I found SimpleTech drives to fail pretty easily, even when you're not dropping them. That's been my experience, anyway.

Data recovery is a very expensive proposition. If the hard drive doesn't respond to the interface as normal, they have to be pulled apart and data extracted from the internal platters. This isn't something you can do without a full safe room (dust-free, wearing special suits and all) because any dust can ruin the platter. Since it's so involved, it's usually really, really expensive. Generally, most people don't bother when it reaches that point unless it's business files (like all of your financial data, for instance).

However, if it's something you really need that bad, DriveSavers is one of the best:
http://www.drivesaversdatarecovery.com/

Jun 21, 2009 | SimpleTech SimpleDrive Pininfarina 500GB...

1 Answer

Simpletech 500 GB external hard drive - unresponsive


If you really can not get it to work anymore, you could try opening it up and connecting the hdd directly on a IDE/SATA port in your computer. This will only work if you have a desktop, for a laptop you would need all kinds of converters.

May 03, 2009 | SimpleTech 250GB USB2.0 7200 RPM External...

Not finding what you are looking for?
SimpleTech 250GB USB2.0 7200 RPM External 250 GB IDE Hard Drive Logo

3,764 people viewed this question

Ask a Question

Usually answered in minutes!

Top SimpleTech Computers & Internet Experts

Marvin
Marvin

Level 3 Expert

82285 Answers

Ricky Ostrom
Ricky Ostrom

Level 2 Expert

274 Answers

Arora Singh
Arora Singh

Level 2 Expert

180 Answers

Are you a SimpleTech Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...