Question about Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

1 Answer

Will not **** water from carpeting

While checking to make sure there was no blockage and filter was clean, discovered the suction hose was split almost all the ray around at the point where the upper and lower sections of the machine rotate.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 190 Answers

You will need to replace the hose with one from:
http://www.hoover.com/parts/?category=carpetcleanerhoses

Posted on Oct 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

4 Answers

My carpet shampooer will not **** the water back up. It is a Hoover Steamvac Deluxe 1600.


Hi,

Check the filters, make sure they aren't clogged. Also if this has the foam filter on the inside of the tank lid, make sure it has at least a 1/4 is gap from the top.

Jun 18, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Why does my machine vacuum has very little suction while the there is no solution come out of the hand hose?


Make sure you have the hoses hooked up properly. Also check that there is no obstruction/blockage in the hose. Otherwise, contact your friend.

...

Apr 26, 2016 | Vacuums

1 Answer

My dyson will not pick up but has suction when using hose only


I have had Dyson All Floors model,( the one with the clutch adjustment to allow transition from carpet to hard floor) for a number of years. Recently pick up from carpet particularly poor. Went through all the solutions as recommended on Dyson website. No blockages, no broken sole plate, bristles (should be around 7mm to 8mm long) protruding ok from soleplate ( these can wear slightly over time but not usually the problem), belt not broken nor slipping. Filters cleaned/ replaced, but still poor pickup. Checking for strength of suction, as recommended by Dyson, both at top of hose and at bottom right inlet revealed no problem there. It turned out the clear inlet hose coming from the soleplate to the underside of the machine was the problem from two viewpoints. Firstly, as can be expected, the clear hose can develop splits after a number of years due to wear and tear. The other, not so obvious, problem is that the hose is also a form of straight spring which is designed to be compressed to a certain degree to an S shape when the machine is in the upright position. Upon pulling the handle back, whilst pushing on the footrest at the bottom results in pressure from the hose/spring being applied to the rear of the sole plate, pushing it on to the carpet. Thereafter the suction takes over, keeping the soleplate firmly fixed to the carpet. The existing hose on my machine had settled in to an S shape over the several years I have had the machine, thereby not pushing firmly enough the rear of the soleplate on to the carpet ( I noticed a significant gap at the rear whilst using the machine). For the couple of splits I had effected a temporary repair using a couple of very narrow strips of Gaffa tape, whilst awaiting the new hose/spring, but only a marginal' if any, improvement. Upon receiving and attaching the new hose/spring the solepate was properly pressed onto the surface of the carpet and pickup was like new.

May 09, 2012 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

Suction problem? The carpet fiber and pet hair


You've probably got a lesser blockage further down the pipework, which is reducing the airflow. Check everywhere possible for blockages, and also make sure the washable filter is clean and dry.

Feb 05, 2010 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

No water spraying, suction still working


I have a Bissell as well, and found that your issue sounds like there is a blockage in the hosing to the main cleaner part of your machine, The siphon action of the suction that your machine is obviously working in that you state that your accessories tubing is working. There is a split though in your unit. probably under the hood of the machine which splits the pressure between the accessories and the main unit. I highly suggest you look there to seek your blockage.
This unit works like a "straw" in a soda pop.. the unit makes a suction draw and that draw is directed to the main unit area and the accessory area, splitting from the main suction line..
Another suggestion though might be to be sure your accessory line is not "open" when you are trying to use your main unit.. you can test this by seeing it it squirts when you run your main unti as well.
Summary then is to check that there is no blockage after the "T" where the pressure seperates to the main squirter and the accessories.. This should be fairly obvious to see and a little cleaning should resolve this right up for you.
Hope that helps!
Stan

Sep 19, 2009 | Bissell Carpet Cleaner Powerbrush Deep...

4 Answers

My VAX Vacuum has lost ALL suction power. I've


vax power pet 1 filter keeps getting clogged up so dirt not going into cylinder

Jul 05, 2009 | VAX Appliances Vax X5 Bagless Upright...

1 Answer

Dyson red style. beater bar not working. no suction


You may have a blockage or the internal hose is not seated tightly anymore.

1) Check for blockages from the bottom of the machine. Remove the:
(i) U-Bend (stand behind the machine and look next to the right-hand-side wheel, it's attached with a rectangular clip next to the
long gray hose - push the clip and pull the U-Bend off, make sure its clear - if there's a blockage remove it and continue with the
blockage check to ensure that the entire machine is clear)
(ii) AI Valve (stand behind the machine and look above the right-hand side wheel, it's attached with two buttons on either side of the
AI Pipe/Valve - push the two buttons and pull the pipe up and off and make sure there is clear - if there's a blockage remove it and
continue with the blockage check to ensure that the entire machine is clear)
(iii) Refit the internal hose on the bottom of the machine between the wheels and make sure it isn't torn and has no holes in it and
that there is nothing clogged inside it - to refit the hose: Pull it off where it sits next to the wheel first - make sure that the
gray piece of rubber is still on the hose (if it isn't, pull the gray piece of rubber off the hole and reconnect it to the hose by
twisting it back on) - next, twist the hose off where it connects to the brushbar - inspect the hose and make sure you don't have any
holes in it - put it back on by twisting it onto the side of the brushbar first - then line the gray piece of plastic end up with the
hole next to the wheel and push and twist it back over the hole. Bring the machine back upright and test it

2) If no blockages are found on the machine at all:
(i) wash the filter in cold water and leave it out to dry for at least 24 hours
(ii) blow out the cyclone from the bottom (open the door on the bin door - you can now look into the cyclone) - blow it out with an
air compressor or a leaf blower
(iii) Wipe all the small holes off on the cyclone with a dryer sheet
When the filter is dry put it back into the machine and test the suction again.

Apr 24, 2009 | Dyson DC07 Animal Bagless Upright Cyclonic...

3 Answers

Dirt devil vacuum has suction on bottom but not on hose


Follow the hose to where it goes into the body of the vaccum, you should be able to release it, you more than likely have something lodged in the hose or at the connection joint, Strech the hose once it is disconnected to make sure nothing is still lodges in it.

Hope this helps, If so please rate accordingly. Thanks, David

Mar 19, 2009 | Dirt Devil Featherlite Bagless Vacuum...

9 Answers

Hoover Agility, No Suction!!!


I had the same problem. Lower the handle to the floor and check the black spiral suction hose at the neck of the machine. The lower hose in my Hoover split. Check and see if yours has done the same thing. If so, the lower suction hose will have to be replaced. Hope this helps.

Oct 04, 2007 | Hoover F6212-900 / F6215-900 SteamVac...

Not finding what you are looking for?
Hoover SteamVac F5914-900 SpinScrub Upright Vacuum Logo

Related Topics:

39 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18392 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1460 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...