Question about Eureka 5892AVZ Bagless Upright Cyclonic Vacuum

1 Answer

Vacume cleaner The vacume has no suction. the belt is fine i checked it. It turns fine no air is comming from the hose.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers
Re: vacume cleaner

Check the hose and see if it has a clog, also the hose at the bottom. The filters may be clogged, make sure they are clean and that air flows thru them, if not then replace them.

Posted on Jan 15, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

Suction stopped. Roller and belt working-in fine order. Checked hoses have not found any blockage. Blowing out air or sucking so little can't feel it with hand on hose end. Help!

Either a blockage or the main air filter is blocked , some it can be washed and others it must be replaced

I would check the owner manual and look at the filter, foam ones can and usually have instructions where they install to wash them.

Dec 11, 2012 | Hoover Tempo Widepath Upright Vacuum -...

1 Answer

Hand held vacum suction stopped after 1st use. Was working fine, suction does work if onfloor but won't once turned to tool

go to the web page and see instructional video and maintenance help

God bless you

Jul 19, 2012 | Bissell 2X Proheat 9200 rug cleaner

1 Answer

My Hoover vacuum cleaner is not picking up from the carpet like it used to. Like it's having difficulty picking up strings, fuzz, etc. from the carpet. Suction power seems to be fine. The belt and the...


Jan 16, 2011 | Hoover Vacuums

2 Answers

Kenmore progressive 360 vacuum cleaner has low suction

Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Kenmore 35912 / 35913 Progressive Upright...

1 Answer

Suction/Brush not working

Hi there SmartAlec from here.
There are a couple of common reasons that your electrolux vacuum cleaner would appear to have lost it's suction. The first and most common is that it has actually broken a belt. If the belt is broken the brushes won't spin and it will not pick up dirt. It is easy to test simply turn the vacuum on, release the handle (as if you were about to vacuum carpet) and lift up the head and see if the brushes are spinning. If not i can supply you with a new belt.
If the brushes are spinning then your next most likely cause is that there is a blockage in the vacuum somewhere. Test this by turning machine on and checking the suction at the hose (as if your were going to vacuum the couch) if it is poor then remove hose and fish out blockage. If it is ok you may have a blockage between hose and the brush of the vacuum.
If it is neither of these problems i can trouble shoot over the phone if you live in Australia 0269215200 or by email
Happy Vacuuming.. :)

Aug 25, 2009 | Electrolux EL5010A Bagged Upright Vacuum

2 Answers

It has lost most of its suction power...what to do?

clean all the filters if this doesn't help then check for blockages at head, hose and entrance to collection chamber

May 30, 2009 | Vacuums

1 Answer

The Hoover Windtunnel vacum will not pull suction

Either the machine or hose is blocked OR the filters are blocked.
Also possible that the belt is broken.
Please leave feedback

Feb 13, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Sudden loss of suction.

Check the inlet down by the brush roll to see if it is clogged. Also check the belt to be sure it is ok. Is there suction at the hose? If not then it is still clogged.

Oct 30, 2007 | Kenmore 33721 Upright Vacuum

3 Answers

No suction

Hmmm...I have the same problem...if you remove the water tank and the water collection bucket and look at what is remaining. Now step on the lever to lean the upright part back and there is a hose there that goes from the hand held hose into this hose into the dirty water tank. MINE is broken at that center point between the handheld hose and the dirty water square thingy...It's probably fixable...maybe this helps you?

Nov 05, 2006 | Hoover F7431-900 SteamVac Vacuum

Not finding what you are looking for?
Eureka 5892AVZ Bagless Upright Cyclonic Vacuum Logo

Related Topics:

117 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts


Level 3 Expert

18258 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Jim Parker
Jim Parker

Level 3 Expert

1040 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides