Question about Vacuums

1 Answer

Ihave a Hoover Windtunnel self-propel model U6445-920. The belt from the drive motor to the big wheel will not run in the center of the wheel. The belt runs about 1/3 off the wheel. I have tried several new belts and still the same problem. What do I need to do to repair this problem.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 430 Answers

The large wheel may be worn off center. If the belt stays on and is not thrown, you can run the vac. if there is wobble in the wheel causing a genuine belt to slide off replace the wheel mechanism.

Posted on Sep 07, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The wheel that connects both belts broke


The drive pulley can be replaced, however I would only recommend being service by a vac shop professional who has experience with the Hoover Self Propelled models.

Oct 20, 2014 | Hoover Ultra U6430-900 WindTunnel Bagged...

1 Answer

How to stop the main belt from comming off the motor shaft on a hoover modle u6634-900/windtunnel


Hello there! If you have replaced the belt and it is still slipping off, you may be not have the right belt for your vacuum. This unit takes a flat belt and a v-belt. Make sure you are replacing the belts with Genuine Hoover Parts. I have included the links below where you may go to order the belts specific to your cleaner.

WindTunnel PowerDrive Belt 2 Pack

WindTunnel Self Propelled Belt

Hope this helps!

Jun 21, 2014 | Hoover Self-Propelled WindTunnel Bagless...

3 Answers

Self propulsion doesn't work on my upright. Vacuum works fine otherwise


You will need to look @ your owners manual to see where the self propell belt is located i am sure yours is broke and need to replace,- it will not be hard to replace-Lance

Oct 21, 2009 | Hoover Vacuums

2 Answers

Self Propel doesn't work on Hoover Wind Tunnel


Your self propel wire could be broken. Lean the vacuum back like you were using it. If you stand in front of the vacuum look down and to your left. When you move the selp propel button you should see a wire move. If not then it's broken.

Oct 06, 2009 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Belt will not stay on hoover windtunnel s3765


The Hoover Windtunnel™ Self-Propelled models have two belts, a flat belt and the V-Belt. This V-Belt is the one that drives the Brush Roller. After about three months, most belts stretch out causing them to slip. This means the brushroll turns slower or not at all and the self-propelled becomes increasingly harder to push. It is recommended that both belts should be changed at the same time.

May 23, 2009 | Hoover S3765-040 WindTunnel Bagless...

2 Answers

Hoover wind tunnel u5755-900. smoke, smell. self-propel


Can you verify the model number? However, based on your posted description, it sounds like the flat belt is either broken or fell off. to access the belts turn it over and remove the bottom plate (4 screws). the Flat belt will connect to the motor shaft in the back and the large black pulley.

Mar 13, 2009 | Hoover Self-Propelled WindTunnel Bagless...

3 Answers

Self Propelled does not work


if you look below the headlamp of your vac you will find a cable that attach's to a piece called the actuator arm. either this piece is likely broke or the cable itself. always work the power drive smoothly or things will break. also could be that the smooth belt is stretched and will cause the same problem. belts should be replaced every 4 months. good news is all parts above should be under $5. dont let anyone tell you that you need a power drive assy, that usually isnt the case. good luck!!!

Sep 24, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Windtunnel self-propelled feature broken


If it is a rubber smell, then it could be belts and/or brush roll. If it is an electrical smell, then it could be the motor. Take the belts off and see if it still makes that noise, if it does, then the motor is going bad.

Apr 22, 2008 | Hoover Self-Propelled WindTunnel Bagless...

1 Answer

Hoover windtunnel Self-propelled - brush roll stops


There is a idler wheel that will drive the V belt, sometimes they jam and you just have to reach in, push and make sure if comes in contact with the belt. Alot of times tho it is the other flat belt, 38528035 that will stretch and can cause you to have problems with the brush roll not turning.

Feb 11, 2008 | Hoover Self-Propelled WindTunnel Bagless...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

73 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...