Question about Kenmore 22812 Bagged Canister Vacuum

1 Answer

The beater of my kenmore vacuum won't turn on - the primary light goes on but none of the sensor lights go on.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 430 Answers

Kenmore vacs generally have three male contacts at the machine end.Internally when the hoses swivels these contacts run on three brass rings which can also get dirty due to proximity to dirt. They can get dirty or dirt can fall into the corresponding female socket where the hose meets the vac. If you have just changed the bag inspect these connections near the intake port on the vac.
The working LED means you have a partial connection. Also try wiggling and twisting gently at the handle of the hose and where the wand connects to the hose and the power head elbow... you have 4 connections between vac and head

Posted on Sep 06, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenmore model 401.39035900 vacuum cleaner beater problems


probably need a new motor and beater bar.

Feb 20, 2013 | Vacuums

2 Answers

Hoover - Red Light Dirt Sensor


check to make sure the settings didn't get inadvertently switched to the hi position, move the switch back and forth from high to reg a few times, then leave it on reg.

remove and hand wash the primary filter and secondary filter, dry throughly and replace them in the vacuum.

if none of this works, you will need to have the vacuum serviced, or if it is still working, just don't pay attention to the dirt-finder. the dirt sensor on your vacuum is located in the suction tube and is generally not accessible enough to clean without taking the vacuum apart.

hope this helps,
trin

Nov 20, 2007 | Vacuums

1 Answer

Servicing windsor sensor xp15


You need to replace your beater bar more than likely, if the light stays on all the time. If it is flashing there is usually something jamming the brush roller from turning properly.

Jan 27, 2013 | Winsor Windsor SENSOR XP15 Vacuum

1 Answer

My Kenmore vacumn won`t turn on . worked fine one minute then stopped. The light works on the handle but no vacumn


You probably have a sensor that needs attention and is clogged up so unclog and see if that takes care of it

Jan 12, 2011 | Kenmore Vacuums

1 Answer

The beaters wont turn


You need to replace the belt. Here is the belt you need:

Kenmore 23313 Belt

Feb 06, 2010 | Kenmore 23313 Whispertone Bagged Canister...

1 Answer

Beater bar will not turn, think belt is broken, but do not know


the model number of the powerhead would be helpful - usually there is plastic cover with a lens for the light, push inward on both sides and the cover will pop offthere are two screws under that OR, there are two screws on the underside of the unit - it just depends on the style

Aug 18, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

I have a kenmore beltless upright the beater brush dosetn spin


If it is direct drive then the motor or the wireing to the motor are bad. If it is gear driven then the gears are probally stripped.

Apr 11, 2009 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Kenmore canister vac 25614


Have you checked and made sure that the hose is COMPLETELY clear and the bag is not full?

Feb 13, 2009 | Kenmore 25614 / 25615 Progressive Bagged...

1 Answer

Brush does not turn on my vaccum


If there is no suction when you disconnect the beater bar assembly near the hand hold where you grab the vacuum, then there may be either a restriction in the vacuum line between there and the vacuum section (that rolls around behind you), or the vacuum line from the handle point to the rollaround section is not properly connected. This all assumes the vacuum motor in the rollaround is running.

The beater bar section does nothing but cause dirt particles to be sucked into the vacuum system. The vacuum or suction is created in the rollaround unit.

Jan 22, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

Beater bar works intermittently


When you push the hose into the tube, there is an acuator that will push the switch so the beater bar will turn. That switch could be just dirty, dust gets in them and they won't always work, the acuator may need to be replaced. Either that or you have a bad wire connection somewhere in the noozle or where the wires just go into the noozle asm.

Apr 13, 2008 | Kenmore 31913 Progressive Direct Drive...

Not finding what you are looking for?
Kenmore 22812 Bagged Canister Vacuum Logo

Related Topics:

138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...