Question about Logitech V20 Computer Speakers

2 Answers

No sound When I first plugged in the brand new speakers they worked fine. After two hours I lost all sound from the speakers. I unplugged the speakers and the laptop speakers work. The laptop speakers work now even with the v20 speakers plugged into the usb. The buttons on top the speaker to control windows media player all function. I am stumped and alone in Costa Rica please help.

Posted by on

2 Answers

Re: No sound

Make sure you've got your V20's set as the default sound playback device.
Control Panel -->
Sounds and Audio Devices -->
Tab 'Audio'; select 'Logitech USB Speaker' in the dropdown list in the first item on the tab.

just a thought...

Posted on Jan 01, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 138 Answers
Re: No sound

Check in your device manager that you have installed the driver successfully.
1st go to control panel
2nd click on system
3rd click on properties
4th...on device manager and select it and see the status!

Posted on Dec 08, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

My speakers were working fine and i unplugged everything to move them. When i plugged everything back in no sound. My computers speakers are working just fine but when i plug in the speakers no sound. I...

I suspect you have not plugged them back into the correct socket. The plug is coloured green and therefore should go back into the green socket. you have probably plugged it back into the blue or pink sockets. Use a torch to check that is in the green one.

May 04, 2011 | Harman Kardon SoundSticks II Computer...

1 Answer

Hello please help. These speakers were working just fine and they right over a year old. For some reason I get no sound at all anymore, and when I unplug and plug it back into the computer it detects new...

turn the power on, then unplug it to computer and touch the input, if there is no crackling sound the amplifier is defective, a technician guy like me can fix the problem

Jun 19, 2010 | Dell A215 Computer Speakers

2 Answers

Getting usb device not recognized on Bose Companion 5 multimedia speakers. I checked and the driver is the newest version. It worked fine for a week or so on a brand new HP machine running 7. Out of the...

Try re-formatting the usb flash drive. Try FAT32. If that doesn't work try NFTS. After you plug the usb drive into copmuter locate it in My Computer and right click it. Click on format.WARNING this will delete all information on the device.

Apr 04, 2010 | Bose Companion 5 Multimedia Speaker System...

1 Answer

Logitech Z-5300 subwoofer from computer to i-pod problem...

The best thing to do is to contact the manufacturers. From this i understood that your speaker system is new. You surely have the manufacturer's guarantee. So its better to contact them than to get it repaired or replaced for free. Sir please do not try to open the sub as it will void the guarantee policy.

Hope your subs come into play as soon as possible.......
All the best...

Jan 05, 2010 | Logitech Z-5300e Surround Sound System...

2 Answers

Speaker power control

If unplugging it did not stop the sound, you have invented a way of producing energy at ZERO cost -- patent the idea, and you could become a billionaire.

Oct 27, 2009 | Logitech X-230 Computer Speakers

3 Answers

Speakers Popping loudly occasionally. Died for several days. Now working again but still making sounds.

The problem is a burned transistor inside the subwoofer. It depends of country's transistor manufacturer. It is supposed to be of a low quality. It's not important for the scope. Mine is knocked down for a year. I saved the electronic schematic diagram and the transistor specs, but lost. I confirmed the cause opening the subwoofer and examine the board. The indicated transistor surrounded area is burned indeed. If anyone find the article in web, please, post here. 

May 12, 2008 | Creative Labs Inspire 6600 Computer...

2 Answers

Z-680 optical acting very strange

I bought a new cable. The old one was bad.

Mar 18, 2008 | Logitech Z-680 Computer Speakers

4 Answers

Z10 USB connection does not work

My symptoms were that the speakers stopped working all of a sudden. Display showed power but gave no access to volume adjustment and did not play sounds.

I read a vague comment by another poster and it worked!
They said to unplug it from the power plug and leave it overnight before replugging it in...... at first I dismissed this, and tried everything else to no resolution. I was ready to return the speakers but decided to unplug it and see... Bingo********! in the morning

Z-10 is now back in action.

Oct 26, 2007 | Logitech Z-10 Computer Speakers

Not finding what you are looking for?
Logitech V20 Computer Speakers Logo

Related Topics:

574 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Computer Speakers Experts

Lawrence Oravetz

Level 3 Expert

7159 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

9503 Answers

L Pfaff
L Pfaff

Level 3 Expert

11572 Answers

Are you a Logitech Computer Speaker Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides