Question about Lanzar OPTI1222D Car Subwoofer

1 Answer

My car sub wont turn on checked all the wires and they were fine and the sub was working fine in my other car right before i changed it?help please

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 53 Answers

Check the leads on the sub itself. sometimes the leads from the plugs to the coils come undone.

Posted on Sep 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Subs wont turn on


make sure there is correct wattage with the subwoofers and the power supply

Dec 07, 2013 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Hi ive got a alpine mrp-m1000 it lights up no sound was woking fine in the car didnt use car for 3 months then i wouldnt work all wires are fine and so is the sub please help


If your not getting any sound make sure the sub input is in the right spot on you radio. if not check the speaker wires on your harness

Feb 14, 2010 | Alpine MRP-M1000 Car Audio Amplifier

1 Answer

One of my subs doesnt work why?


bad conection,blown sub,try wires from the one that works on the one that doesnot if it works then the wiring is broken somwhere.

Dec 28, 2009 | Car Audio & Video

1 Answer

Alpine type-r 2ohm dual voice coil help


try reconnecting your rca's from the deck to the amp when finished wire one speaker positive to positive on left channel and negative to negative on right channel then connect the 1st subwoofer. if all power and sound is fine and working turn off power to amp and connect negative terminal of 1st sub to positive on 2nd sub and positive from first sub to negative on second crossing the wires runs the speakers in series another way to try is parralel the speakers wiring by connecting positive left channel output of amp to positive on 1st sub same with the negative then splice positive to positive on second sub and same with negative.

Feb 09, 2009 | Alpine Type-R SWR-1222D Car Subwoofer

1 Answer

My amp wont power both subs the same


you most likely mess up you wiring... im not sure what ohm resistance your subs are, but if its 2ohm or 4ohm you wire straight foreward one sub all positive wires to left positive, all negitive to left negitive, and the same with sub 2 to the right terminal. BUT if your subs are 8ohm then wire it with all positives from both subs to LEFT positive and wire all negitive wires to RIGHT negitive... and see if that helps and good luck!

Jan 12, 2009 | Pioneer TS-SWX310 Car Subwoofer

1 Answer

Subwoofer Output Not Working...


first check that the subwoofer function on the actual head unit is turned up,second check that the gain on the amp is at bout half way then check that it is on a lp (low pass setting)
then check that the boost on the amp is turned up.
please leave feedback.
cheers

Jul 02, 2008 | Eclipse CD5405

3 Answers

Kicker 750.1 Amp wont play music


it is probably the rca inputs on the amp may have fried. was your cd decked turned up loudly before the power went out? did any wires accidently touch each other? If had worked fine and then suddenly stopped, than either a wire came loose or the inputs fried. try using different cables and I also suggest disconnecting power for 24 hours and then reconnect. If the green light is on then it is getting power and the problem is in the rca cables or the inputs

Jun 03, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

What could be wrong???????


The only thing left is the wiring, and or connectors from what you are describing.

You can try another amp and another set of speakers on the same wiring to see if they work. If not, the only thing you have left is the wiring and connectors (if connectors are used).

This suggestion is valid providing that substitution equipment is not defective.

Jerry G.

May 01, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Speaker trouble


MAKE SURE NO SPEAKER WIRES ARE TOUCHIN THE OTHER, IF DONT WORK.. YOU WILL NEED TO TOUCH TWO WIRE AT A TIME, DID YOU HEAR SOUND BE4 INSTALLING

Mar 25, 2008 | Car Audio & Video

Not finding what you are looking for?
Lanzar OPTI1222D Car Subwoofer Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Joe Alexander
Joe Alexander

Level 2 Expert

65 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...