Question about ATI RADEON X1600 Pro 512MB AGP Graphic Card

1 Answer

Broken Component on ATI RADEON x1600 PRO 512Mb AGP card

The inital connector that links the card to the power supply on computer is broken and was wondering if their was any way to fix it/have someone fix it.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 67 Answers
Re: Broken Component on ATI RADEON x1600 PRO 512Mb AGP...

If its a bent pin you can bend it back make sure you discharge yourself & pliers when you do this.If its completely missing you have to get it replace or solder on a pin if you have it .

Posted on Dec 10, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have an ATI Radeon x1600 Pro 512 Mb. I am installing into a computer that I am reformatting and installing windows xp. When I get to the windows install screen it begins to examine the PC hardware...

One bad lead can cause a computer to continue on a cycle or to shutdown or fail to detect your hard drive

Test all leads that attach to your hard drive including electrical extensions,IDE,SATA

the leads from your ((motherboard to your hard drive)) make sure they have a secure connection and are not faulty or just replace them there probably old and faulty
make sure all leads that are attached to your drives dvd\cd 3 1/2 inch floppy have secure connections and are not faulty even the electic extensions or just replace them they are probably old and faulty a computer needs its connections to have an end so any faulty leads will end up with a computer error

hope this helps

Feb 12, 2011 | ATI RADEON X1600 Pro 512MB AGP Graphic...

1 Answer

Motherboard doesn't recognize new video card.

do you have an nvidia motherboard? this may be the cause of it.

Dec 09, 2009 | Sapphire ATI RADEON X1600Pro 512MB...

1 Answer

ATI Radeon x1600 Pro unstable in Dell XPS desktop

If you have the latest drivers installed, try uninstalling them, and going back to the 2nd most recent driver released. Sometimes the latest drivers have issues. Work your way back trying multiple drivers if possible until you find the sweet spot. You might try this website, it has a driver cleaner that removes old drivers. Then try reinstalling the driver of your choice.

Sep 02, 2009 | ATI RADEON X1600 Pro 512MB AGP Graphic...

1 Answer

Card works in vga mode before installing 9-3_1_legacy_xp32-64_dd_ccc.exe After installing, video fails; displays only distorted flickering lines.

Restart your computer.
Tap on "Delete" until the BIOS comes up.
Look for an option for "VGA mode", as I wouldn't know what your BIOS is, you'll need to look carefully.
When you find it, shut it off, save your options then restart computer.
Comment if this didn't work, I can help you further.
If this helped, please vote and have a good week!

Jul 16, 2009 | ATI RADEON X1600 Pro 512MB AGP Graphic...

1 Answer


Reinstall. Go to and select the driver for your operating system. They use a one driver for all cards approach

Apr 26, 2009 | ATI RADEON X1600 Pro 512MB AGP Graphic...

2 Answers

Old Geforce 7300 works fine on Windows XP, when I insert Ati x1600, the motherboard fan turns for two seconds, then stops, the system will not boot. I have a 400W power supply, even though the ATI X1600...

1-go into safe mood and verify that the card is recognized
2-if you cant enter safe mood for some reason use ati flash just type atiflash -i
3-if you cant boot at all then try using a pci card and check for the cards status

either your power supply is faulty or something in the bios maybe should give more info

Apr 01, 2009 | ATI RADEON X1600 Pro 512MB AGP Graphic...

1 Answer


Hi Matt,

Check out

While they are not the 'offical' drivers, many people have gotten improved performance or fixes.

Its worth a shot!

Oct 16, 2008 | ATI RADEON X1600 Pro 512MB AGP Graphic...

1 Answer

ATI x1650 Pro Stops!?

the card you have is a PCI express 16X your board is for PCI express 8X. I think some cards can run at a slower speed but I believe you have the wrong card for your board

Jul 29, 2008 | ATI RADEON X1650 Graphic Card

Not finding what you are looking for?
Graphics Cards Logo

Related Topics:

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top ATI Graphics Cards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers


Level 3 Expert

5660 Answers


Level 3 Expert

2598 Answers

Are you an ATI Graphics Card Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides