Question about Onkyo TX-SR606 Receiver

19 Answers

Onkyo 606 doesnt show video anymore fom ps3 over hdmi

Ive had my onkyo for over a year and recently when i switch to my ps3 it shows no signal and my sat is hooked up hdmi and it works fine. if i plug my ps3 into my tv it works fine but once i plug in the receiver nothing. but sometimes if i let it sit 10 or 15 minutes it will all of a sudden work. ive swithced cables, inputs, i only have this problem with my ps3. sometimes i only get audio sometimes nothing then once in a great while it just comes on. my osd used to work over hdmi now it dont. ive tried switching it to passthrough(thinking thats basically like hooking it directly to my tv)but still nothing. ive gone through all the settings on my ps3 thinking that was the problem but still nothing. can anyone help? please!

Posted by on

×

19 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I've got exactly the same problem described by cccandme and the unplug for an hour/Master Reset Solution posted by dustywadham did not work for me. Everything was working great for about a year, and then I started having issues with the PS3 connection.
What's weird is that sometimes it will start right up, and other times it may take ten to fifteen minutes to acquire a signal. It seems as if something has gone haywire on the Onkyo, but I don't know what it is. From looking around the web, it appears as if quite a few people are starting to have problems with the TX-SR606 and their PS3 connection, and I wonder how someone could make Onkyo aware of this.

Posted on Nov 05, 2009

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

I hate to say it i got the same problem and the only way i sorted was a master reset which means u have to do all the set up again and asign all the hdmi again but since i done that no problems to do this un plug the lot for an hour reconnect everything then push and hold the vcr button and push stand by a message will say clear on the receiver then it is back to when u frist got it out th box hope this helps

Posted on Sep 04, 2009

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Had exactly the same problem after one year without problems, every source that was not hdmi (Wii, Setup Menu) was not displayed anymore while HDMI sources (PS3, Sat) were. Did the clear process (VCR+Standby) and reprogrammed everything. Now it's working fine.

Posted on Dec 24, 2009

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Same problem here! I have a ps3 & xbox360, both via HDMI to a Onkyo 606, then via HDMI to a Samsung 650 52" set. Worked great for 4 months, then I had trouble getting a signal when I switched from HD cable box to ps3. It got worse and worse, then I got no signal everytime I turned the reciever on. Now it is so bad, 11 months later, that I can spend 30-45 minutes switching everything on and off in order to get a signal. This morning I gave up and connected directly to the Samsung LCD, bypassing the Onkyo altogether. Works great. I'm gonna have to buy an optical cable to use the Onkyo 7.1 system, and deal with the disadvantages of optical cable rather than HDMI. This sucks, and when I did the Master Reset on the Onkyo everything just got worse.

Posted on Nov 30, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hi!
I had the same problem with the PS3 and the Onkyo 606.
Today I send it for repair...
Onkyo??? Never again

Posted on Sep 03, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Same issue here.

I have the Onkyo AVR with a custom build media center (outputting via HDMI - i.e. no DVI to HDMI conversion) and a Panasonic BD30 connected to it.

Both the BluRay and Media Center work fine when connected direct to the TV and everything used to work fine. But after about a year I'm getting the same issue - TV shows no signal. OSD sometimes doesn't appear.

Interestingly my TV is also a Samsung which is mentioned quite a bit by you lot. Its the LE40M86DB in this case.

I've done resets galore, but the only way I can get it to work is switching on and off either the TV and/or AVR several times. Eventually it will work.

Posted on Nov 30, 2009

  • 1 more comment 
  • coolbeans29 Aug 29, 2010

    Hi,

    I too have had this problem with the reciever(Onkyo 606) needing to warm up for 10 mins or so(no fix for that one) but regarding the PS3 issue I have the solution(hopefully)!!

    The reciever can only upscale to 1080i not 1080p, this is normally ok with a 1080p source like a Blu-Ray player because the handshake over HDMI normally resolves any problems with resolution. Unfortunately the PS3 does not work this out with a device between itself and the TV on some occasions.

    The answer, set the PS3 output resolution to 1080i and bingo it should appear fine through the reciever.

    Would be good to know what happens out there with this one,

    Coolbeans

  • sheldonsweat Jan 26, 2011

    where exactly did you find this setting, I can't see an option to select output resolution on my ps3 settings menu

    sheldon_sweat@yahoo.com

  • pcsomb Jan 22, 2012

    Thank you. I almost but gave up on fixing my ps3 problem. Removing the 1080p output from my ps3 fixed my issue with my onkyo receiver in which I get no signal. I recommend this solution to anyone who is getting no signal through their receiver. I can't tell the difference anyway between 1080p and 1080i.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I found this answer on a review of the receiver through Amazon but it worked perfect. All you need to do is go into the video setup and turn off the Deep Color option and it will work great.
Good Luck

Posted on Aug 16, 2012

  • Ryan Rigby Aug 16, 2012

    Sorry just to clarify that you turn this feature off on the PS3. This also keeps you from having to adjust the resolution down to 1080i

×

  • Level 1:

    An expert who has achieved level 1.

    Governor:

    An expert whose answer got voted for 20 times.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 9 Answers

Http://www.youtube.com/watch?v=gj0x5S9ez5U

do this for about $10

pretty good success rate

Posted on May 27, 2011

  • Onkyo USA Apr 17, 2015

    Please contact our Parts & Services Dept via fax 201-934-7823 or email (parts@us.onkyo.com) at the number listed below during normal business hours Monday-Friday 9am-5pm EST. You will need to provide the following information: Name, address, contact info (telephone number/ email address); along with copy of sales receipt, model number, serial number; and full description of issue(s) of your TX-SR606/ HT-R 667 receiver. Note: if you do not have your sales receipt; please provide information on date and dealer of purchase for your TX-SR606/ HT-R 667 receiver. Your correspondence will be reviewed and handled by the Parts & Services representative who will contact you regarding your issue.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Same PS3 through HDMI problem, same SR-606 receiver. I could get video from my PS3 but only if I dropped the resolution to 480p. I am going to call Onkyo tomorrow and see what they say.

Posted on Mar 28, 2011

  • Wonderfred Apr 08, 2011

    I did get my PS3 to display through the receiver with the resolution turned down to 1080i.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I originally did this as a work around for what turned out to definitely be a faulty HDMI card in the reciever and it worked well, you need to go(on the PS3) Settings then scroll down to Display Settings and walk through the setup to change resolution. These excellent recievers unfortunately have a habit of cooking themselves slowly but Onkyo were kind enough to have a standard "2 year" warranty and when I finally contacted the reseller was simply asked to drop it back and they will call when its mended and back, it took 6 days!! I was so chuffed, especially when I discovered that Onkyo won't let retailers perform warranty repairs and make them send all units back to an official Onkyo repairer. The work is perfect and the reciever is like new, as far as I can tell they changed the HDMI daughter card and re-flashed the firmware and so far no issues. I would however recommend NOT covering the top of the reciever at all to allow heat to dissipate.

Posted on Jan 26, 2011

  • coolbeans29 Jan 26, 2011

    I originally did this as a work around for what turned out to definitely be a faulty HDMI card in the reciever and it worked well, you need to go to(on the PS3) Settings then scroll down to Display Settings and walk through the setup to change resolution. These excellent recievers unfortunately have a habit of cooking themselves slowly but Onkyo were kind enough to have a standard "2 year" warranty and when I finally contacted the reseller was simply asked to drop it back and they will call when its mended and back, it took 6 days!! I was so chuffed, especially when I discovered that Onkyo won't let retailers perform warranty repairs and make them send all units back to an official Onkyo repairer. The work is perfect and the reciever is like new, as far as I can tell they changed the HDMI daughter card and re-flashed the firmware and so far no issues. I would however recommend NOT covering the top of the reciever at all to allow heat to dissipate, normally you would not need to tweak the PS3 resolution settings but it helped when mine was misbehaving.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have this same exact problem- I have the Onkyo TX-SR606 and it worked fine with a ps3 for just over a year, then it started to have video problems but would work sometimes, now video won't work at all. Cable works fine with hdmi, and the ps3 works if I connect it direct to the tv. I'll try to contact Onkyo. If they won't fix or replace it I'll be contacting the MA Attorney General

Posted on Jan 09, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Having the same problem but without gaming systems. Worked perfectly for over a year, suddently three different DVD or Blu-Ray players SOMETIMES can't send video, sometimes audio, sometimes neither through receiver. Yet through it all, high def DVR/Sat works fine, never an issue.

Sounds like it is time to switch brands entirely.

Posted on Jan 04, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It's nice to see that this is a problem alot of 606 owners are experiencing with the HDMI Throughput.

My Setup: PS3, XBOX 360 Elite, Comcast Cable HD DVR via HDMI...

It seems like the 606 needs to warm up to properly HDMI Handshake with my 360 *& PS3....

How I get it to work is I start up the COMCAST CABLE Box 1st.....and set it to a SD Channel....this gets the video started.

After a couple minutes I switch to an HD Cable channel and the unit handshakes.

After about 20 min....I switch to the XBOX 360 or PS3 feed......

There has to be something wrong with the chipset for all of us to start experiencing problems with the 606 almost the exact times after purchase.


Posted on Dec 23, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I started having this issue a couple of months ago, but with a little patience (would watch satellite TV for a while) then I would switch to my input where my PS3 was assigned.

Now the problem escalated to the point where now I have to connect the PS3 directly to my TV (LG70) in order to see an image. I tried resetting the display setup (by holding the power button for a couple more seconds once it has turned on) and re running the setup connected directly to my TV. Once the setup had finished I reconnected to my Onkyo Rx (TX-SR606) and it worked, only once, though.

I have called Onkyo and a rude representative told me, and I quote, "Connecting the PS3 through the AVR is NOT the same as going straight to the TV, disable your 24Hz movie mode and try again. If that doesn't work contact one of our service centers along with your reciept so they can have a look at it." (click).

I am in the process of contacting one of these service centers and I will have to wait and see what happens.

Posted on Dec 09, 2009

  • miggystyle Dec 09, 2009

    Just to clarify. The display setup I reset was the one on my PS3. The only thing I enabled was 1080p output and nothing more.



    I tried this fix again and it did not work. The PS3 won't even display an image on my TV (forgot to specify my model: 52" LG70) with the PS3 outputting 480p via the HDMI port.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I am having this problem with a Samsung LN52A5402FXZA and a PS3 when running it through my Onkyo HT-S9100THX. I have done the reset on the receiver, have unplugged and plugged back in the hdmi cables, etc. I have to turn on everything, and then turn the onkyo on and off over and over to eventually get a picture, and it seems to be getting worse every day. Onkyo told me I was responsible for sending it in to their 3rd part repair center, and it could take up to a month in limbo to get it back. I am thinking about trying a new hdmi cable before resorting to this, just to make sure it isn't a faulty one....

Posted on Aug 05, 2010

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 5 Answers

I have the same receiver with an xbox 360. To correct the problem, I disabled the Display Discovery feature on the xbox 360.

Posted on Feb 12, 2010

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I've tried the vcr + stby button but did not work. I'll give the 1hr and then button sequence to see if that works. Mine just did it for the first time the other day. Then it worked fine. Now it has just gone out again. I wonder if there is a chip defect.... Mine is on a Samsung LCD tv as well. 46in 6 series if that helps any. Could try to figure out if its all tvs or just a few select brands.

Posted on Nov 26, 2009

  • loonyme2003 Nov 26, 2009

    I've tried the vcr + stby button but did not work. I'll give the 1hr
    and then button sequence to see if that works. Mine just did it for
    the first time the other day. Then it worked fine. Now it has just
    gone out again. I wonder if there is a chip defect.... Mine is on a
    Samsung LCD tv as well. 46in 6 series if that helps any. Could try to
    figure out if its all tvs or just a few select brands.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same issue with XBOX (Component) and MacMini (HDMI). It all worked fine for few months and suddenly no video signal (when on XBOX - I see a black screen and on MacMini - just snow or video in a very poor quality). Audio is fine and usually, if I wait enough or turn off and on enough times, I get the video signal back.

Posted on Nov 16, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have the same issue with the WII component or composite outputs. Audio works but no video. Tried the CLEAR (VCR + Standby). Same issue. Other symptom the OSD Menu doesn't work when WII not working. OSD should work, its only connected HDMI to TV.

How about the TV interface causing the DSP not to scale or pass through correctly? Mines a Samsung HL61A750A1F.

Posted on Nov 15, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to fix the HDMI board on Onkyo TX-SR608


If you look on the internet HDMI board failure on these Onkyo's seems quite a regular occurence.

Time to scrap the Onkyo and buy something with a better name - like Yamaha, Denon or Marantz.

Dec 12, 2011 | Onkyo TX-SR608 Receiver

1 Answer

I have an Onkyo HT-S6100 home theater not sending picture to TV.


I just fixed mine with the same problem. Apparently, the HT-R667 and 606 receiver that comes with 6100 has a problem with the HDMI board. Onkyo wanted $500 dollars to fix it, costed me $16. Here's how to fix it. http://www.highdefforum.com/high-definition-receivers-recorders-players-tivos/121956-repairing-onkyo-htr667-aka-606-a.html
and the youtube vid: http://www.youtube.com/watch?v=gj0x5S9ez5U
Good Luck!

Apr 04, 2010 | Onkyo TX-SR605 Receiver

1 Answer

TV not receiving video signal from DVD. Component video setup from DVD player to SR-606; DVD input assigned to IN1; TV receiving TV signal routed through same HDMI working OK. Was working OK once. Didn't...


This model has a defective hdmi pcb assy. this is a well know defect with this model.If under warrenty have hdmi bd replaced if not the hdmi pcb assy retails around $350.00

Mar 28, 2010 | Onkyo TX-SR606 Receiver

1 Answer

My ps3 wont show on my tv anymore. what do i do?


not to worry it is very simple

1. if u are using hdmi port and it is connected to hdmi in your tv

setting might have been changed

1. take out ur nomal av output wire which is given by sony , plug it on to a normal tv (rgb) now u can see the display (if not try mannual swithch off the ps3 and on for 3 to 4 times) u will get the display
2. now go to settings (video settings) there is a option called video output u can change it to AUTOMATIC

3.NOW COME OUT of it and switch off

4. now pug into ur hdmi port it will work

Mar 15, 2010 | Sony Playstation 3 (PS3) Console

1 Answer

Onkyo tx-sr 606 HDMI signals not working anymore...


I am sorry about your issue,. If the reset did not resolve your issue the receiver would need to be serviced. It if was purchased from an authorized seller less than 2 years ago it would be under warranty. Thank you. Onkyo USA

Mar 09, 2017 | Onkyo TX-SR606 Receiver

2 Answers

Upscale from 480p Signal via HDMI


ok the problem might not be with your receiver it is with your direct tv settings. Double check to make sure you go to the format and set it up to be fixed or 1080i whichever will give you the highest resolution. Check your manual for the direct tv receiver. If this is all correct for the DTV then you must go into the setup on the receiver and at hardware icon toward bottom check on that box, now goto the hdmi settings and make sure it is set to through. this will allow the best picture with no upscaling which will degregade picture for blu ray. so your direct tv will be only 1080i but very impressive. if you still want to upscale you can then you have to change the hdmi settings from before to upscale 1080p . I just hope that your dtv can output 1080i it will give a better picture than 480p even if both are upscaled to 1080p
Oh i forgot to ask if you are connected through hdmi to the tv. Hdmi is the only option for upscaling

Feb 21, 2009 | Onkyo TX-SR606 Receiver

1 Answer

Freezing and No signal


PS3 is one of the most amazing gaming device but like other competitor gaming devices (Xbox and Wii) It also has some problems like Freezing up. You may check out the informative Article at ezinearticles Remedy for PS3 Freezing up

Oct 18, 2008 | Sony Playstation 3 (PS3) Console

2 Answers

PS3 - tv says no signal


You need to change the resolution output on your PS3 to match the capabilities of your TV. If your TV is not HD you can't leave the PS3's video output on HD. SCART is for european television connections. Have you tried using component cables? Have you tried changing your tv's source to Video 1 or Component 1 or HDMI or anything that might work? Good luck!!

Sep 30, 2008 | Sony Playstation 3 (PS3) Console

1 Answer

Ps3 defaults to 576p when connected through onkyo 606 receiver


You have to tell the PS3 what the Okyo can do and it probably cannot do 1080P 60Hz (but can likely do 1080P 24Hz).  Try ticking more resolutions in the PS3s setup

Jun 22, 2008 | Audio Players & Recorders

2 Answers

HDMI SOUND


True HD can only work with HDMI interface and is only available on some newer HD DVDs. Check the DVD to see if the True HD encoding is available.

Feb 11, 2008 | Onkyo TX-SR605 Receiver

Not finding what you are looking for?
Onkyo TX-SR606 Receiver Logo

6,976 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5020 Answers

The Knight
The Knight

Level 3 Expert

73698 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

Are you an Onkyo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...