Question about Marantz SR-18EX Receiver

1 Answer

No sound on SR18

I heard a pop from the amp and then there was nomore sound. All controls work fine and there are lights on at the amplifier.


Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

One of your five amplifiers has blown its output transistors. Unfortuately, with SR18s, many components down the line from the outputs get fried as well, and (in my experience, anyway) it usually takes hours to track down all the problems. You can still use the unit as a preamp/tuner/surround processor by taking signal out at the pre-out jacks (you have to remove the five jumpers), and feeding it into external power amps, but repairs to the SR18's amp are probably going to be costly and complex. Sorry about the crummy news - hopefully I'm wrong!

Posted on Oct 18, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sony XM-1600GSD have low amps on middel fues and wont work


You are in over your head with this. There is only one fuse on the outside and it is the main power fuse. When you hook something like this amp to a power source for conversion from 110 there is a ripple current. The more the Sony pulls out of the converter, the higher the ripple current came be. That ripple can cause failure of other parts in the amplifier. Since you heard a pop sound. It is apparent that the components in the amplifier have failed. You are going to have to disassemble it and look for damage. Then you need to find that parts that are blown and then you need to be able to solder and replace them.

Nov 12, 2017 | Sony XM-1600GSD Car Audio Amplifier

1 Answer

I have a Sony Xplod 800w Amp running a 10' Sony Xplod Amp....i unhooked the amp to do some moving and i tried to put it back in today and it didnt have any sound coming from it! I did notice the power...


it sounds like it could be a blown channel in the amp. if the sub was blown it would still work just sound horrible. i have blown many subs and amps. you can bring it to an audio shop near you and they can fix it. i just got one of my channels fixed for 35$

May 11, 2011 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

1 Answer

I have a 2005 Maxima, the other day I heard a pop sound and my bose stereo system (the sound) stopped working. My son replace the AMP but still no sound. Everything else is still working, ie the display...


did you mean that the output was replaced or the whole amplifier?
The pop sound along with the sound loss can be attributed to a failure of a component , most possible is a capacitor when the aluminium top bursts. So open the amplifierr to look for pieces of the component that burst out and you can piece up them to confirm.
The powerr to the section can also be faulty or open due to this so the voltage must be checked to be in order.
The possible area can be the power supply circuit or the output of the amplifier.
Test from the power supply section down to see the power into the preamp and power amplifier output section. make sure that the input selectors are also working in the command of the main controller.
Checck only with some knowledge of these circuits otherwise take help.

Aug 31, 2010 | Bose Wave Music System Remote

1 Answer

I have a ADF-242 that is having sound output problems


If the car was running when testing sub and heard noise this could be engine noise and an inline filter would cure that problem and also have a good ground no more than 15 inches away from the amp.And good metal contact for ground.

Jun 06, 2010 | Audiofonics ADF-242 Car Audio Amplifier

1 Answer

Hooked up the amp, lights up, fans kick on and run fine, speakers hooked up proper, no sound? hooked up speakers to another amp and they work fine. Fuses are all good too. Thoughts?


could be bad rca cables or no output from the radio rca outputs. the sub control may be turned off on the radio (ive seen that alot at my work). if all that is fine, the amplifier may be bad. the rca cables may be plugged into the "out" section of the amp. gotta look at all the small obvious things first. good luck.

Dec 18, 2009 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

Moisture in amp while on, caused a small pop, then no sound outpu


check the fuse between the battery and the amp. (not the fuse in the back of the amp).
if that doesn't work then something on the inside of the amp is fried.

Jan 30, 2009 | Phoenix Gold Xenon-200.4 Car Audio...

1 Answer

AudioBahn A2300HCT no sound


Generally, if the amplifier smokes, the power supply FETs have failed.

Many times, the output transistors fail and that causes the power supply FETs to fail.

Audiobahn won't release schematics. The amplifiers are relatively simple and a schematic isn't generally required.

If you know how to check the transistors, check them to determine the severity of the damage. If you don't know how to check them, read through the following page following all links provided.

Basic Amplifier Repair

Let me know if you have any other questions.

Sep 04, 2008 | AudioBahn A2300HCT Car Audio Amplifier

1 Answer

I need help, please!


you have just popped your speaker or the speaker has disconnected from the voicecoil or just burned out you might have over loaded it!

Aug 13, 2008 | AudioBahn A8000V 400W x 1 Car Amplifier...

2 Answers

Rampage amplifier


The amp is supposed to turn on and off with the head unit. The remote wire on the amp should be connected t othe amp control/power antenna wire of the head unit.

The pop should go away when the remote is being switched on with the head unit.

If the amp is staying on with the key removed, it will drain your battery. You need to re-wire it so you don't get stranded.

Nov 29, 2007 | Audiovox Rampage 1200 Watt Amplifier Car...

Not finding what you are looking for?
Marantz SR-18EX Receiver Logo

321 people viewed this question

Ask a Question

Usually answered in minutes!

Top Marantz Audio Players & Recorders Experts

The Knight
The Knight

Level 3 Expert

74383 Answers

 Grubhead
Grubhead

Level 3 Expert

5158 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Marantz Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...