Question about Sony Grand WEGA KDF-60XS955 60" Rear Projection HDTV

4 Answers

KDF-E60A20 Going on and off by itself..no blinking lights

My Sony WEGA 60 inch keeps losing picture (black) and audio about every 15 seconds then comes right back on for about for about 5 seconds before shuting down again. No blinking lights the green power light stays a steady green. Repeats this process over and over. Looked through all troubleshooting ideas and don't see anything for this. Any ideas? Please help!

Posted by on

  • 6 more comments 
  • Rinab Dec 15, 2007

    I have the same problem, Tv just over a year old and every two minutes it goes off and after about a minute comes back on. Doe's anyone have an answers to this problem?

  • btag Dec 17, 2007

    I have the same problem. My TV is 18 months old with normal usage. It tries to turn on and you can hear sound and see the beginnings of a picture. Then It shuts down. After a few minutes, it repeats the process. Sometimes I will hear a louder than normal fan sound for several seconds. Sometimes the red light will blink in 5X intervals. Any advice out here?

  • gloghe Dec 20, 2007

    the tv is goin on &of about10 sec

  • rwrose Dec 31, 2007

    i have the same problem. tv is 2.5 yrs. old . sony only offered the closest sony repair serviceman. lamp driver was the diagnosis over the phone. lamp, driver and service call. $723.00 what a ripoff on a $3800. tv.

  • Anonymous Aug 05, 2008

    same problem

  • Anonymous Aug 13, 2008

    I'm having the same problem. At first the tv shut on and off only once or twice a week. Now it's is turning off every 5 minutes or so. I'll try and replace the bulb. Hope that works!

  • mteeden Oct 11, 2008

    I have the same problem.  Took it to #$% electronics 85$ to diagnostic text and now the want to replace bulb and balast.... don't know what balast does but I feel like they are trying to rape me... mainly because the fault indicator light never showed a fault.  Does anybody else have knowledge of the balast assy replacement causing the the exact fault: video and sound cycling off continuously every 15 sec or so...  I dont want to give these guys my money but I dont know enough about this TV except SONY auth. them to repair their tvs on the website.

  • Anonymous Jan 06, 2009

    I HAD THE SAME PROBLEM AND MRSONY TOLD ME TO REPLACE THE LAMP. IT IS OVERHEATING AND SHUTTING DOWN THE TV, THEN WHEN IT COOLS A FEW SECONDS I POWERS BACK UP TO OVERHEAT AND THEN SHUT DOWN. I REPLACED MY LAMP AND ITS BEEN FINE EVER SINCE.

×

Ad

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

It works!! First i took off the front panel. Just check your manual for instructions, very easy to do. If you do not have a manual just down load one from google.. The instruction are easy to follow. The screw they have you loosen with a alan wrench is attached to the plastic, so you do not have to worry about dropping it inside the tv. Removing the lamp was simple. once out you will notice on either side are two small mesh screens. One of mine was 80% blocked with dust, the other side was only 30-40% covered. I used a vacuum to remove the blockage, i did not want the dust and dirt to go inside the bulb. i then cleaned all around the lamp. Reinstalled, and we are go to go. The kids are happy and i am happier since my wife not be buying a new TV.
total cost of repair $.00
time required to fix, less than 15 minutes.

Also when my TV was loosing sound and picture and then return. I did turn off my TV, then turned on. I nothiced a red blinking light. Mine flashed 5 times. After some reserch, 5 times is video related, bulb or video board. google red flashing light with the model you have and you will find what all the codes mean.
So if yours is flashing 5 times try the above, it might work for you and it is well worth the time before you call a tech and drops hundreds of dollars.

hope this helps.

Posted on Oct 10, 2008

  • Dave D Dec 05, 2010

    Check out the class action lawsuits for defective Sony TV. Many models over the past 8 years with the same problem. Do some google search about your model and other similar Sony models with the blue spot and blue smudges on the left side of the screen and at the bottom. Sony is giving free TV's and/or greatly reduced prices for a new model. But hurry as many of the class action lawsuits have already expired.
    http://www.facebook.com/pages/I-Have-a-D...

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

My sony wega kdf-e60a20 had exactly the same problem 2mins on 2mins off no flashing red light just the normal green. I suspected a power supply problem. After some research I bought a new lamp for it (even though I was sceptical that this would work) It is extremely easy to change the only tool you need is an allen key wrench (for 1 of the 4 fasteners) Anyway it worked a charm and I realized my picture had been gradually dimming for some time. Haven't had a problem since and the picture is much brighter.

Posted on Oct 23, 2008

  • coolplexer Oct 23, 2008

    I got a new lamp on ebay for $115 by the way just before it went 2mins on 2 mins off it would just switch off briefly about every hour if you see these symptoms this maybe your solution too.

×

Ad

Our KDF E60A20 was turning off and on all by itself also.
It did it at 30 second intervals with both sound and picture. By replacing the bulb, we got our TV back to new. I never would have believed that the bulb could have dimmed as much as it had, or that it could have created the problem we were having. The TV is BRIGHT and CRISP, like when it was new. Our experence is that these lamps WILL dim before they go out and make the TV cycle on and off. $225.00 for a lamp makes us all try to second guess, i think.......... We were happy that the problem was no deeper than that

Posted on Jan 04, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 4,402 Answers

2004 Grand WEGA models: blue spots, blobs, haze, or star pattern
On June 23, 2007, Sony issued an Additional Service Coverage on the optical block of its 2004 Grand WEGA models (KF and KDF): KDF-42WE655, KDF-50WE655, KDF-55WF655, KDF-60WF655, KDF-55XS955, KDF-60XS955, KF-42WE620, and KF-50WE620. This coverage is based on what Sony describes as a "blue dot" or "blue star" pattern (also called "blue haze," "blue blob," and other names by some owners). Sony has posted sample pictures of the blue spot problem at the above link. One of them is from my TV (see pictures below). The location and intensity of the blue anomalies can change, tending to get progressively worse. Some users have reported that, over time, increasing numbers of bright blue or white spots appear within the anomalies, which presumably represent pixels stuck in an "activated" state. Colors other than blue have also been reported. The additional service coverage is good through December 31, 2008 regardless of the original purchase date, and owners who have already had their TVs repaired at their own expense will be reimbursed. The page linked above contains links to instructions and a claim form.
http://splinke.googlepages.com/sonyrearprojectionlcdtv-opticalblock

Posted on Dec 05, 2007

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Picture and sound come and go on antenna or dvd


Try another lamp. Error 5 is Lamp power supply, but its usually always the lamp bad.

Mar 27, 2014 | Sony Grand WEGA KF60WE610 60" Rear...

1 Answer

I have a sony 60" wega lcd rear projection. it has been losing picture, going black yet power stays on then 5 blinking lights. turn off then back on and comes up and shows picture like there is nothing...


5 blinks means that the system has detected a faulty or error on chroma board ( often called as C board)..You need a Qualified and well trained service technician to fix the problem.. Some times a reset on 3 LCD connectors solve this type of trouble..

Aug 23, 2010 | Sony Grand WEGA KDF-42WE655 42" Rear...

1 Answer

Sony Grand Wega KDS-R60XBR1


yOU SHOULD HAVE 2 MORE SETTINGS ZOOM AND EXTENDED ZOOM THIS SHOULD FILL OUT YOUR SCREEN, THE REASON FOR THE SMALLER PICTURE WHEN IN REGULAR CABLE IS BECAUSE IT IS SENT IN 4X3 FORMAT INSTEAD OF 16X9.

Nov 22, 2009 | Sony Grand WEGA KDF-60XS955 60" Rear...

1 Answer

I have the sony wega 60 lcd tv, it turns on ok then shuts off


How long have you had the set? If its been at least two years then its time for a new lamp.

Thanks
you can email me at Delhielectronics@live.com
if you need futher assistance. I believe your lamp is faulty...

Sep 26, 2009 | Sony Grand WEGA KDF-60XS955 60" Rear...

2 Answers

Sony 60" Grand Wega has Picture go BLACK and NO SOUNDS!!!


My Sony Wega KDF-55XS955 55" was going on for 1-2 minutes then going black with no sound and after a few minutes would come back on. After reading all the posts and talking with a repair guy I replaced the bulb and that fixed the problem.

Aug 24, 2009 | Sony Grand WEGA KDF-55XS955 55" Rear...

1 Answer

Pictures goes black while power light blinks green


I have a 40 but i was having the same problem. It turned out to be my lamp. I got a brand new lamp from Projector Lamp Services (relampit.com) and my tv works fine now. Im pretty sure that the 40 and the 60 take the same lamp. You might want to give them a call.

Jan 05, 2009 | Sony Grand WEGA KF60XBR800 60" Rear...

2 Answers

My Sony comes on then both sound and picture goes black.


After being on a little while, the screen goes black (no audio as well) for 20 to 30 seconds. Green light stays on. Then, picture comes back on and takes a couple of seconds to get up to full brightness. About 5 seconds or so after the video comes back, the audio returns.

Until this morning, has only happened a couple of times a day, now happening more often. About 3 times in last 20 minutes.

KDF-E55A20 is about 3 years old.

May 03, 2008 | Sony Grand WEGA KDF-55XS955 55" Rear...

4 Answers

TV Picture Goes Black


I had the same exact problem.
I removed the bulb and cleaned it. There is a small screen at the top of the bulb and it was covered with dust. Once it was cleaned I replaced the bulb and it solved the problem.
Thanks to those who posted the solutions

Jul 28, 2007 | Sony Grand WEGA KDF-60WF655 60" Rear...

Not finding what you are looking for?
Sony Grand WEGA KDF-60XS955 60" Rear Projection HDTV Logo

3,556 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Televison & Video Experts

The Knight
The Knight

Level 3 Expert

75767 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Jerry Greenberg
Jerry Greenberg

Level 3 Expert

1689 Answers

Are you a Sony Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...