Question about Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Well i need help with my amp./

I have a Sony Xplod 600 watt amp and a sony cd player and it dosent have the rca hookup in the back of cd player what should i do?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers
Re: Well i need help with my amp./

If the amplifier doesn't have speaker level inputs, you will need to use a Line Output Converter (LOC) to convert the speaker level signal to a preamp level signal.

Posted on Dec 04, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have two sony xplod 12" speakers wich can hold

You only gave us the model of the amp so I will make an assumption that your 12" subs are the Sony XS-GTX120LW. First, they cannot hold 1200 watts a piece. They are meant to be powered with 350 watts RMS. They will hold 1200 watts peak. That means that 1200 watts for a few seconds will be ok. Past that and kiss them goodbye!

Next you indicated that bridged the amp. Since the subs are both 4 ohm single voice coils did you wire them in series or parallel?

It sounds to me like you wired them in parallel resulting in the amp seeing a 2 ohm load. The amp you referenced is only stable when bridged at 4 ohms.

Has the amp begun working again once it cooled down? If not you could have fried the outputs by having the resistance too low.

Dec 21, 2010 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

I Have a Sony Xplod 800 watt amp and 2 12 inch Sony Xplod subs

You should definately bridge them. Firstly, lay the 2 speakers face down next to each other. Note the connections +- +-. The first + will go to the amplifier. The next terminal(-) will be connected to the next speaker(+). Take the last(-) and connect to amplifier. Please note that your amplifier has a bridge section which is normally the first + and the last- on the two channels. Connect your woofers on the bridge.

May 28, 2010 | Sony XM-ZR1252 Car Audio Amplifier

2 Answers

My sony xplod 1200 whatt amps red light keeps coming on all the wires are good when it gos to hit it gos red

check your ohm load on the sub and see if your amp can do the same, That is why every time it shuts off into protection mode. Check your gain level on the amp to this is not a volume knob for your amp, It is to get both the amp and cd player on the same page. Hope this was helpfull

May 19, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

My amp is not putting out all the watts

sorry to tale you, but my opinion SONY just SUCKS... as you can tell. Might wanna upgrade your amp. I have had no luck with sony. Try audiobahn, mmat, ppi, mcintosh, zappco, orion, rockford. THESE are a lot better amp to go with by far. But thier is a lot better brands out thier that just knocks sony in the dirt. my favorite happens to be the audiobahn A2300HCX aka cheater amp. NICE AMPS. it also depends on what kind of subs you got to

May 11, 2010 | Sony Car Amplifiers

1 Answer

I just got a 600 watt sony xplod amp with a 10 inch xplod sub and it keeps turning off i thought i blew it but it went back on im confused

Could be overheating or a bad ground. Could also be a cracked tube or other internal part, that is expanding under heat and failing out.

Apr 07, 2010 | Sony XM-1502SX Car Audio Amplifier

1 Answer


I had the same problem as you. The problem is the wiring from your speakers to your amp TRIPLE check your wiring. Make sure that none of them got disconnected or connected to the wrong wire.

Mar 30, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Hi i have a 600 watt sony xplod amp model xm-554zr and it recently stopped working. when i turn my car on the amp turns on but only for a sec then the protection light comes on, on the amp and it wont...

sounds like maybe a speaker short, try unhooking your speakers and then powering up your amp, if it then powers up with the speakers unhooked try hooking up each speaker one by one untill the amp goes back into protection and then you have your bad speaker.

Mar 08, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Sony Xplod 2-Channel 1000 Watt Amplifier trouble shooting

What's the model number of the amp?

What speakers do you have on the amp?

Are the speakers moving significantly at high volume?

Sep 13, 2008 | Car Amplifiers

1 Answer

Car amps

important is to hav correct wires and groud cable...

Dec 29, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

Related Topics:

131 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers


Level 3 Expert

56836 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides