Question about Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Well i need help with my amp./

I have a Sony Xplod 600 watt amp and a sony cd player and it dosent have the rca hookup in the back of cd player what should i do?

Posted by on

  • natedawg14 Dec 04, 2007

    Hey i have a sony xplod 600 watt amp and a sony cd player and the Cd player dosent have the input on the back of it so i can hook the Rca cables up to the amp wat do i do?



1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If the amplifier doesn't have speaker level inputs, you will need to use a Line Output Converter (LOC) to convert the speaker level signal to a preamp level signal.

Posted on Dec 04, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

My sony xplod 1200 whatt amps red light keeps coming on all the wires are good when it gos to hit it gos red

check your ohm load on the sub and see if your amp can do the same, That is why every time it shuts off into protection mode. Check your gain level on the amp to this is not a volume knob for your amp, It is to get both the amp and cd player on the same page. Hope this was helpfull

May 19, 2010 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

I have an sony xplod 4 channel 600 watt amp

First are they in the same box? If so and they are sharing the same air space running one amp to both is best andwill perform better. One woofer could be over powering the other and or you could have a woofer problem. A lso your wiring coul be problem. When amp is bridged it changes the OHM reading and output your other woofer may not be rated at or able to handle a lower Ohm rating also it coul blow that woofer if it hasn't already hapened . Be careful. check woofers independently for operation and check the non performing woofer on an unbridged power source or amp. Hope this helps. Write back if not.

May 06, 2010 | Rockford Fosgate P112-200 Car Subwoofer

1 Answer

I just got a 600 watt sony xplod amp with a 10 inch xplod sub and it keeps turning off i thought i blew it but it went back on im confused

Could be overheating or a bad ground. Could also be a cracked tube or other internal part, that is expanding under heat and failing out.

Apr 07, 2010 | Sony XM-1502SX Car Audio Amplifier

1 Answer

No sound to the subs

Possible solution: Check to make sure your ground connection is connected to metal that is NOT covered in paint. This is not a solid connection and can ruin your amp over time. Simply scrap away the paint and re-connect. This was a problem i ran into recently.

Jul 27, 2009 | Sony XPlod CD Player w/MP3 Playback...

1 Answer

Settings for a Sony Xplod 1200 watt amp, with two 12 inch subs

What kind of subs are you running? Meaning what brand, what are the ohm, spl and wattage? I'll look up your amp while you get that info to me. Looking forward to helping you:) Thanks!

Apr 08, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer


I had the same problem as you. The problem is the wiring from your speakers to your amp TRIPLE check your wiring. Make sure that none of them got disconnected or connected to the wrong wire.

Mar 30, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Sony Xplod 2-Channel 1000 Watt Amplifier trouble shooting

What's the model number of the amp?

What speakers do you have on the amp?

Are the speakers moving significantly at high volume?

Sep 13, 2008 | Car Audio & Video

1 Answer

Car amps

important is to hav correct wires and groud cable...

Dec 29, 2007 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Sony Xplod XM-1652Z Car Audio Amplifier Logo

Related Topics:

136 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Audio & Video Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

xxxxxx xxx

Level 3 Expert

4905 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Sony Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides