Question about Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum

1 Answer

Embedded dirt finder light stuck

The embedded dirt finder light is stuck on red. The light stays lit even in areas that I know are clean. Is there a way to fix this or "reset' the system?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers
Re: embedded dirt finder light stuck

Try cleaning out all the pathways you can get to. Trapped particles can mess up this indicator. Particularly check the extra mesh filter that is under the bag (there's a plastic grid that snaps over it to hold it into place). Clean that out and make sure the bag is securely in place.

Posted on Dec 23, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

The dirt sensor light stays green. It won't turn red, even when I know I'm picking up a lot of dirt.

The Board(46851083) is No Longer Available
The EDF Duct (47823004) EDF= Electric Dirt Finder is $20.40 from
http www searspartsdirect com model part u6485900 0517 0645000 50039309...
You can test the board by crossing the 2 connectors to "close" the circuit for the mic (small black and blue wire) while vac is running and light should go to red every time you complete the circuit. WARNING: There will be exposed electrical points on board that could cause an electrical shock!!! or damage to board if not just crossing mic connections.

Jan 22, 2016 | Hoover U6485900 Bagged Upright Vacuum

2 Answers

Hoover - Red Light Dirt Sensor

check to make sure the settings didn't get inadvertently switched to the hi position, move the switch back and forth from high to reg a few times, then leave it on reg.

remove and hand wash the primary filter and secondary filter, dry throughly and replace them in the vacuum.

if none of this works, you will need to have the vacuum serviced, or if it is still working, just don't pay attention to the dirt-finder. the dirt sensor on your vacuum is located in the suction tube and is generally not accessible enough to clean without taking the vacuum apart.

hope this helps,

Nov 20, 2007 | Vacuums

1 Answer

Hoover windtunnel dirt finder light stays red. We've cleaned the elbow the roller the hose and have a clean bag. The vacuum is new only had it for 3 months.

I'm not sure about a 3 month old vac, I'd probably go the warranty route. However, for the older vacs thy start getting false positives. The sensor is simply a microphone hooked to a computer chip detecting sounds of dirt entering the bag.
To rig it to start working, you'll need to remove the tool accessory tray and elbow that enters the back of the vac, and attached to the bag. This will reveal the microphone at the elbow, and wire that runs into the bottom area of the vac. When on, a large amount of air comes from the bottom screw and area where the wires enter. My fix was to clean up the microphone contact points a little bit with a screwdriver, and then leave the vac running while putting in dampering in the hole at the bottom, and around the back of the elbow. Cotton balls and electrical tape at the bottom hole, and napkins around the outside of the elbow (wedged between the back of the vac assembly and elbow did the trick). The schematic for the vac is here: http<colon>//www<dot>vacsrus<dot>com/CartGenie/pg_U6485900<dot>asp
Look for micrphone.

May 12, 2010 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

My Hoover Dirt Finder red light stays on. All

Inspection of the circuit board found that the 470uF capacitor looked damaged. I replaced it and I now have the Green and Red lights are working correctly.

Jan 19, 2010 | Hoover U6476-910 WindTunnel Upright Vacuum...

3 Answers

Dirt finder sensor stopped working

I had the same problem with a hoover windtunnel 6200 - u5477-900. I removed the flexible hose from top of the plastic tube running vertically along the right side of the back of the vacuum. When I used a flashlight to look into the plastic tube, I could see a clog at the bottom, where the flexible hose curved frontwards towards the brushes. I then removed the 2 screws holding the vertical plastic tube to the vacuum. When I disconnected the plastic tube from the flexible hose at the bottom, I found a clog of dirt and dog hair. After removing the clog and reassembling, the clean / dirty light now moves back and forth from red to green.

Jan 29, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

4 Answers

Embedded dirt finder light stuck

The Hoover uses a small microphone that is positioned in the plastic housing that the end of the hose fits into, just behind the bag compartment. What happens is that when dirt comes up the hose and hits the 90 degree corner, just before it enters the bag, the microphone picks up the sound and transmits that info to the electonics that controls the lights. Sometimes the microphone will stick and the red light will stay lit. If you take a screwdriver and give the microphone area a sharp tap with the handle of the screwdriver, this will often jar the microphone and it will begin working again. If not, it may need to be replaced. NOTE: this function does not affect the cleaning efficiency of the vacuum. Your vacuum will still work normally whether the dirt sensor is working or not. It is a totally unrelated function to the vacuum itself.

Dec 31, 2007 | Vacuums

1 Answer

Problem with embedded dirt finder

Take the hose off at the back of the vac, should just turn then pull oull, look down inside the tube that the hose was connected to, there is a sensor there and if it is coated over with dirt, then it can't work, Clean it off and the try it, if it still stays on, then you have a bad sensor, and if this is less then a year old, you have a one year warranty on this. Take it to a warranty shop and take proof of purchase with you.

Oct 24, 2007 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Dirt finder

The sensor may be bad, or it may be coated over with dirt. Re,ove the hose at the back of the vacuum, the head of the sensor is down inside that opening, reach in there and clean it off and see it that corrects the problem, if not replace the sensor.

Oct 16, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Embeded Dirt Finder

check out the switch that activates it. go to thehooverstore for a complete listing of hoover machines. I'm sure you'll find your machine listed along with an exploded diagram of the machine

Sep 19, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Savvy

Does this happen at both Dirt Finder Sensitivity settings?

Sep 16, 2007 | Hoover U8171-900 / U8172-900 / U8173-900 /...

Not finding what you are looking for?
Hoover U6437-900 / U6439-900 Windtunnel Bagged Upright Vacuum Logo

1,071 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts


Level 3 Expert

18258 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides