Question about Vacuums

1 Answer

Hoover Hush Series Central Vac won't turn on

The central vaccuum will not turn on from the wall (hose), it has to be be turned on at the canister. All the electrical connections are correct and nothing seems to be loose. I had this problem when I installed it and I can't remember what I had to do to fix it. Can you help

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

If the low voltage wires are hooked up to it, then you probably have a stuck relay inside the cannister. It could also be the switch in the hose handle.

Posted on Feb 12, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I installed the Hoover Wind Tunnel Central Vac in my new home. After connecting the wall outlets and successfully turning on the system from the hose control, I discovered there is lots of air flow t


I would recommend checking your wall outlets where the hose plugs in for any type of clog in the tubing. If the vacuum itself has great suction but when you go to the wall outlets that is probably something in the hose that is stuck. If cleared it will most likely have excellent suction throughout the entire system in the house.

Jul 21, 2012 | Vacuums

1 Answer

I have an electrolux central vacuum in my house. My central vac hose has something stuck in it, I think, maybe a sock. I tried to put a long dryer wand down it but the hose is just too long. Does this need...


The best way to clear an obstruction is to blow it out by attaching the wall end to the exhaust of a shop vacuum, or using an air compressor.
You can try holding the wand end of the hose directly to the CV in port and turning the machine on. This provides essentially the same action as the previous method.
If neither of these work, try a combination of the two. Or using a shop vac, hold the wall end to the exhaust of the vacuum and the wand end to the in port of the shop vac. Turn shop vac on and the obstruction should come out.
Borrow a good strong shop vacuum if you need to.
If these methods fail, take it to an authorized Aerus Electrolux store and have the service tech try to clear it. Care must always be taken when trying to clear an obstuction with a long object, especially if it's pointed. I've seen many hoses that have shorted out and even caught fire due to the wiring accidentally being "nicked".

Jan 03, 2011 | Electrolux Central Vacuum

1 Answer

On my M&S Air Vac AV425 central vaccuum system, the system usually turns on by inserting the vaccuum hose into one of the vaccuum outlets. However, it now runs continuously. I am able to turn it off...


we are a central vacuum service company and we service all of new jersey. sounds like you have a short some where that keeps your unit running or it could be your relay module thats stuck our number is 908-721-7595 its j&j central vacuum services

Dec 28, 2010 | Vacuums

1 Answer

Electrolux 1590 not turning on


TRY JUMPING THE CENTRAL VAC INLET WIRES AT WALL! IF COMES ON SOMETHING IS MISSING ON HOSE TO WALL CONNECTION. MOST HAVE A METAL RING TO ACTIVATE THE INLET DOOR WHEN HOSE IS CONNECTED.

Dec 12, 2009 | Electrolux Vacuums

1 Answer

Hush - Insufficient suction


You need to approach this step by step. If you have insufficient suction at all locations you need to check as follows:
1. Hose, drop a coin through from the handle to the wall end, with the hose detached from the wall. If the coin goes through from one end to the other the hose should be clear. If the coin stops it will rattle inside where the obstruction is if you gently shake the hose you will feel it through the wall.Obstructions in hose or pie need to bee **** wards out of the hose or pipe.
2. Vac. Go to the vac itself and see if the onboard inlet has suction. If it does your problem is beyond the vac. If not your problem may be a leak, either a broken inlet, with a cracked or sagging door or jammed hinge, a clogged intake in the vac, or damage to the pipe within the house or a twisted gasket where the pail of the vac secures to the body, or an issue with the motor itself..
3. Take the hose, inlet to inlet and check all locations in the house. I mark a tissue with a number for each inlet and plug in the hose, one inlet at a time. If the tissue makes it all the way to the bucket from each location, that means the branch line for that location is clear. I work from the closest inlet away to the furthest checking for tissues one inlet a t a time. This will help pinpoint location of any blockage in the main line.
4. If you have had any renovations or painting done it is not uncommon to disturb the seal behind and inlet or pierce your piping with a nail or screw. Check for all these and post back to say waht you have found.



Sep 27, 2009 | Hoover S5636 Hush Central System Vacuum

1 Answer

Central Vac will not turn on.


These problems are nearly exclusively caused by a bad circut board and replacing it is the fix. Bad boards can cause many different effects so its nearly impossible to be sure. The 9v signal wire is not enough to short out an entire unit so it is unlikely the hose. If it is a direct connect system and you are pulling power from the 110 somehow that would cause main unit problems but that is unlikely at best. Sounds like a failed board to me.

Best of Luck

Jun 04, 2009 | Easy Flo EF1400 Central System Vacuum

1 Answer

AirVac ZX6000 won't turn off!


There is a relay board inside your unit which is most likely bad. If you have the make and model, you can contact me and I can order the board for you(pending your mechanical abilities). If not, contact your local central vacuum installation company. www.thevacdudes.com

Apr 21, 2009 | M&S Systems AirVac AVP1200 Platinum Series...

1 Answer

NuTone CV353 Central Vac does not start when hose is plugged into


Try to plug the hose in sideways. So the top of the hose is rotated 90 degrees. If the unit turns on then there is something wrong with the hose. It might be a short or it could be a bad switch on the handle. If the unit still wont turn on I would think that maybe the low voltage wire got disconnected from the unit or there is a break in the low voltage wire somewhere along the way. Let me know if you plugging the hose in sideways works.

Feb 22, 2009 | Broan-NuTone CV353 Central Vacuum

2 Answers

I have a 3 year old NuTone CV 353W central vac system and recently the switch on the hose handle does not turn the system on from any outlet in the house. I have to plug the hose into the outlet and then...


http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=567634
Generic problem for all Vacuums
I have a 3 year
posted by patfitz on May 03, 2008
I have a 3 year old NuTone CV 353W central vac system and recently the switch on the hose handle does not turn the system on from any outlet in the house. I have to plug the hose into the outlet and then turn the unit on from the switch on the canister. Any help would be greatly appreciated. Thanks

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. There are a couple of things that come to mind, 1st. you may have a bad switch in the hose and in most cases that can be repaired – if not you would have to purchase a new vacuum hose. 2nd. You may have a bad inlet valve in your hose and most of them are low volt of which would only cost less than $10.00 and can be replaced yourself unless you have what they call a SuperValve of which has 2 low volt wires and then it is wired to your home electricity and that should be replaced by an licensed electrician. It is a low volt and high volt inlet.

#3. the last thing you may check id that you may have a bad relay in the canister itself. Because you should be able to turn on the Central Vac with the switch on the hose and everything should work just fine . feel free to contact your local vacuum cleaner dealer in your area of call the Nutone Factory cust serv line for further assistance. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://nutone.com/ Customer Service
Nutone Inc.
9825 Kenwood Road
Suite #301
Cincinnati, OH 45242
Customer Service 1-888-336-3948
Technical Support 1-888-336-6151
Thanks, Don the Vac Man
Go Ahead. Use Us.

May 03, 2008 | Broan-NuTone CV450 Central Bagged Central...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

360 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...