Question about Samson Servo 170 Amplifier

1 Answer

Samson Servo 170 - 1 dodgy channel

Sometimes when I switch my Samson amp on I only get sound out of one channel and have to turn the input volume up high in order to get the channel to come on. Once it's on it seems to be ok. Anyone know what could be causing this?


Posted by on

1 Answer

Re: Samson Servo 170 - 1 dodgy channel


Posted on Dec 17, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

How do I connect my samson amp to my samson MDR10 mixer?

on the mixxer, use the "mix" "L" and "R" outputs. use 1/4 inch instrument cables, and connect the mox L and R to the amp's "channel 1" and "channel 2 inputs". always turn the mixing board on first, and the amp second- when turning off turn off the amp first, and turn off the mixer second. start with the mixer levels at the lowest, with the amp levels about 1/2 to 3/4 up. slowly raise the mixer channels first and then the mixer main volume until you have an adequate volume.

Mar 09, 2011 | Samson SX1200 Amplifier

1 Answer

As soon as I turn it on I get a low-mid frequency hum and no sound from other sources comes through...

Does the hum occur when the levels are all the way down?

1st thing to check is for a broken input jack

2nd thing would be power supply capacitors gone bad

Aug 14, 2010 | Samson Servo 170 Amplifier

1 Answer

When i turn my servo 170 on the protection light cums on so does the left channel clip light

Disconnect your speakers and see if the same thing happens. If it does not, then you have a problem with your speakers - possibly too many wired in parallel. If the amp. still shuts down, then it'll have to go in for repair.

Jul 23, 2009 | Samson Servo 170 Amplifier

1 Answer

Can I use my amp with PA speakers?

Yes, but stay within the "ohms" limit of the amp.(probably 4 ohm or greater)

Jun 09, 2009 | Samson Servo 170 Amplifier

1 Answer

Hi when i turn on my servo 170 my protection lite stays on

One of the channels in the amp is bad. That channel will need tobe replaced. You may need to take it to a repair shop.

Nov 12, 2008 | Samson Servo 170 Amplifier

1 Answer

Samson Servo 170 Amplifier

check see if youy have some coving the vent or the speak connect right

Dec 05, 2007 | Samson Servo 170 Amplifier

Not finding what you are looking for?
Samson Servo 170 Amplifier Logo

Related Topics:

609 people viewed this question

Ask a Question

Usually answered in minutes!

Top Samson Amplifiers & Preamps Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers


Level 3 Expert

4518 Answers

Are you a Samson Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides