Question about Kenwood KAC-9102D Car Audio Amplifier

2 Answers

Amp Turns on... then off

Looks like my KAC-9102D is going into protect. Had it hooked up with 4gauge and replaced it with a KAC-X10D because I missed bass =(

I took it all apart and didn't notice anything obvious wrong with it. Anything I should look for? I can take some hi-rez pics if it would help. Thanks guys

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: Amp Turns on... then off

I have a kenwood kac 9102 1000 watt amp and it stays on but no sound i took it apart and has no burt spots but when i hooked it back it work but then the sound went out but when u hit it with ur hand it comes back on

Posted on Mar 28, 2011

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that gotĀ 5 achievements.


    An expert that hasĀ over 500 points.


    An expert who has answered 200 questions.

  • Expert
  • 231 Answers
Re: Amp Turns on... then off

Unplug all speakers and see if it still into protect .If unit powers up normally without speakers , then hook up a temporary speaker directly to speaker out to see if you have output.If it works .Then check speaker cables and speakers for shorts.Also make sure you have good ground and main power and standy are present.

Posted on Nov 30, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I hooked up 2 capacitors into my amp and every time I put power to it the amp shuts off and 10 seconds later a red light comes on for 5 seconds and the amp don't turn on, basically it goes into protect...

Well, I have no idea why you would have two capacitors on a 500 watt amp but, did you charge the capacitors? Have you tried the amp without the capacitors? What size power wire are you using?

Sep 20, 2010 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

My amp is a kenwood kac-9152d it goes in to protection mode soon as you hook up the power

In protection mode do you mean the light comes on and it plays music and stuff? If that's the case, that's what the amp is supposed to do. Protect itself from a power surge

Feb 21, 2010 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Amp goes dirctly into protect

ok well it could be two thing wrong your amp dont have a good ground or your amp is a smar amp and your subs must have to be hooked up so the power from the amp cn go to the subs so the amp can see that you do have subs hooked up to take it out of protect o and look at your fuses to to smal or to big will send it to protect to

May 19, 2009 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

To bridge a Kenwood KAC-9102D

Hello laurogleal,

The Kenwood KAC-9102D is a mono amp. There is no bridging. Having two sets of terminals is just a more convenient way of connecting two subwoofers. The amp is stable down to 2 ohms impedance, so it is safe to run 2 4 ohm loads in parallel.

Hope this helps.

Apr 28, 2009 | Kenwood KAC-9102D Car Audio Amplifier

2 Answers

1 amp cuts off

i had this same prob. & i run 2 amps as well, cameto find out i had a neg. & positive touching , so check all ur wiring for tht amp..

Apr 01, 2009 | Kenwood KAC-9102D Car Audio Amplifier

3 Answers

KAC-9102d no sound, Amp powers on but no sound to the subs.

If the sub isn't working, you won't get a pop. All you need is a small speaker. Don't need a sub, you just want to test the sound. I recently blew 2 subs, no smoke, no smell, no sign of being blown. Absolutely nothing from the subs.... In the past my sub locked up. You can take your sub out of the box and hook the + and - to the battery to see if you can get the sub to pop there. I believe a small box will push a sub into a deep excursion to the center of the cone. I have 2 lanzar VW12D's that just quit. I hooked a 6 x 9 up to my amp and low and behold I had sound! Try that and see what you get...

Feb 07, 2009 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Amp goes into protection

First change the wire,and disconnect the subwoofers to check if the amplifier turn on without going in to protection mode,if the amplifier go to protection mode you gotta change the Audio amplifiers IC's because they are in short circuit.And if don't go in to protection put one speaker at a time to check if one of them are damaged.Good luck.

Jun 02, 2008 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

Powers up- and turns off!

If they go in to protection mode the audio amplifiers IC's are damaged and you gotta to change him.Good luck

May 23, 2008 | Kenwood KAC-9102D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-9102D Car Audio Amplifier Logo

Related Topics:

277 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pieter Vleeshouwers

Level 3 Expert

1333 Answers

Are you a Kenwood Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides