Question about Eureka 431A Optima Bagless Upright Vacuum

3 Answers

Suction switch I used my new eureka optima once and now it has no suction. The suction only switch does not turn on. I've checked for blockage and can't find any

Posted by on

  • 5 more comments 
  • MamaOfTwins Dec 03, 2007

    I have the same problem only I've had this vacuum for a little over a year. It was working fine this morning, then the brush roll clean light came on, so I turned it off, cleaned the hair off the brush and the filter, stuff inside the hoses, and when I turned it back on, NOTHING! No suction. The brush rolls, and the sound is different, not that high pitched motor sound it usually makes. Please Help!! }:-/

  • kleaner Feb 10, 2008

    same thing happend to me, no motor and no suction all of a sudden!

  • lil mamma Mar 12, 2008

    well when i first got the vaccum it worked great but now it only works for like 20 minutes and then the suction just stops and i dont know what happened because the brushroll is still rolling but the suction is not working what happened what can i do to fix this problem please help me i have taken it apart and put a new belt on it and went through the wiring and nothing so i dont know what to do please tell me a solution thanks?

  • lazyvac Aug 23, 2008

    There is no suction when I turn the suction switch to floor. There is no suction with or with out the roller. The roller does not turn. There is suction when turned to hose.

    1 I have double checked the switches.
    2 I have checked for blockage and found none
    3 I have removed excess dust from the filter

    I have not taken it apart

    It is 2 years old used maybe 10 times.

    many thanks ------ Janet


  • jennyleonard Oct 05, 2008

    I have the same exact problem. I have owned the vacume less then one month and the suction stops working. Then after cleaning the filters and letting it rest it works again.

  • jnk2008 Oct 23, 2008

    same problem only used 3 times and no suction.

  • Anonymous Nov 07, 2008

    Grrrrr, I have the same problem! Why are things so poorly made now-a-days? My parents still have their vacuum from 30 years ago and it works better than this. I guess this is why getting a cheap vacuum isn't the best idea...

×

Ad

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Leave the thing off for about 30 mins, let it cool. Take that time to clean out all of pieces. Its a pretty simple machine, but has many suction points. Mine killed around Christmas time. Flippin pine needles got caught everywhere,clogged the whole works and it just died. Though she was toast, but its back in action now. I really like this vacuum for how much I paid for it.


Posted on Dec 14, 2008

Ad
  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Well I turned it off for a half hour and it came back on suction and all!! you must have to let it rest if it overheats. the brsh was full of hair and I cleaned it out and let it set and now it works,,weird. wish the brush didnt fill up so fast!!!

Posted on Feb 10, 2008

Ad

I had the same problem and took the whole thing apart to get into the motor the wiring is done by the Chinese so just go through the wires and check for missing connections, I went through it till I came to the motor at the bottom of the unit and fixed it by putting a wire back on that had come off

Posted on Dec 16, 2007

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Eureka Optima Lightweight suction weak on bare floor, hose only works when dial is turn to floor?


I think it is normal. My favorite setting is the dial is turned to bare floor. If you set your vacuum to hose, then you need to adjust the height (do not set the dial to the bare floor).

Feb 21, 2014 | Eureka Vacuums

1 Answer

My Eureka Optima vacuum doesn't have any suction when on the floor option. How can I fix this?


It will as long as long as your accessory hose is properly inserted into the base. Otherwise the vacuum stays on the hose only.

Mar 13, 2010 | Eureka 431A Optima Bagless Upright Vacuum

1 Answer

No suction when vacuuming, but suction is good when using hose


check for blockage from where the hose sets in its
holder to the roller brush. Also see if the brush is
turning, the belt maybe broken.

Tom

Oct 22, 2009 | Eureka WhirlWind Litespeed 5844 Upright...

3 Answers

The suction on my eureka optima stopped working but the roller still works, what might i do to fix it?


Hi there. Most suction problems are due to a blockage. Start with the base and look carefully for debris that is stopping air flow. You may have to remove the base plate to get to the problem. I am including a link to the manual for your machine. look on page four so see how to remove the base and check for blocked airways. http://www.eureka.com/service/manuals/75287_eng.pdf

Aug 19, 2009 | Eureka 431A Optima Bagless Upright Vacuum

2 Answers

Eureka 2961 BVZ no suction, burning smell


I have the same vacuum. The burning smell is letting you know that your belt is either broken or about to break. I have had mine for a year and have had to replace the belt 5 times. Now I have to replace the brush roller 'cause it broke under normal use. My next vacuum will be a Dyson Ball.

Jul 05, 2009 | Eureka 2961AVZ Bagless Upright Vacuum

2 Answers

Eureka Optima vacuum has suction at the hose but not at the floor. I took out the filter and it still isn't suctioning so I don't think it is the filter.


it sounds like you have a plug. check where the hose goes into the back of vac. it should have a clip remove this and see if there is a plug there

May 18, 2009 | Eureka 431A Optima Bagless Upright Vacuum

1 Answer

No good suction!


the belt may appear to be in working order, but your problem is - it is time to change the belt. Once you replace it with a new one and enusre all area are clean and connected propperly, the vacuum should work fine

May 07, 2008 | Eureka 2961AVZ Bagless Upright Vacuum

1 Answer

Eureka optima


The filter probably needs a darn good clean. If it is clean, wipe the inside of the canister with a clean cloth to get rid of static.

Oct 13, 2007 | Eureka 431A Optima Bagless Upright Vacuum

Not finding what you are looking for?
Eureka 431A Optima Bagless Upright Vacuum Logo

Related Topics:

632 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18429 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

charlesjo336

Level 1 Expert

8 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...