Question about JBL GTO755.6 Car Audio Amplifier

1 Answer

Powering the unit

I have connected the unit directly to a 12volt car battery, the protect LED comes on briefly then goes out. There is no sign of life, what am I not doing right? The units is intended for a Quad cycle and initially to be powered by car battery then hopefully either Li-on or leisure batteries.
Dave

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Please check battery voltage dont drop below 10.8volt,
when trying to power up.

Posted on Nov 30, 2007

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwood VR 605 power light flashes


CHECK FOR CLEARED COOLING VENTS & FOR PROPERLY WORKING COOLING FANS. THIS WILL CAUSE SHUTDOWN OF THE UNIT. IF ITS ALL CLEAR, YOU PROBABLY HAVE A POWER SUPPLY ISSUE.

Dec 10, 2013 | Kenwood VR-605 Receiver

1 Answer

My MTX continues to draw power even when the key is not in the ignition. What can I do?


It sounds like you have constant 12volts applied to your remote turn on lead. The amplifier will have 3 connections for power:

1. 12volt constant
2. chassis ground
3. 12volt switched power - this wire should come directly from your head unit. It only sends 12 volts when the radio is on allowing to amp to power up only when the radio is on.

Dec 22, 2010 | MTX JackHammer JH600 Car Audio Amplifier

1 Answer

Is the brutus amp blue led light suppose to stay on when the car is off?


No. The LED should be off when the radio is off (amp turns off as well)

It sounds like you have constant 12volts applied to your remote turn on lead. The amplifier will have 3 connections for power:

1. 12volt constant
2. chassis ground
3. 12volt switched power - this wire should come directly from your head unit. It only sends 12 volts when the radio is on allowing to amp to power up only when the radio is on.

Dec 22, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

My 4 channel amp keeps going into protect mode when i power on,its not a imminet light,but it blinks once then dies out,plz help


Remove all speaker inputs and outs and just have your 12volt battery, ground and radio remote connected and power up the amp. If it turns red instantly, then the amp is shorted/blown. If it stays green, then install your speaker inputs and outs one at a time. make sure your amp is on while your doing this. if the amp goes into protect mode, take note of which wire it was for it's most likely shorted. Fix that shorted wire and the unit should stay on.

Apr 13, 2010 | Car Audio & Video

1 Answer

On this advice given by skinnman 33, it says "check your ground." How do you do that? I am experiencing the same problem with the led protector light coming on. It will play for about 3 minutes or so and...


When we say, "check your ground" all we mean is to look at the ground wire that connects to the amp and make sure it's adequately grounded. What I do is bolt it to a car seat bolt, that is the best ground you can get(called chasis ground). Try that and if you're still experiencing issues, troubleshoot it by removing one signal wire at a time. signal wires are the speaker and auxillary wires. Sometimes a short on these wires will cause the amp to go into protect mode. If you removed all your signal wires and all you have left on the amp is the remote, power(12volt battery) and the ground and your amp still goes into protect mode, then there's a short in your amp. good luck

Nov 21, 2009 | Lanzar VIBE286 Car Audio Amplifier

2 Answers

Se198wfpf lcd does not stay on screen briefly


It could be the high-voltage inverter board, I case of a faulty backlight (one of the tube flickers) the board would protect itself by powering off. Try changing one of the CCFL tube.

Oct 29, 2009 | Dell Computers & Internet

1 Answer

Brand new Amp, LED Protection lit up


If you have a good ground and 12+v on both the B+ and remote terminals, it's likely a DOA amp. Return it to the place of purchase for repair or replacement.

Jun 10, 2009 | Visonik V204XT Car Audio Amplifier

1 Answer

POWER SWITCH DOES NOT ILLUMINATE GPS SCREEN WITH 12VOLT PWR.


bjw122266 Have you tried holding the power button down for about 10 seconds or so?

Dec 29, 2008 | Navigon 2100 Portable GPS Receiver

1 Answer

My amp is not powering up anymore


take the amp out the trunk and connect directly to the battery, use a jumper wire for the remote from the constant power 12volt , if the amp fail to turn on it may be damage. check the fuses and look for any burnt connection.use a test light to test for power at the connection.

Aug 30, 2008 | MB Quart RAA1000 Car Audio Amplifier

Not finding what you are looking for?
JBL GTO755.6 Car Audio Amplifier Logo

Related Topics:

87 people viewed this question

Ask a Question

Usually answered in minutes!

Top JBL Car Audio & Video Experts

hoyzee1

Level 2 Expert

150 Answers

Rob Beech

Level 2 Expert

61 Answers

Morne Olivier

Level 2 Expert

257 Answers

Are you a JBL Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...