Question about Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

1 Answer

Hose i put a new bag in but the hose has vey little sucking power to it

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers
Re: hose - Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum Vacuums

Either the hose or the inlets are clogged.

Posted on Jan 05, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

How to fix

The machine may be over heating.Check the hose and power head for a block.Or,put in a new bag and suck in a few pieces of tissue to coat the lining of the bag....Chris

Aug 01, 2014 | Electrolux Epic 6500 Vacuum

1 Answer

Where do you hook up hose

Years ago I used to sell and demo kirbys up to the G-5 model,I believe you have to sit in front of your vacume,raise the wheels as high as they can go and on the logo face tun the crank one way,this loosens the belt and give a little tug and the roller sucking chamber will drop.Pull the chamber away.,now take your hose and stick it over the shaft and lock it down with the wing nut and then you can use all your vacume attachments.UNLESS YOUR TALKING - vacume bag hose- this is just a simple twist and click on the vacume exhaust chamber. Now if your hose is unhooked in your vacume bag it self,you will have to get a new bag attachment or get a repair man to look at it.

Jan 08, 2012 | Kirby G6 Bagged Upright Vacuum

1 Answer

The unit is not sucking anything up. checked for possible clogs in the hose - all clear. Took base off and cleared the bottom hose - put all back together and still not cleaning anything up.

There may be a screen filter beneath the bag that's clogged. Remove the bag, check, and clean if necessary.
Also, check the power head above/behind the brush. Things sometimes get caught in the tube between the brush and the hose.
There may also be holes or cracks in the hose will also reduce the "suction".
If these aren't the problem, take the vacuum to a repair shop, preferrably an authorized Riccar store.

Feb 23, 2011 | Riccar 4812 Vacuum

2 Answers

Hoover steam vac model f5912-900 stoppped sucking.please dont tell me to check the hose, there isnt one,and the extraction tank IS empty.this machine is brand new with 10 minutes on it ?????

There is a hose under or behind the extractor tank which can come loose or tear. Lower the handle and remove the tank to look for it. See if it sucks when you use the upholstery attachment. If it does this would indicate that the part that lowers to the floor is not going low enough to get the water.

Aug 01, 2010 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

I have a Kirby G4. I have noticed the last few days when trying to vacuum that it is blowing more than it is sucking up. I put on a new bag to make sure it wasn't too full. I also put on the hose and...

take the mini emptor off(plastic piece on bottom of cloth bag) this is done by rotating it away from the body of the machine. There is most likely a clog there. Also take the brush head off and inspect fan for chips or cracks this will also reduce suction. let me know if you need further assistance

Apr 08, 2010 | Kirby G4 Bagged Upright Vacuum

1 Answer

Little to no suction even with new bag, rug head spits dirt out

Proably a cloged pipe and suction hose>>> take both ends loose and run a broom stick through it..
Let me know if this helps and please give a good raiting

Jan 29, 2009 | Electrolux Guardian Bagged Canister Vacuum

1 Answer

I have a bissell power force vacuum and I just pulled the bag out to change it and when I put it back in it began blowing air out the filter on the side and is no longer sucking

Try checking the attachment hose for clogs. It should come completely off of the vacuum with just a few screws. Also, check the little hole underneath the brushroll where the dirt goes in. Hope this helps...

Nov 25, 2008 | Vacuums

1 Answer

Shop Vac not working well

The only thing after the filter and bag is the motor. Do you have suction with the hose removed? If not then the hose is clogged. If you have some, then the motor is the problem.

Nov 18, 2007 | Shop Vac 925-09-62 QSP Plus Wet/Dry Vacuum

4 Answers

Dirt devil mvp not sucking

Could be bad filters, is there suction at the end of the hose. That will tell you which direction to start looking. If no suction at hose end, then filters could be the problem. If you have suction, then the problem is down lower, dirt inlet is clogged, if belt has never been changed, then I am sure it has stretch to the point that under load it doesn't turn like it should. Could even be that although the motor is running, it may be running at a slower speed, in which case it would have to be replaced.

Oct 14, 2007 | Dirt Devil 12 Amp HEPA Filter Vacuum...

Not finding what you are looking for?
Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum Logo

Related Topics:

27 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts


Level 3 Expert

18258 Answers

Roger Potts

Level 3 Expert

694 Answers


Level 3 Expert

56925 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides