Question about Car Amplifiers

1 Answer

Wiring diagram for a kole amplifier 1920

I need a visual diagram for my kole amplifier 1920 and the answer to what a "tri mode capable" is

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers
Re: wiring diagram for a kole amplifier 1920

Here is a basic diagram of how it works.

Posted on Nov 29, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have a kole amplifier 4 channel 720 and It wont come out of protection mode. red light on and wont go to green. Its not overheated nor has it ever been hot. Is their something internal i can repair to...

The red light is an indication of an internal short circuit. First things first, try disconnecting all the speaker connections and turn it on to see if any of your speakers are burnt and shorting. If that does not make any difference it means you have lost one or more MOSFET transistors in the amplifiers output stage. You will need professional help to replace those.

Jun 16, 2011 | Kole audio HK720-4 Car Audio Amplifier

1 Answer

The light is red and no bass is coming out of my subs

The Amp Is Most Likely In Protection Mode... 2 Ways To Figure Out Whats Wrong With it Is Check Every Single Wire And Make Sure That Every thing Is Hooked Up Correct And There Are No Bad Connections With Ur Remote Wire, Ground Wire, And Battery 12v Wire, Rca Cables As Well. If Every Thing Checks Out Good Then Try Checking The Fuses And Make Sure u Are Using The Correct Fuses That Are Good For That Amp. If U try These 2 Things And You No Your Subs Are Hooked Up Correctly Then The Worst Is Probably There. I Had The Pioneer 7200 Amp And It was A Blown Amp And The Red Light was Constantly On. No Sound No Nothing. If U Try Those Steps And it Still Does Not Work Then Most likely Your Amplifier Is Toast. Hope This Helps :-)

Feb 18, 2011 | Kole audio Q2-1920 Car Audio Amplifier

1 Answer

How do i get my Kole audio qx4-720 amp out of protection mode

be sure the master volume is in minimum some amplifier has protect circuit when the volume exceed the maximum sound level to protect circuits from damage. try to disconnect speakers maybe one of them are shorted already

Feb 02, 2011 | Kole audio QX4720 Car Audio Amplifier

1 Answer

My Kole qx1-30000 ground wire gets hot and no sound out of RCA and amp goes into protect mode. Why does this happen?

make sure that the fuse under the hood is the right amp and that your ground is secure and solid

Mar 30, 2010 | Kole audio QX1-2400D Car Audio Amplifier

1 Answer

What sizes fuses go from battery to the amp on the kole audio 1920 watts kx2-1920?

depends on the size of your amplifier. what size is it? and how many channels? and what class?

Oct 22, 2009 | Kole audio KX2-1920 Car Audio Amplifier

1 Answer

I improperly hooked the ground connection to the hot wire connection and vice verus.

Hi so what are you saying does it work when you put pos on pos and neg on neg more info please the more the better

Oct 17, 2009 | Kole audio QX2-1920 Car Audio Amplifier

1 Answer

Bad ground feedback?

Make sure you run the Positive wire from battery on one side,which is normaly the drivers side. Then run the remote wire and the spearkers on the passininger side. Feedback comes from two places, Your radio or your amplifiers. If running to amps always run sepert positive wires with 25amp fuses on each. For the ground (8g) and power wires are always best at 4g or 8g wiring. The ground wire must go to a clean spot of metal that is ether the frame or chasey of the car. Plus use metal srew to mount the ground wire. If it is not giving you feedback then thats a good ground which is ok to mount 2 or 3 amps max. If you still hear feedback, it's time to look at the radio and make sure the ground wire is good.

Jun 21, 2009 | Kole audio QX2-1920 Car Audio Amplifier

1 Answer

Kole Audio Amp does to protect when I turn it on

Hi, Assuming you have been using the unit already for some time, it is possible that: 1. (Agree with you) The ground might have loosen up, re tighten the connection points and make sure that if it is chassis/body grounded, there is no paint/corrosion between the grounding lug and the point of connection. Better still,wire at least a #14 autowire from the amp's body to the negative of your battery; 2. check and verify that the speakers connected to the amp are good; 3. The speaker wirings might be touching the car's chassis or grounded somewhere. Check where the speaker wires pass and leads to visually making sure that no bare/scraped wire touched any metal part of the car; and/or 4. The amp itself might be at fault and would require the services of a qualified professional. Hope this gives you some ideas and work out for you. Good luck and pls post back how things are and/or if you need further information. Kind regards.

Aug 20, 2007 | Kenwood KAC-X501F Car Audio Amplifier

2 Answers


chenge and replace the safe of the amp

May 22, 2007 | Kole audio Q2-1920 Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

802 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pablo Gonzalez

Level 3 Expert

733 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides