Question about Logitech X-530 Computer Speakers

2 Answers

No sound from center and rear speakers

I tried setting these up in windows, and sound came from all speakers on the test. But the center and rear speakers don't work when I run any other program, music, games, etc. I'm using on-board sound (Gigabyte 965p-s3 mobo) so I updated my drivers, but got the same results. I went to the device manager, and tried updating the driver for Realtek HD Audio but found nothing.

I'm running 64-bit vista, audio codec ALC 883. Any suggestions?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: No sound from center and rear speakers

I had same problem and this probably isnt the same as yours but all i did was click on the speaker symbol on the taskbar and under speaker configuration set it to 6 for the sound card i think the default setting must be 2 because thats what it was set at hope this helps someone cos i was gettin so annoyed at only having 2 speakers and woofer working

Posted on Dec 09, 2007

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 500 questions.

  • Expert
  • 508 Answers
Re: No sound from center and rear speakers

Good Morning malaclypse
windows, Vista, well, a mess with DX9, that is new there 10,
you have to play with modes, on multimedia on control panel, and level with setting there for 5.1 or 6.1, surround speakers, and play music, or games, and see if work, sometimes, changing to a good sound card, like Audigy, or X-FI streme, do the trick.

Posted on Nov 28, 2007

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

I have the X-540 Speaker system set to 5.1 surround sound. By testing it on Windows Vista Home Premium x64 I have concluded the center speaker does not work when all others do including the sub...

Have you tried adjusting the matrix settings on the speakers. Try pressing the matrix button on the control box and see if that resolves the issue for you.

Robert from Blitware

Jun 17, 2010 | Logitech X-540 Computer Speakers

1 Answer

How can I test if my my g51 speakers are working

Hi Try using your MB Audio Programs that came when you installed your MB drivers...I know GIGABYTE Audio Programs Test sound from each Speaker that is connected....Or you can try this website and download that and test....Hope this helps
Happy new year bud :)

Dec 30, 2009 | Logitech G51 5.1 Multimedia Surround Sound...

1 Answer

Center/subwoofer speaker out...mixed

Hi all, I also purchased a logitech x-540 a few days ago and also have the center speaker outputting sound when i test or play the subwoofer. I didn't think this is normal and am now confused. Maybe its a problem with the audio drivers? MB is a ASUS P6T Deluxe V2 with Soundmax drivers. Hopefully someone can help to diagnose/ find a soluytion.

Jun 27, 2009 | Logitech X-540 Computer Speakers

1 Answer

No sound from rear and center speakers Creative t6100

Go insto your speaker properties/configuration from the little speaker icon in your taskbar. Check to make sure you have it configures in a 5.1 format rather than stereo. If it is set in stereo change to 5.1 & hit the test icon. All speakers should now be working. Hope this helps.

Jun 08, 2009 | Creative Labs Inspire T6100 Computer...

2 Answers

Rear speakers not working

try using SRS sandbox instead of using your sound driver it uses the SRS driver which is pretty good. I am using a creative inspire 5.1 and supreme fx soundcard a big difference when I tried SRS sandbox especially gaming.

Jun 09, 2008 | Logitech Z-5500 Computer Speakers

1 Answer

Logitech X-530 Speakers System

There are several reasons why there is no sound coming from the rear speakers.
  • Improper connection of the signal cable is a possible reason why there is no sound coming from the rear speakers.

7949.jpg Green connector is for the front left and right channel. Black connector is for the rear left and right channel. Orange connector is for the LFE (Low Frequency Effects) subwoofer and the center channel.

The connectors for the Logitech products are color coded as explained. The connectors on the sound card may not be color coded or a different color coding maybe used depending on the manufacturer of the sound card. Check the manual for the sound card to make sure the correct connector is connected from the Logitech speaker to the sound card.
  • After verifying that the connections are made correctly, the sound card needs to be checked to make sure it is setup correctly. There are many sound card manufacturers so we cannot possibly cover every make and model. We recommend contacting the manufacturer of the sound card to make sure the sound card is setup correctly for use with analog 5.1 speaker systems.
  • When a software DVD player is being used to watch a DVD, the audio output needs to be set to surround sound mode. Please refer to the user manual for the software DVD player to check the settings.
Many DVDs have more than 1 sound format available. Just as the sound card and the software DVD player, the DVD itself has to be set to the correct sound format.
  • Finally you can test to see if the speakers are working correctly by plugging the front channel cable coming from the sound card to the rear channel connector on the subwoofer. If sound comes out of the rear speakers, then there is no problem with the speakers. The problem could be with the software DVD player, or the audio setting on the DVD.
THIS article can be used to test if your speakers are indeed working.

Hope that helps!

If your issue is not resolved, please do not assign a rating just yet. Please post back as to what steps you took, results, etc, and I will try to assist you further as best I can. I am here at your service.

P.S. -You can rate this solution with one of four votes (remember that at times a bit of to and fro dialogue may be necessary to resolve an issue).

  • "FixYa!" - The solution provides great advice on how to solve the problem.
  • "Helpful" - The solution provides useful leads that helps solve the problem.
  • "Thanks for Trying" - The solution does not solve the problem but the effort is appreciated.
  • "Inappropriate" - The solution has absolutely nothing to do with the problem.
Thank you for using FIXYA!


May 04, 2008 | Logitech X-530 Computer Speakers

1 Answer

Rear speakers do not connect



Check out Dell WL6000 Setup and Quick Reference Guide -

Try re-synchronize the wireless link. If there is still no audio form the rear speaker, check if speaker mode in your computer is set to 5.1 channels. Click Start Control Panel Sounds and Audio Devices. Under Speaker Setting, click Advanced and select 5.1 surround sound speakers.
NOTE: The rear speaker will not have audio output if the source audio does not have surround sound.


Mar 08, 2008 | Dell WL6000 Computer Speakers

3 Answers

Rear speaker connection issue

OK, the fix for the missing rear speaker sound on the DELL WL6000 5.1 Surround Speaker System is relatively simple, just 7 simple steps (Verified by Dell at

First, power down everything. Second, disconnect the rear speaker and subwoofer from the power source and wait about 5 minutes. Third, be sure the power switch is off on subwoofer and the center speaker. Fourth, plug in the power for the subwoofer but DO NOT turn on the power yet. Fifth, plug in the rear speaker power cord. Sixth, turn on the swtich on the subwoofer (this is the start of the resync mode). Seventh, turn on the center speaker power and the system will change the rear speaker system LED from flashing blue to solid blue in 5-8 seconds. The surround system is functioning again. You may test this under sound in the Control Panel but I would prefer to use a modern music CD that has Dolby Digital Support for 5.1 sound or better. YOU WILL HEAR INSTANTLY THE SOUND DIFFERENCE WHEN THE REAR SPEAKERS ARE CONNECTED.

Nov 10, 2007 | Dell WL6000 Computer Speakers

2 Answers

Speakers not working correctly

pls swap the spk pin in to your sound card jack socket . bye

Sep 22, 2007 | Logitech X-530 Computer Speakers

3 Answers

Rear speaker not working

If you did the 5.1 sound test and the rear speaker works, sometimes you have to see in your software speakers settings,probably you need to change to 5.1 speakers

May 28, 2007 | Dell WL6000 Computer Speakers

Not finding what you are looking for?
Logitech X-530 Computer Speakers Logo

1,012 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Computer Speakers Experts

Lawrence Oravetz

Level 3 Expert

7053 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

9503 Answers

L Pfaff
L Pfaff

Level 3 Expert

11572 Answers

Are you a Logitech Computer Speaker Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides