Question about Logitech Z-5300 Computer Speakers

1 Answer

Problem with starting the speakers

Hey i have a problem with making the logitech z5300 speakers work.
and everything is plugged in but im not sure what to plug in too my comp.

Posted by on


1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert who has answered 500 questions.

  • Expert
  • 620 Answers

Good day and happy holidays
you have to look at back of your comp, if you has a 5.1 speaker first, like Creative Audigy, live, or X-FI, then according with the cables, colors, must be, Green . black, according for output sound, see manual for the cables and put at back according.

Posted on Nov 28, 2007


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Hey ive just bought Logitech Z506 surround sound speakers and im just wondering how do you connect it to your T.v ive tried and the rear left works, rear right works, the front left doesn't work and the...

you will probably have to buy some 2 to 1 input plug adapters and set them up
i cant see your television so im not sure of its speaker set up
hope this will help you

Mar 07, 2011 | Logitech X-530 Computer Speakers

1 Answer

New laptop. Hooked up Logitech Z5300 speaker system. Have power, but no sound. Fuse is good and volume is up.

if your computer came with a motherboard disc the sound drivers could be on it
you might have to uninstall then restart your computer then reinstall both the sound drivers and the sound card make sure you have both of these devices backed up to a disc before uninstalling
a yellow? question mark means you need to install/update driver to do this
right click to install driver also
click start control panel administrive tools computer management device manager scroll to sound,video and game controllers you might see a yellow question mark? Right click to reinstall drivers
click start control panel sounds and audio,volume,advanced,speakers make sure you have selected the
(((appropriate speakers))) also audio you will find 3 drop down lists make sure you have the correct settings there
click start control panel sounds and audio devices you can adjust the volume there also select speaker volume you can change your settings there you can also tick in the box place icon in taskbar
if his does not fix the problem

have you tried this control panel sounds and audio,volume,advanced,speakers select the appropriate speakers from the drop down list or navigate to the device manager scroll to system devices + to expand,system speaker right click properties then select use this device (enable) also you might check
the speakers plug/outlet is usually at the back of the computer you will have to open up the computer to check the lead attached to the rear of the input plug make sure the connection is good
try cleaning your computer of dust using a fine air blower from a compressor making VERY sure that there is no MOISTURE in the air line specifically around the sound card and the CPU central processing unit dust causes static to build up in a computer
hope this helps

Feb 19, 2011 | Logitech Z-5300 Computer Speakers

1 Answer

No power in my logitech Z5300 speaker system

Since power is involved, usually there is a busted capacitor in main circuit board or a open resistor which makes your remote fail. Try to see a technician to look at it.

Nov 18, 2017 | Logitech Z-5300 Computer Speakers

1 Answer

3 or 5 speakers arn't working


May i know the brand of speakers

However try to

Go in Start>control panel> there u will find a sound man icon open and there is a option to test the speakers check them if you are getting sound on it

Apr 14, 2009 | Logitech X-530 Computer Speakers

1 Answer

No sound

make sure the speakers are plugged into the GREEN port on your sound card many times people plug it into the linei n or mic jack by accident.

Dec 30, 2008 | Logitech X-240 Computer Speakers

1 Answer

Creative Inspire T6100 5.1 - No Power

I am facing the same problem with my creative T 6100 speakers...Please post if any solution found.....Thanks

Sep 09, 2008 | Logitech X-530 Computer Speakers

2 Answers


ive got the same problem but with my z5500

wonder what it is?

Mar 16, 2008 | Logitech Z-5300 Computer Speakers

1 Answer

Constant static

hello, all you have to do is get the ipod or portable dvd or cd player plug it and play it with minimal volume, just listen if there is clear sound coming out from the speaker, for you to know the answer to question...

Feb 28, 2008 | Logitech X-240 Computer Speakers

2 Answers

Speakers work when plugged into electrical outlet however will not work on battery power

hey u r using i think power is not suff for them to use dc flug boards..i mean direct curr...
y do u try for a batery??itz waste of money

Nov 29, 2007 | Logitech Inc MM50 Portable Speakers iPod...

Not finding what you are looking for?
Logitech Z-5300 Computer Speakers Logo

Related Topics:

199 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

Michial Gueffroy

Level 3 Expert

1138 Answers


Level 3 Expert

102366 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides