Question about Kenwood KAC-728S Car Audio Amplifier

1 Answer

It cuts off and on every couple of seconds when i turn the volume about 3/4 the way up. i am using it on subs

Posted by on

  • montgomeryb0 Aug 06, 2009

    i got a capacitor & it hel[ed out a bunch. Thanks

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 133 Answers

Do you use the supercap (the big 1 farad capacitor)?

If not, then the current peaks to the subs could cause the amp to loose power for its own operation so it crashes down a little bit every now and then, but then it recovers when the current draw diminishes.

Also, it could be a battery problem, try to check the liquid level in each cell and add distilled water if necessary, if it doesn't help, it could be that the first cell at the positive terminal of the battery is "cooked" because of a lot of discharging / recharging (it does happen, but if your car has no problems starting then the battery is probably still good).

To see if the battery is the problem, try connecting a battery that you know is still good (you might want to borrow it from someone so you don't have to buy a new one right away).

If you do have the supercap and you're absolutely sure the battery is good, then the problem might be in the power amp itself, also check the wiring and speaker impedance, if it's significantly lower than 4 ohms (standard impedance for car audio), then the speakers just might be wired in a way that your amp doesn't support, so they're juicing the amp a bit too much and it goes into overload protection when you turn the volume way up.

It could be that the problem is somewhere else, i just mentioned a few things i would have checked.

regards

3rq8 (Triarcuate)

Posted on Aug 02, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Legacy LA770 worked for 2 10" subs but not for 1 12" sub


if the protect light is still on with all speakers disconected then you have overloaded the internal ic and blown it beyound its ability to reset

sorry

Jun 25, 2010 | Legacy Audio LA770 Car Audio Amplifier

1 Answer

CHT12 speaker cuts out randomly have to turn off and on to get sound



Here is something you can try.

On your source check the output level for your sub.
Try setting up at a higher level, if at 1 set it for 2 or 3
Then adjust the volume control on the sub down to mach the speaker volume level.


Nov 25, 2009 | Velodyne CHT-12 Subwoofer

2 Answers

Subwoofer Turns Off when volume is turned up


check your earth from the amp i had same prob and the vibration broke earth connection once secured it was fine

Aug 24, 2009 | Pioneer TS-SWX310 Car Subwoofer

2 Answers

Jl 1000/1 cuts out


Hello, It sounds like you may have a problem with one of your subs. If this problem was not happening before that's what I would suspect. You need to check the ohms of both subs seperately, make sure you don't have a half blown sub. Second you need to test the voltage going into the amp while playing at a decent volume to see if there is a major drop in voltage. Also, check your ground. You'd be surprised at the many people who bring there cars to my shop with similar problems and turns out the ground was bad or loose. I would doubt there is something wrong internaly with your amp. The problem lies in the wiring or speakers. As you said it only started doing this after 3 or 4 months after it was installed. It's cutting off at high volumes cause it can't draw the power it needs at the higher volume, so make sure you check all your wiring good. Let me know what you find, I would like to be able to help you more if for some reason you can't figure it out. I own a shop and also do amplifire repair. Hope this helps.

Aug 16, 2009 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

Alpine PDX1.600 amp cuts off


Make sure there's no missmatched impedance. If your sub running 2 ohms then your amp has to be 2 ohms stable. Does the amp blow fuses or get really hot? If it does it can be a fire hazard and I would recommend taking it out of your car. It could be that you don't have sufficient grounding. The grounding needs to be very close to the amp and the paint needs to be thoroughly scratched off. Otherwise could be a blown transistor within the amplifier, you can check this by opening up the amp, running a multimeter and testing the transistors for resistance.

Aug 04, 2009 | Alpine PDX-1.600 Car Audio Amplifier

1 Answer

Subs cut out at low volume no matter the settings


I'm not a complete audio expert but it sounds like somethings over heating or you have a blown out put bridge.

Jun 20, 2009 | Alpine Type-R SWR-1222D Car Subwoofer

2 Answers

SUBS


Hi , you need to replace with thick wire , if possible attache fuse or circuit trip overload protection you may ask to thew radio store .

May 07, 2008 | Polk Audio EX12 Car Speaker

1 Answer

Amplifier power cutting out


not enough power to amp and or amps location is too hot might want to invest in a couple cooling fans from computer store and attach where needed

an amp should take up to 3/4 load but when not enough air to it to cool it off it will shut down

try this turn gain all the way down and slowly work up too desired amp volume setting

May 07, 2008 | Audio Players & Recorders

1 Answer

Stops working


THEY MIGHT BE DRAWING MORE CURRENT THEN UR ALTERNATOR CAN HANDLE.TRY CONNECTING A CAPACITOR FOR THE SUBS.

Feb 01, 2008 | Bazooka EL1204 Car Subwoofer

1 Answer

Amplifier cuts out when turning the gain up


Make sure the amp is getting good power and ground - there should be 12V across the two terminals. Also make sure you're giving it the proper ohm oad - how do you have your subs wired up? Do your headlights or interior lights dim when this happens?

Sep 16, 2007 | Eclipse EA3422 Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-728S Car Audio Amplifier Logo

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...