Question about i-rocks IR-7100 Mouse

1 Answer

Ir-700 mouse my mouse was working fine on my laptop until we had to delete everything back to factory setting, now my mouse is not recognized by the laptop and I'm not sure if I had software to begin with, I don't remember any. Can you please help.

Posted by on


1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert that got 10 achievements.


    An expert that got 5 achievements.


    An expert whose answer got voted for 500 times.

  • Expert
  • 8,637 Answers

Reinstall your CD software program for your mouse because it was wiped out when you went back to factory settings.
Normal 0 Try disconnecting the Mouse Receiver from the USB port and reinstall the CD software program. When the program asks you to connect the Mouse Receiver to the USB port, do so and it should work.
Hope this helps. Bud

Posted on Jan 20, 2009


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

Usb port won't recognize mouse

the usb port may be damaged or bad solder connections, do a system restore taking the it back before the problem occured. "long shot"

Mar 19, 2012 | Toshiba satellite c660

1 Answer

I plug my router into my modem and it just doesn't want to work with me. Everything was working fine, and then last night my connection gradually got worse until I lost the Internet. I plugged my computer...

There must be a small reset button on your router. Hold it down for 30 seconds. Release it. wait for one minute. Now unplug the power and plug it back in. Wait for 1 minute.
Once you reset the router, it will come back to factory default settings.
You will need to reconfigure the router form the start according to your Internet service provider.

Click here for step by step instructions

Sep 26, 2010 | Linksys Wireless-G WRT54G Router

1 Answer

My computer icon is crouppt

you can do system restore, set it back to the date when it is still working fine. or back up your files and perform one key recovery, you can do OKR by shutting down your computer and pressing arrow logo beside power button, it will take you to a step by step screen to restore your system, back up your files coz it will delete everything and set your computer to its factory default state.

Jun 09, 2010 | Lenovo 3000 Y410 Laptop

1 Answer

I somehow deleted the mouse from my laptop!

Hi there
I read your report. OK you can go to save mode and it will automatically give you your mouse back so you can go to admin rights to restore your computer. So you can get your mouse back. But if your system not set to do that. i recommend you get yourself a usb mouse for your labtop . it will automatically recognize this new mouse. I hope this little info helps. Thank you for writing to fix ya.

Best Regards Richard

Dec 03, 2009 | Office Equipment & Supplies

1 Answer

Usb not recognizing the mouse or flash drive


have you tryed the devices with out the cooling pad? USB ports have a limit on the amout of current they are able to source and it could be that the cooling pad is drawing to much current.



Oct 26, 2008 | Acer Aspire 9503EWSMi Notebook

1 Answer

Problem with KVM switch and Vista

Your problem has nothing to do with the Operating System (Vista), it has something to do with the brand of your computer. I have similar problem before, I have Vista (Dell), but the time I connected another Vista (Sony Vaio), everything worked correctly.

This is what you need to do:

1. You have to make sure that you are using a standard USB keyboard and mouse.

2. Connect first the keyboard and mouse directly to the Vista computer to see if the USB ports of your computer are working properly.

3. You may power cycle the KVM switch by disconnecting it from the computers (including the keyboard and mouse) and leave it disconnected for 2 minutes.

4. Reconnect everything after two minutes and then reboot the computers.

5. Try using different USB keyboard if problem exist after power cycling the KVM switch.

Sep 16, 2008 | IOGear GCS632U 2-port KVM Switch

1 Answer

Flahsing Red Light

Now what you have to do is look for a reset button on your mouse and your wireless mouse signal receiver.
When the receiver and mouse both are on press the reset button on both of them one by one.
This should solve the problem.

Jul 16, 2008 | Logitech MX 700 Mouse

Not finding what you are looking for?
i-rocks IR-7100 Mouse Logo

Related Topics:

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top i-rocks Computers & Internet Experts

micky dee

Level 3 Expert

2970 Answers

Alan Rothery

Level 2 Expert

105 Answers


Level 2 Expert

359 Answers

Are you an i-rocks Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides