Question about Vacuums

1 Answer

Wind tunnel two with bag, started with burning smell then shut off with red light on. Belt is fine but cannot get it to start again.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,486 Answers

Sounds like your motor.Try replacing the brushes in the motor.If that does not work then the windings in the motor have burnt out.

Posted on Aug 01, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hoover bagged wind tunnel 2 vacuum turns its self off after about 10 min. of normal vacuuming I can press the power button right away and the vacuum will turn back on and vacuum for sometime as long as 5...


There is a thermal sensor in the motor which shuts power off if it gets too hot but usually it won't turn back on until it cools down. It seems you might have a defective switch

Oct 06, 2013 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

I have the G series Kirby silver vacuum, I was vacuuming and started to smell some burning. Looked down and my green light was off also. What could it be? PLS HELP


Your belt is burning and will eventually wear down and break. The green light comes from copper brushes on your roller creating an electrical current that lights the little green light. As long as the roller is turning, the light will stay on. There may be something jamming the roller (hair, string, paper, etc). Clean the roller off and replace your belt. If you don't replace the belt it will break soon enough. Once you start smelling the "rubber burning" smell it's and indication that your belt has deteriorated at some point and has a weak spot in it. Clean the roller and replace the belt and it should be fine.

Apr 20, 2013 | Kirby Ultimate G Bagged Upright Vacuum

1 Answer

I have a windtunnel vacum cleaner. When I


It might be a slipping rubber belt, is the brush roller moving when you look underneath? If it's a self propelled machine there might be another slipping belt. Friction from fast rubbing rubber can smell like it is burning.

Jan 16, 2010 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

How to change the V belt on hoover wind tunnel U6435-900 ?


Below I have listed a link to the manual which has instructions and a link to the V belt you need.

Windtunnel Manual

Windtunnel Replacement Belts

Nov 03, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Self Propel wheels not enough power to move machine over carpet.


Sounds like the transmission might need an overhaul. Take it to a local vacuum repair shop and have them look at the transmission.

Sep 03, 2009 | Vacuums

1 Answer

My Hoover Wind Tunnel has a burning smell when running. I replaced the belt, but this didn't help.


its clogged my vax does that burning smell when it gets clogged up thats for the five minutes before it overheats and stops

Aug 03, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Vacuum shuts off and has a burnt smell


Hi,
Try removing the drivebelt, and try running it to test like this. The brush bar will not turn, but it should function normally without smell at this point. If it doesn't, you may need a new motor as I think the brushes may have worn down - producing an electrical type burning smell.

If it runs fine without the belt attatched, then there is probably a build-up of hair or threads at each end of the roller stopping it turning freely. With the hoover off, check it turns freely and easily. A small metal nail file or similar is usually a good tool to clear it.

If the roller is stiff, the belt will not turn easily, and overheat on the motor spindle - causing the burning smell.

Jan 08, 2009 | Hoover Vacuums

2 Answers

Rubber smell, Hoover


Well it sound like you do need a new belt because of how the smell is you might want to stop using it because the smell comes from the burning and over heated belt my solution would be to get a new belt and that should fix it if you need anything else you know whre to find me.

Jun 30, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...