Question about Dometic Rooftop RV Air Conditioner

2 Answers

Unit seems to work fine, but NO COLD!!!

Model number: 57915.622The compressor kicks on and runs fine. All of the different fan speeds work fine. The new 5 button controller system works fine.The unit does not blow COLD air. When I took the shroud off, I felt both the evaporator coil inlet and outlet and the condensor. The evaporator was not COLD and the condensor was not HOT. I think this unit needs a 'recharge'. Where can I get this and how do I do that myself?

Posted by on

  • cheaneyc Jul 31, 2009

    Thanks, guys.

    It has an access port for the recharge to be applied. As for leaks, this unit is about 12 years old, but of course, could have a leak in it.

    Unfortunately, it is R22. All one has to do on that score is check the model number...

    I guess I take it to La-Z-Dayz to get the recharge.

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,273 Answers

If the compressor kicks on and runs fine, this usually indicates that the freon in the system is good. Is there anything else that can obstruct the air into the unit or into the cabin? I believe that this refrigerant will be R-22, and may be difficult or impossible to purchase without a license. I also think R-22 is sold in cylinders larger than you'd want. Check in your unit, though. If, by some slim chance, it is R134a, you CAN buy and install this yourself, but, again, I doubt it is. Your best bet would be to have a local technician put the gauges on it and recharge it. Be sure to check for leaks. If you're losing refrigerant, you need to get the leak stopped, or you are going to just throw your money away.
Best regards, --W/D--

Posted on Jul 31, 2009

Ad
  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 233 Answers

You need to verify what refrigerant the sytem is using, and if there are access ports on the unit to allow servicing, (many smaller units are not so equipped) If it is 134a you can puchase a kit at auto parts stores. (they usually have directions for use.. good luck :)

Posted on Jul 31, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Auto/On set to ON. Fan runs.


Sounds like the thermostat, the way to verify is to unplug indoor unit, remove thermostat, take pic of wiring with phone or label the wires as to the terminals. Carefully twist the yellow,(Y) Red (R) and the green (G) together. Plug the furnace back in, if the unit operates normally, replace the thermostat. I am basing this on the fact that the blower speed is changing. This could also be an anomaly within the circuit board in the furnace section, not likely though as the outside unit (condenser) is not controlled n by the indoor board unless this is a heat pump. hope this helps. D

Jul 21, 2015 | Dometic Rooftop RV Air Conditioner

1 Answer

Freezer won't stay cold


What is the model number of your unit?

Feb 10, 2013 | Gladiator Chillerator Top Freezer...

1 Answer

Compressor runs and gets hot but fan will not kick on. Replaced the capacitor and that did not help. One side of coils gets hot, the other side gets cold, which seems normal. Just can't get the fan...


Don't run the compressor for any length of time without the fan operating. Is it possible that the fan must be replaced? Can you power the fan safely to test it?
Gary

Jul 26, 2011 | Maytag M7DH45B2A Dehumidifier

1 Answer

Keeprite 2300 sx a/c w/ 2 speed fan never seems to go high speed .should I be able to hear it change and how do I dainose the problem ? and does this cause poor cooling ? the compressor unit line is cold...


I need more info. I can't seem to find your indoor unit. Is this a 2 stage cooling unit or just 2 speed fan? Please send the model number of your indoor unit.

Apr 11, 2017 | Heating & Cooling

1 Answer

I have a dometic unit on my RV. Now the fan runs and the compressor runs good but I got no cold air. Do I need a new unit or what is the problem?


If you are sure the compressor is kicking in and staying on, then you should be getting cold air. Did it work o.k. up until now? Anything different?

Aug 05, 2009 | Heating & Cooling

1 Answer

Rheem central air unit is blowing cold air but seems to be in low


If you have had a drop in how much air is coming out it is quite likely not fan related. The fan motors usually run or do not run. More likely it is a clogged air filter or some of your ducting has blown loose. Like water, air will go the route of least resistance. If your fan motor is not running at all, I would need model number for resolving that.

Jul 08, 2009 | Heating & Cooling

1 Answer

Kenmore a/c window unit fan not kicking on with compressor.


Likely a bad motor, when this occurs verify the board is sending voltage to the motor.

May 30, 2017 | Kenmore Heating & Cooling

1 Answer

It does not continuously run and it is not cold


These units are not repairable.(per Maytag) The entire unit must be replaced.(per Maytag)

May 26, 2009 | Maytag SkyBox MBV1976A Beverage Dispenser

3 Answers

Split unit, I get heat but no cold


I have run into this with the LG brand systems. try shutting power off to the outdoor unit to reset all units. If problem persists, it could have to do with a charge level of refrigerant (freon) or possibly a failed control board.

May 16, 2009 | Fujitsu 24R1 Air Conditioner

Not finding what you are looking for?
Dometic Rooftop RV Air Conditioner Logo

442 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dometic Heating & Cooling Experts

Bill Long

Level 3 Expert

587 Answers

Donni Steen

Level 3 Expert

659 Answers

mike cooper

Level 3 Expert

884 Answers

Are you a Dometic Heating and Cooling Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...