Question about SPL Dynamics XL2-820 SPL Car Audio Amplifier

1 Answer

Power protec is signal red on - SPL Dynamics XL2-820 SPL Car Audio Amplifier

Posted by on

  • Mark Skinner May 11, 2010

    Please describe your problem in more detail please. Then we can figure out or narrow the problem down. It sounds like some power mosfets or output transistors got shorted. I need to know what happened first, why it stopped working.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 68 Answers

Missmatched impedence, ie you are running your amp which is 4ohm load to a sub which is 2ohm load, insufficient grounding could be the cause, blown transistor within the amp possibly.

Posted on Aug 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

NEED TO TAKE OFF WRITE PROTECED ON SONY SDHC 4GB..


There is red colored switch aside ur memory card. check it if its locked mode,then push it upwards and make it visible.

Dec 11, 2012 | SanDisk 4GB SDHC Memory Card Class 4 w/ 25...

1 Answer

Al prender mi camara digital alympus dice protec. escr que hagO.?? pOr favOr aiiudaamee


When this problem occurs Protec. Escr., Just enter the tools menu and find "Format" and voila, the camera returned to work usually remains

Aug 27, 2010 | Olympus FE-240 Digital Camera

1 Answer

Similar prob.did the 12 steps on how to install amp(jensen4100,blue).red protec light comes on when starting car then goes out and is not followed up by the green protec light .green one never comes on....


If you are running a set or a single subwoofer with the jensen amp than you will want to hook up the rca cord to the subwoofer rca connection on the back of the stereo unit-the other rca outputs are there in the event that you want to run a 2 or 4 channel amp to power the speakers that are generally located in the doors or back deck-with that set up properly you would still be able to adjust the balance and the fader just as though you were powering the speakers with the deck. Pug the free ends of the RCA cord into the input rca receptacles of the amp- the stereo now will feed a signal to the amplifier that only contains bass - good luck

May 16, 2009 | Jensen LXA300 Car Audio Amplifier

1 Answer

Where can i get a free copy of schematic diagram for amplifier


Generally a "protect" mode would be triggered by a shorted output (speaker). I would suggest disconnection all of the speakers to see if the red light goes off.

Mar 16, 2009 | Car Audio & Video

1 Answer

Nothing comming on but red light flashing


unit is is shut down ,hsa a fault and to protec furthe damage shuts down,until error is corrected.needs service tech.

Apr 13, 2008 | Panasonic PT-47WX49 47" Rear Projection...

1 Answer

Manual for the Protec Bytelan KVM/4


The switches are used when cascading more than a single BYTELAN KVM. It specifies the scan rate, and which KVM unit the keyboard and mouse are connected to. For a single KVM, use the default settings. SW1 SW2 Scan Rate ---------------------- ON ON 2 seconds OFF ON 10 seconds ON OFF 20 seconds OFF OFF 40 seconds SW3 NOT USED SW4 ON For KVM unit with KB/mouse OFF For other KVM units w/o KB/mouse, If your power supply isn't adequate, it may cause your KB/mouse problem. It should be 9VDC with at least 500ma. Hope this helps.

Aug 20, 2007 | Protec Microsystems Bytelan KVM/4 KVM...

2 Answers

Protec Microsystems


I have one of these and the powerpack is 9 volts 600 mA

Jun 04, 2007 | Protec Microsystems Bytelan KVM/4 KVM...

Not finding what you are looking for?
SPL Dynamics XL2-820 SPL Car Audio Amplifier Logo

Related Topics:

75 people viewed this question

Ask a Question

Usually answered in minutes!

Top SPL Dynamics Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4834 Answers

yadayada
yadayada

Level 3 Expert

75005 Answers

The Knight
The Knight

Level 3 Expert

73619 Answers

Are you a SPL Dynamics Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...