Question about Phoenix Gold MX1260 12-Channel Amplifier

1 Answer

Blows 10amp fuse. Speaker 1&2 50volt ps capacitor burst open at top. Disconnected that amp from ps and unit still lights light bulbs I have in series. I disconnected each amp one at a time and light bulbs in series still light up indicating a short until I have no amps hooked to power supplies in unit. I need help and a schematic. thanks loren

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

Sounds as though you have a direct short in Primary Amplifier circuit. Have you dissasembled unit and ohmed out Transformer? Also Cooling fans that are high amperage draw that short out as well as you said Bad Capacitors. Try ESR meter on Caps.

Posted on Aug 01, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Radio amp fuse blows


problem could be radio.10 amp fuse for ignition switch power up radio display the 30 amp fuse for radio amp system in which that circuit hot at all times.

Nov 18, 2013 | 1998 Lincoln Continental

1 Answer

2003 nissan pathfinder blows tail lamp fuse


you got a wiring issue that keeps shorting out fuses find that and that should take care of everything else

Mar 08, 2012 | Nissan Pathfinder Cars & Trucks

1 Answer

My front left speaker began to make a loud noise after being on for about 10 minutes, getting worse. I swapped the speakers around and the sound stayed int hat channel. I disconnected that speaker and the...


i think there may be leaky capacitor in your amplifier. there is also chance of ic failure in the amplifier it may be producing noise after getting hot. open cover & carefully see if any capacitors(which are large & round one) are burst. check for excessive heat of the amplifier ICs. replace with same type if u find any of above capacitor or ic defective.

Sep 03, 2011 | Denon Audio Players & Recorders

1 Answer

Suddenly it does not work. No clock no light up in the panel.


Open the unit. On top where mains come in would be a big fuse normally 10amp , its blown. This is almost always caused by faulty door switches. Also check diode from the big cap to earth. be careful the cap can store high voltages even when unit is off.Discharge capacitor first with a wire to earth.Make sure the unit is off.The fuse will also blow if that diode is blown.they usually go short circuit.

Apr 02, 2011 | Emerson MW8987B/W Microwave Oven

2 Answers

Need a diagram of the fuse box for a 1994 volk


Heres a picture of fusebox,and listed is the fuse locations,1) 10amp left low beam light
2)10amp rt low beam light
3)10 amp instrument& license plate light
4)15 amp, rear wiper
5)15amp frt washers and wipers
6)20amp A/C fresh air fan.
7)10amp rt tail & side marker lights
8)10amp left tail & side marker lights
9)20amp rear defroster &heated mirrors
10)15amp fog lamps.
11)10amp left high beam
12)10amp rt high beam
13)10amp horn, rad fan run on
14)15amp backup lights (m/t),power mirrors,heated seats,heated washer jets,cruise control (m/t)
15)10amp engine electronics,coolant pump run on(v6)
16)hazard signals,glove box lite,shift lite
17)10amp turn signals
18)20amp fuel pump, oxygen sensor
19)30amp a/c, rad cooling fan.
20)10amp brake lights,cruise control.
21)15amp dome light,cigar lighter,locking system,multifuntion indicator,clock,vanity mirror.a94b062.gif

Mar 10, 2010 | 2003 Volkswagen Passat

1 Answer

Gemsound xp-550


A diode/rectifer or voltage stabliser, or leaky capacitor in the power supply.
Also the main transistors in the power amp or if it has an output IC - that!
If you can in anyway disconnect the power supply section from the amp circuit, you can isolate which part is faulty. For if it blows when disconnected from the power amp, you know it's just the power supply that's gone. And if it does not blow - then it's the amp!

Aug 24, 2009 | Gem Sound GemSound PA-585 2-Channel...

5 Answers

2002 jeep liberty interior fuse diagram


1-20amp-pwr outlet frt. 2-10amp-rear fog lights(export only)
3-15 amp-horn 4-10amp-hedlt low beam rt
5-10amp-hedlt low beam lft 6-20amp-bodycontrolmodule/pwr dr locks 7-spare 8-spare 9-10amp- rt pk lt /rt tail lt/trailer tow lt/cluster
10-spare 11-15 amp-flasher 12-15 amp-stop lts
13-10amp-bodycontrolmodule/cmtc/cluster 14-spare
15-10amp-pdc fuel pmp & auto shutdownrelays/skis
16-20amp-pwr outlet rear 17-15amp-rear wiper 18-20amp-radio choke relay 19-20amp-frt fog lts/trailer tow stop and turn lts
20-20amp-sunroof 21-spare 22-10amp-wiperswitch/frt and rear washer 23-10amp-lft park lt/lft tail lt 24-10amp-pdc blower motor relay 25-10amp-heatseatswitch/hvac controlhead/trailor tow battery charge 26-10amp-hedlt highbeam rt 27-10amp-hedlt highbeam lft
28-spare 29-15amp-heated seat module 30-10amp-heated mirrors/rearwindowdefrosterindicator 31-20amp-cigarlighter
32-10amp-radio/frtdoorlockswitches/bodycontrolmodule
33-10amp-skis/diagnostic connector 34-15amp-cluster/courtesy lts/radio/bodycontrolmodule/maplights/cmtc/underhood lt/vanity lts
35-spare 36-10amp-ignition run/start-orc/lft and rt siacm
37-10amp-ignition run only-orc 38-10amp-abs module/brake shift interlock solenoid 39-10amp-rear window defroster relay/flasher/backup lts

Jul 03, 2009 | 2002 Jeep Liberty

2 Answers

Fuse blows when I turn on the tail lights.


May be a tough one to isolate, hopefully not a bare wire to lights but very well could be. Personally, I'd try removing all the running light bulbs, then turn them on and start replacing one at a time, to see which one causes fuse to blow. have a real good look for a bared wire at or near connection , or one full off water/moisture.If you have one that looks like water or moisture in it, that's where I'd start.

Feb 16, 2009 | 1987 Acura Integra

1 Answer

Rockford amp cut out


Disconnect all speaker wires from the speaker terminals of the amp and disconnect the RCAs. Replace the 30 amp fuse with a 15 amp fuse. If you turn it on and it blows the fuse, it's likely that it has shorted output transistors. If that's the case, you need to have the amp repaired.

Dec 22, 2007 | Rockford Fosgate p-450.4 Car Audio...

3 Answers

Hood lights


This is a problem with the control board, which we commonly repair for $32.50. This is caused by not disconnecting the microwave from the power line when removing or installing a bulb.

May 30, 2006 | Sharp R-1481B Microwave Oven

Not finding what you are looking for?
Phoenix Gold MX1260 12-Channel Amplifier Logo

Related Topics:

180 people viewed this question

Ask a Question

Usually answered in minutes!

Top Phoenix Gold Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5190 Answers

The Knight
The Knight

Level 3 Expert

74459 Answers

Are you a Phoenix Gold Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...