Question about Phoenix Gold Titanium 1000.2 Car Audio Amplifier

1 Answer

I have a phoenix gold ti 1000.2 amp.. this is such a great amp and its hard to find.. the problem is when the bass hit i thought i blew the amp.. no bass comes from the amp anymore but the amp turns on and the fans work. but when i turn off the car the amp is still powered up. so i cut the remote wire and it still powered up. any idea of what might need to be repaired?

Posted by on

  • docny1984 Jul 30, 2009

    i took the amp to where i purchased it but he no longer works with phoenix gold.. everythign was perfectly installed and workin for about 3 months in my new car.. i had the amp 3 years prior and it worked.. i have 2 kicker cvx subs that i are not even a year old.. its something in the amp. was jus wonderin if anyone knew what it was in the amp n the price range to fix whatever it is or if its cheaper to jus get a new amp

×

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 12 Answers

Are you sure its grounded good and are you sure the amp is on or do you know for sure its the amp not the sub to see if its the amp just just wire it to an old speaker not a subwoofer and be sure to switch the lpf off

Posted on Jul 30, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do you wire a qx500.1d to get 1 bridged channel. a shop connected just to the left channel. i thought it needed to be positive from right and negative from left to bridge. i am using 1 fosgate r2d2 10.


A Class D amp only has 1 set of out puts for sub's. so it will only be a left and right pos and neg.As i look your amp it is a 2 channel so both speaker terminals are internally bridged so you can hook the to either set as it will be the same since they are cross overed internally. i found you a good guide for your amp i will include it and should help you greatly. . hoped i helped you.
http://www.parts-express.com/pedocs/manuals/263-800-phoenix-gold-manual-41601.pdf d

Apr 24, 2011 | Phoenix Gold Car Audio & Video

1 Answer

Phoenix gold ti 12d sub gets hot shuts off amp


Depending on your location most places will replace certain things. You may try and see if your sub has any type of warranty. But yes I do believe it would be consistent with a voice coile being bad.

Oct 27, 2009 | Phoenix Gold Ti12D Car Subwoofer

1 Answer

How to hook up led lights for phoenix gold x10d4 speakers


THERE ARE 2 WAYS:

1. (STEADY ON) - RUN THE POWER FROM THE AMP TO THE POSITIVE LED TERMINAL THE NEGATIVE CAN BE RAN FROM THE NEGATIVE SPEAKER TERMINAL.

2. (INTERMITTENT; COMES ONE EVERY TIME THE BASS HITS) - RUN THE POSITIVE AND NEGATIVE WIRES FROM THE + AND - TERMINALS TO THE POSITIVE AND NEGATIVE TERMINALS OF THE LED LIGHTS.

LET ME KNOW IF THIS WORKS FOR YOU -- CADILAC00@HOTMAIL.COM

Mar 15, 2009 | Phoenix Gold Xenon X10D4 - 10" D4...

1 Answer

Pheonix gold amp bass remote


i just had the same amp and tried using my buddies bass knob from a different model wouldnt work so i called company they said you have to have the cord that came with the amp

Jan 14, 2009 | Car Audio & Video

1 Answer

Amp problem, need help!!!


Sounds like one of two problems: either your subs are beginning or have gone bad, or you amp is going bad. What size power and ground wire are you using? You should be using at least a 4 gauge for both. Also what impedence are you running with the amp, ie; 4ohm mono, 2ohms stereo, etc?

Jun 19, 2008 | Phoenix Gold Octane-R 4.0:2 Car Audio...

1 Answer

Crossover


i have lost my manual to the phoenix gold 600.1 xenon amp. i want to set it up by the book can you help me ?

Apr 25, 2008 | Phoenix Gold Xenon-600.1 Car Audio...

1 Answer

Interference


how many watts is the amp and speker are you sure you are not putting too much?

Jan 31, 2008 | Phoenix Gold Ti600.2 Car Audio Amplifier

1 Answer

Amp goes in and out.


THE BASS GETS LOUDER AND LOWER.COULD BE A VOLTAGE DROP.IF YOU PLAY AT LOWER VOLUME WITH NOTHING ELSE RUNNIG,LIGHTS,AIRCONDITIONER,THOSE THIS STILL HAPPEN? THOSE YOUR FRONT HEADLIGHT BLINK WHEN AND LARGE BASS NOTE IS HIT?R U USING A CAPICITOR INLINE WITH THE BATTERY,I HIGHLY SUGGEST AMPS THEAT PULL DIRECTLY FROM BATTERY CAN CAUSE DAMAGE TO THE IC IN THE ALTERNATOR.RATING PLEASE ,GIVE MORE INFO

Jan 29, 2008 | Phoenix Gold Octane-R 15.0:1 Car Audio...

Not finding what you are looking for?
Phoenix Gold Titanium 1000.2 Car Audio Amplifier Logo

Related Topics:

224 people viewed this question

Ask a Question

Usually answered in minutes!

Top Phoenix Gold Car Audio & Video Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Mark Skinner

Level 2 Expert

77 Answers

Jeffery Lewis
Jeffery Lewis

Level 3 Expert

318 Answers

Are you a Phoenix Gold Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...