Question about Eureka WhirlWind Litespeed 5844 Upright Vacuum

1 Answer

Eureka 4D. Brush turns but not alot of suction. dust bunnies build up inside the hose at the bottom and at the dust brush connection. Seems to be very hot. ?????

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 76 Answers

Try cleaning the filters

Posted on Aug 22, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Eureka upright bag less model 5857 az. The hose has suction but not for the carpet. Is there a switch that needs to be turned to floor suction? I do not have a manuel.


I'm just guessing here, but have you laid the vacuum down with the underside of its head showing? There is a channel that runs from the brush section to the hose when it's connected correctly to the head. Look for item(s) that may be jammed into that channel. Ensure that the hose is properly attached to the head. If you feel no suction on that underside channel, you have something jammed in it.

Oct 19, 2014 | Eureka Vacuums

1 Answer

Turbo tool used only once or twice, already brush moves so slowly it stops when I try to use. Brush can actually be stopped by hand. Manual says nothing at all about the brush ie. HOW to take apart to see...


It takes a lot of suction to spin the brush. First make sure the suction is good. Make sure the bag and/ or filters are clean. Replace if necessary. Most turbo tools can be opened up to clean. Most have a lever that allows you to open it up to clean hair, dust, etc from the fan and fan shaft and other areas inside the tool. The tools pick up a lot of hair and debris and some will wrap around the moving parts building pup to the point the brush will not spin fast enough. The same thing can happen to the brush roll on your vacuum so be sure to clean it too and replace the belt at least twice per year.

Oct 31, 2013 | Eureka Vacuums

1 Answer

Doesn't pick up and blows dust forward


Check for clogged hoses, dirty HEPA filter, animal/human hair, carpet fibers/threads- build up on brush head or inside underneath the brush head.

Sep 23, 2013 | Eureka Powerline Cyclonic 4484 Upright...

1 Answer

Swivel glide has no suction in the hose but seems to have a bit at the head, definatly not alot. can i fix this myself somehow?


Get ahold of a plumbers snake, disconnect the hose and run it through unclogging it .
Undo hose and see if there is suction right at the socket where the hose plugs into to see if there is suction there.

Inside the place where the bag goes, at the bottom there is a motor dust filter, see if it is clogged.

Also at the beatter brush, make sure that there is not dirt crammed around the nozles input, and check to see if the belt is not slipping on the beatter bar and remove the wound threads from the beatter bar it self.

Best!
Robert!

Oct 02, 2009 | Dirt Devil SwivelGlide Bagged Upright...

1 Answer

Eureka 4870: Brush roller turns even in hose setting.


You either have the wrong size belt, most likely too small, or you have installed a new belt incorrectly. When you open the cover on the bottom of your vac, you will see the pulley that moves as you flip the switch from floors to carpet. The belt does not go around this pulley. When activated(carpet) the pulley puts tension on the belt causing it to turn the roller. When switched back to hard floors, the belt looses tension allowing motor to cause suction but disabling roller. Also, the dial on top of vac is only to direct suction, not for disabling roller

Jun 21, 2009 | Eureka Smartvac 4870 Bagged Upright Vacuum

1 Answer

The brush does not spin when making contact with carpeting


I tried the electrical-tape-around-the-wooden-spindle technique. After a minute or so, it's back to functioning normally.

Mar 14, 2009 | Eureka Smartvac 4870 Bagged Upright Vacuum

1 Answer

Vaccum has no suction


Here is what we did to fix the problem of our vacuum having no suction.
We unscrewed the three screws on the back and took the hose off of the vacuum.  Then we took the hose outside and put the water hose through the vacuum hose and turned on the water.  After about 30 second the water pushed through a dust bunny the size of a fist and a marker.  Basically, the vacuum did not have suction because the hose was clogged with dust, etc.  After reassembling the vacuum, it worked just fine.  

May 11, 2008 | Kenmore 34923 / 34925 Progressive Bagged...

1 Answer

Eureka the Boss bagless


Sounds like you have a clog somewhere. Check the filter inside the dust compartment, if is very dirty it won't allow ait to flow thru, Part #62132, DCF-H filter. Check the hose, take it off if you can and drop something in it to see if it comes out the other end, if it doesn't, then the hose is clogged. Check bown by the brush roll, the inlet may be plugged. Also if the belt is more then say 6 months old, you may want to replace it, I am sure it is strertched, part #61120B, extended life belt.

Jan 23, 2008 | Eureka 4700A Maxima Bagless Upright Vacuum

4 Answers

Eureka vacuum


if you have ran over any big objects you might try removing the cover from bottom take out the roller brush and see if it is clogged from the bottom

Nov 30, 2007 | Eureka Altima Upright Vacuum Model 2996AVS...

3 Answers

Vaccum wont work


There is also a reset button on the side at the bottom. Good luck.

Oct 14, 2007 | Vacuums

Not finding what you are looking for?
Eureka WhirlWind Litespeed 5844 Upright Vacuum Logo

Related Topics:

138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

JoeVacs

Level 2 Expert

357 Answers

Alan Matzke

Level 2 Expert

78 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...