Question about Eureka SC886 Bagged Upright Vacuum

1 Answer

I have a Sanitaire model SC886 upright vacuum. It's about a year old. I replaced the belt , cleaned bag , checked for blockage in impeller fan and now it makes a noise , like a grinding noise or something . Could you tell me how to fix it ?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 90 Answers

The bearings in the motor needs to be checked,
or the impeller is damage.

Posted on Jul 31, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

No suction


I presume the motor is running, take the front brush roller off and check the fan is still intact. Possibly broken fan.

Mar 30, 2014 | Kirby Ultimate G Bagged Upright Vacuum

1 Answer

Sc888 replace fan


please go to :http://www.eureka.com/en-US/Customer-Service/Videos/ proeed with common sense. God bless you

Jul 15, 2012 | Eureka Sanitaire Commercial SC888 Bagged...

1 Answer

Doesn't pick up


This could be a few reasons. Check and make sure your bag is not full of dirt, a full bag will make your vacuum's suction worse. Next check for clogs of dirt and debris. Check the nozzle and brushroll too. If you find no clogs and the brushroll and belt look good, it may be your vacuum fan is damaged and needs to be replaced.

Genuine Oreck Mataxalloy Fan Impeller R0008


GoodVac.com
800-775-6586

May 09, 2012 | Oreck XL21 Bagged Upright Vacuum

2 Answers

I have a Sanitaire model S663. It came with the 12" Vibragroom I aluminum roller brush E-53272. Is the Sanitaire Vibragroom II 12" steel roller brush E-53270 interchangeable?


If you go to this URL:
http://evacuumstore.com/c-57-sanitaire-parts.aspx
You will see both of the brush you mention. Compare what they show and if necessary, call the on line store for their input.

Oct 03, 2010 | Eureka Sanitaire S663 Upright Vacuum

1 Answer

How i clean cloth bag sc886 vaccum


well if you must clean it,,(not a good idear to do so) you could throw it in the washer by its self! but its far better to put a new cloth bag into the vaccum cleaner,, a washed cloth bag wont work half as well as a new bag will,,all you will get is even more dust out of it,,,thats twice the cleaning,, buy a new bag and save the time and work

Jun 25, 2010 | Eureka SC886 Bagged Upright Vacuum

1 Answer

Kirby g6 will not pic up dirt. Belt is on and bag


check for blockage or impeller if vacum makes loud noise the impeller is the part that gives it suction

Oct 15, 2009 | Kirby G6 Bagged Upright Vacuum

1 Answer

Hello, I have a Eureka Sanitaire upright vacuum. It is not picking up as well it usual and I notice it no longer has that deep motor sound. What do you suggest?


Does there seem to be good air-flow and suction? If not, look for a blockage somewhere. Otherwise (and more likely because of what you say about the sound), look to the brush roller. Does it rotate when the machine's switched on? If so, maybe the bristles are worn and no longer make contact with the carpet properly. If not, the belt that drives the brush roller is broken and must be replaced. Your Owner Manual will tell you how to do this.  Good luck!

Jul 17, 2009 | Eureka Sanitaire Commercial SC785 Bagged...

1 Answer

How to replace fan impeller on old Hoover upright. Taking off the belt pulley is giving me the problem.


Depends on how old it is ... if it is real old try putting a open end wrench on metal belt pully, and then hit wrench with a hammer i think counter clockwise to loosen

Mar 26, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Motor running extremely hot


You might want to check the brushroll. It may need to be replaced. The brushroll end caps on your model should come off easily and if there is a collection of hair, etc under them and you can clean it out, do so. If it is impossible to clean out, you must replace the brush. You can get one at any Eureka/Sanitaire dealer or warranty station. If you have a model 1934, you can upgrade to a better metal brushroll which won't give you as much trouble.

Sep 24, 2007 | Eureka 1934 Bagged Upright Vacuum

Not finding what you are looking for?
Eureka SC886 Bagged Upright Vacuum Logo

Related Topics:

179 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eureka Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

charlesjo336

Level 1 Expert

8 Answers

Are you an Eureka Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...