Question about Escort Passport 8500 Radar Detector

1 Answer

Stop working where can i send this unit for repair

Posted by on

1 Answer

Re: stop working

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

2 Answers

Laser alarm gos off when accelerating

This is a common problem with the older units, the Laser horn gets dirty and out of alignment causing this issue. You can send the unit in for repair or try to fix it yourselfe

May 12, 2014 | Escort Passport 8500 X50 Radar Detector

1 Answer

Stopped working

What stopped working? Does the unit power up? Is there no sound? Will the unit not alarm any more?

If it stopped working, did you check the fuse in the units' power cord or the vehicles lighter socket fuse?

If not sound, does all the other lights and buttons function? if so, is the volume control turned up?

Aug 14, 2010 | Whistler DE-1793 Radar Detector

2 Answers

My speaker stop working


Check the sound drivers in your system and also check whether the speakers have been properly plugged into the system

Thank U

Please rate me as it wil cost u just one click

Oct 23, 2009 | Cobra XRS 797 Radar Detector

1 Answer

Program button is stuck and shaking causes settings to change

Yes, you could remove the button and then your settings wouldn't change. Yet this will be difficult to do since the momentary button switch is very tiny and is difficult to desolder. Your best bet is to send your X50 to Escort for repair.

Apr 11, 2009 | Escort Passport 8500 Radar Detector

1 Answer

Cobra XRS 9330 problem with K & KA bands constantly going off

I have the same problem. My detetor is three weeks old. I am sending mine back under warranty to the merchant or Cobra directly.

Aug 02, 2008 | Cobra XRS 9330 Radar Detector

5 Answers

8500 Alerts for no aparent reason

Got to the bottom of my false alarming situation. I finally called Escort and discussed the behavior with the technician who immediately concluded the antenna was failling and needed a repair. $30 worth of shipping and about a week later I got my repaired unit back and it works perfectly. Not sure the root cause but I am going to treat it as gently as possible and hope it keeps working, I sure like it better than the V1.

Dec 05, 2007 | Escort Passport 8500 Radar Detector

2 Answers

Whistler 3300

Did you look at Whistler's website for R1 error trouble shooting steps?

Nov 30, 2007 | Whistler 3300 Radar Detector

12 Answers

False Laser warning when engine RPM goes over 3000.

Hey guys, me again....Deadcandance..... I posted my trouble on a Satellite forum I belong to and I had a suggestion which I tried. And it worked!!!!! No manufacture returns, no cost at all, what I did was tokk it apart gently how everything comes apart so that you can reassemble again....

Start by getting a couple Q-Tips (Ear Swabs).Leave them dry so they won;t leave any residue on the diodes. Gently clean the horn, than clean/wipe the electronics board, and blow out the diffusion screen (leave the spit in your mouth). After I wiped the unit down, I didn't see any dust persay or dirt on the Q-tip but whatever I did, fixed it....
It worked for me. Took 15 minutes to do and I have been using the Radar for three months and not one false alarm in Laser mode.
Good luck...

Sep 01, 2007 | Escort Passport 8500 Radar Detector

Not finding what you are looking for?
Escort Passport 8500 Radar Detector Logo

Related Topics:

219 people viewed this question

Ask a Question

Usually answered in minutes!

Top Escort Radar Detectors Experts

John Nolan

Level 2 Expert

346 Answers


Level 3 Expert

3283 Answers


Level 3 Expert

3018 Answers

Are you an Escort Radar Detector Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides