Question about Kenwood Audio Players & Recorders

1 Answer

Ka5010 amplifier dead

Unit dead. 2.5A 250V fuse blown inside unit.R88 and R62 fried. R88 is situated next to Q24.can you help
jamycor

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 50 Answers

Possibly transistor Q24 may be faulty,replace Q24 plus the associated cmponents that have blown.

Posted on Jul 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can I use a 15A/32V fuse to replace a blown 15A/250V fuse


No! Unless you have read it wrong and it should be 320V. You can go higher than 250 volts but not lower. And you can go lower say to 10A and say up to 16 or 20A, though you should stay around 15A to be safe. If you do fit a 10A fuse at 250 volt and it blows straight away then it won't be the fuse that is faulty, but something inside the amp that has gone. As fitting even a 15A 250V will do the same. A 32 volt fuse in the mains section will burn out in a fraction of a second.

Dec 08, 2012 | Audio Players & Recorders

1 Answer

Fuse type for onkyo a-9555


The main power fuse for most amplifiers is a fast blow, 125 volt fuse for the US and a 250v fuse in countries with 220v. This unit is 125 watt so the main fuse should be 2 amps or so. The correct fuse size is written on the circuit board next to where the internal fuse was located.

Feb 23, 2012 | Onkyo A-9555 2-Channel Amplifier

2 Answers

Actually iSymphony M110 - it doesn't wont to turn on. Just the stand on red lamp is on and no response on any buttons. Does it has sort of reset button or it should be repaired in service center? Do you...


I just bought one of these "dead" units for $15...I replaced the blown 2A 250V fuse with a new 2A fuse and it blew as soon as I plugged it in so then I took one of the 4A 250V fuses from the other side of the unit(located right behind the speaker output terminals) and it works perfectly now.

Sep 18, 2010 | iSymphony M1 Shelf System

4 Answers

Brookstone Wafer-thin CD with MP3 player circuit failure...why?


sure, ur power amp section is completely shorted. meaning it is totally fried. get it repaired. it was a stupid idea to jump the fuse. u cud fry the whole thing!!! i sincerely hope it is only the power amp. if it is more than that u have only urself to blame. remember looks can be deceptive.

Apr 13, 2010 | Brookstone Wafer-Thin CD System with MP3...

1 Answer

No power to Crown XLS 602 Amplifier


Hi...

There may be some internal fuses on that unit.

You can open it by taking the cover off and looking for fuses and discolored parts.

It may have a thermal fuse on the power transformer which then will require service

Check the web for service people in the UK

Mar 31, 2010 | Crown XLS 602 2-Channel Amplifier

1 Answer

Moisture in amp while on, caused a small pop, then no sound outpu


check the fuse between the battery and the amp. (not the fuse in the back of the amp).
if that doesn't work then something on the inside of the amp is fried.

Jan 30, 2009 | Phoenix Gold Xenon-200.4 Car Audio...

1 Answer

MPA-101 Amplifier powers on, receives source signal, the fuse is not blown inside, but no sound comes out of the amplifier. The amp is pretty new, doesn't even have dust inside the unit.


Hello, is this a Radio Shack PA amp or Jamo amp? The unit is probably in "Protect" mode. Is this a PA system or a receiver...receivers have a protection circuit that will not let the speaker relay activate if the amplifier output section is shorted and sending voltage towards the speakers...so they won't fry!!The speaker relay should activate within 3 to 5 seconds if your output section is ok.

barneyluc

Oct 13, 2008 | Audio Players & Recorders

2 Answers

Fuses for P-07


the fuse you need is a t4al 250v

this is a common slow blow 250v 4amp fuse.

You can get them at RadioShack



Oct 03, 2008 | Gemini Sound Products P07 2-Channel...

1 Answer

I think I broke my baby...


If it's dead, it's probably a blown fuse or maybe a blown thermalcouple fuse. a bad magnatron won't make the unit apear dead unless its blowing fuses.

Hope that helps..

Geno

Mar 24, 2008 | GE JES1142SF Microwave Oven

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5047 Answers

Eddie Dalton
Eddie Dalton

Level 2 Expert

53 Answers

Henry  Thomas
Henry Thomas

Level 3 Expert

1074 Answers

Are you a Kenwood Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...