Question about Kenwood Car Audio & Video

1 Answer

On a kac-x650d does the power light stay on or flash

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 655 Answers

Hello mpredday,

The Kenwood Excelon KAC-X650D power light is ON during normal operation. It blinks blue to indicate BMS selection, yellow for low voltage, purple for DC voltage on the outputs, red for overheating, and green for a shorted or grounded speaker wire.

Hope this helps.

Posted on Jul 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Kenwood kac9152D turns on but why dose the red light on the top keep flashing?


The manual only says the power indicator burns when the power is on.
25372094-ptmniwyvtjobac0k42nxowvq-3-0.png
I can't find anything about it also should flash. The only thing I can think of, it has detected an error, like a blown amp or a low impedance on a speaker terminal.
Here is the manual:
http://images.kenwood.eu/files/prod/29/5/KAC-9152D_9102D_8152D_8102D_(EN).pdf

Jan 17, 2015 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Can i run just 2 subs on this 1200 watt kenwood 5-4-3 and if so what way will i get the most power, i mean do i bridge it or pute the speaker wires in other ports


you can run 2 subs given that you dont go over 2 ohms of resistance and that the subs are rated at 1000 watt max each around 4 or 500 watt rms. if your not sure about ohms dont bridge it and get single voice coil subs. this amp is capable of about 700watts constant power 1200 max spike if the voltage stays at 12 or higher.

Feb 05, 2010 | Kenwood KAC-X650D Car Audio Amplifier

1 Answer

My amp indicator is blinking blue and my sony xplod sub is not workin thru the amp but works wen i connect it in my other car how do i fix it so my light stops blinking, and my sub works again


yes you have a internal fault of the amp. the circuit that puts it into safe mode is bad and that is a very small chip on the board know as a op amp. needs to be repaired.

Jan 03, 2010 | Kenwood KAC-X650D Car Audio Amplifier

2 Answers

Kac-7202 flashing power light


ALL THAT IS A WASTE OF TIME AND YOU MAY HAVE CAUSE MORE DAMAGE TO THE AMP,THOSE AMP WILL FLASH WHEN THERE IS NOT ENOUGH POWER SOURCE EITHER GROUND,OR LOW VOLTAGE REMOTE OR TWELVE VOLT SOURCE CHECK ALL THOSE AND MAKE SURE YOUR HAVE RIGHT SIZE SPEAKERS THAT CAN HANDLE THE LOAD FROM AMP

Aug 07, 2009 | Kenwood KAC-7202 Car Audio Amplifier

1 Answer

Amp overheated


Yes, try replacing the fuses first. If that doesn't work, then I'm sorry to say that you most likely fried your amp.

Jun 06, 2009 | Kenwood KAC-X650D Car Audio Amplifier

1 Answer

One amp dies.. then revives


I'm no expert, but the two most obious problems that come to mind would be the power supply or amp over heating.  Test your battery and alternator..

Oct 28, 2007 | Kenwood KAC-X650D Car Audio Amplifier

3 Answers

AMP FOR SUB SHUTS OFF SOMETIMES


your system is not connected right take it all out and put it all bk in

Oct 27, 2007 | Kenwood KAC-X650D Car Audio Amplifier

2 Answers

Kenwood kac 859 amp


hi, note that if you are not using the proper gauge b+ and gnd cable with this amp then the current available at the amp wont be sufficint to keep amp on. also try using this amp while vehicle is idling. if this doesnt work then disconnect all spks from amp and check if red lite stops flashing. if it doesnt stop flashing then amp has internal fault. if lite stays on brite then proceed to check each spk load impedance, then reconnect each spk individually. the minute red lite starts flashing it will give you a clue that the channel or spk load is faulty. cheers

Jul 27, 2007 | Kenwood KAC-859 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

yadayada
yadayada

Level 3 Expert

75197 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

7782 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...