Question about Motorola Radio Communications

1 Answer

I hava a practically new two-way radio that does not work. The radio does not seem to work when turned on. I just hear a slight static from the speaker. Is there a reset or button press I can perform to get it working again?

Posted by on

  • 2 more comments 
  • rstrom Jul 28, 2009

    I have a Motorola Talkabout Model T5620.
    When I turn it on there is nothing on the display, no indicator light and a small amount of static from the speaker which does change when the volume control is changed.

  • rstrom Jul 29, 2009

    Motorola
    T5620

  • eradiostore
    eradiostore May 11, 2010

    What model?

  • eradiostore
    eradiostore May 11, 2010

    It is possible the radio is not programmed to match your other units, so it appears not to work. What model of radio do you have?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Motorola Master
  • 1,646 Answers

The fact you do not have a display indicates you either have a bad or damaged radio, or you have a battery or battery contact problem. Clean the battery contacts with a pencil eraser and insert known good batteries. If this does not solve the problem the only solution is to replace the radio.

Posted on Jul 29, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have galxy DX33PH i can not hear anyone on it and it dose seem like i am put out


two things, hows the swr and is your internal speaker working? Check to make sure the unit is on cb and not pa. Make sure that your squelch is all the way to the left and your rf gain is all the way to the right . Turn the radio on ,it should come on and you should hear static . Now adjust your swr as low as you can get it and it should work fine.

Feb 08, 2015 | Radio Communications

1 Answer

Motorola talkabout t5710s won't recieve


Hi,

The question I would ask is:

How close are the two radios to each other when you contact from one to the other?

A distance between the two radios of about 10-15ft, preferably more is desirable to achieve audible results, having the closer than 10ft, causes one to cancel the other out, so you either hear static, feedback or nothing.

Try 15ft of more distance between radios and see what happens.

Pls feel free to post the results here on the two way radio forum, as I'm interested to find out what happens.

Cheers, Peter@FixYa Team

Nov 29, 2012 | Radio Communications

1 Answer

I have a cobra 29 with echo, tweeked and tune. I can transmit strong and I hear those who speak to me but I dont have any static like you do with a new radio. Is this something I need to worry about as Im...


Make sure the squelch is turned all the way to the left, the RF GAIN is turned all the way to the right. The cobra 29 has a very good noise blanker, Turn the ANL/NB switch to off, You will probably hear a Lot of static, As long as you have a good ground on the radio and antenna, and your SWR is 1.5 or lower, you need not worry about static.

Oct 05, 2012 | Cobra 29 LTD CB Radio

1 Answer

Turned up full volume u can only just hear sound if ear right to it was working fine then the volume just ******** out


It could be the mic plug. uniden is known for the issue where the wires inside the mix plug break at the solder joints.

When the RX wire breaks, you will loose receive because the radio will not go into receive mode. But you can usually hear it ever so slightly if you crank the volume.

Other issue that may cause this. No radio activity, (unless you hear radio activity low and not static)

poor feed line or antenna.

I would try a different mic that is known to work.

Aug 11, 2012 | Radio Communications

1 Answer

Can not get static out of radio i have a cobra 29 with weather channel the squ knob seem 2 b not working sometimes can u help me


Turn the squelch down, and the RF gain all the way up.

You need to realize that some times, there is not a lot of noise out there. Right now lately there has been due to skip. But it does die down. When you hear a lot of noise for a while, then it goes away, it messes with your head. You don't hear anything, but that's because its quite out. I would test it by talking to some one on the radio. If you can hear them just fine even though you don't hear a lot of static, then its just quiet out.

Jul 23, 2011 | Cobra 29 WX NW ST 40-Channels Base CB...

1 Answer

How can i hear what they are saying without that awful loud sound when they arent saying anything. cause when i turn the volume down i cant hear what they are saying


Turn up your SQUELCH button when no one is talking until the static noise just goes away.

Now your set will remain quiet until someone talks.

If you set the squelch too high it will also cut out the people talking, so always try to have it set just slightly above the background static level.

Good luck.

Apr 15, 2011 | Uniden BC350C Base Scanner

1 Answer

When i transmit if the other vehicle is anything over a mile away they get a lot of static. I can receive them clearly at up to 5 miles. What do I do to get better transmission? I have a K40 antenna...


Well if they are not hearing you over a mile but you hear them over 5 miles that is a good indicator that your antenna is working properly but your radio is not getting out there. First go ahead and check the TX knob. Turn it all the way to the right so you modulate as much as the radio will allow. Next turn the squelch knob all the way to the left until you hear static and then turn it to the right slowly until the static noise goes away. Some don't mind the continual static but I like to squelch it out. The TX being turned to the right will allow your radio to work at full capacity. If you still don't get reports much over a mile then you can try a power mike to help you out a bit. Your microphone could have seen it's better days and can for sure mess up your transmit. Make sure your SWR is low 1:1.5 is the goal not to exceed 2. If all that checks out then have it peeked /tuned and aligned by a tech. Good luck to you.

Feb 06, 2011 | Cobra 29 WX NW ST 40-Channels Base CB...

1 Answer

The AM/FM radio in my 2003 CTS faded to just


This sounds to me like the antenna wire may have become loose in the back of the radio. It just took a few weeks for it to become free. :) If you can maneuver your arm behind it, you should be able to push the connector back into the hole in the back of the radio. But the safest and most practical way to do it is to remove the radio from the dash and plug it in that way. :)

I hope this helps! Let me know if I can be of further assistance. :)

Sep 30, 2009 | 2004 Nissan XTerra

1 Answer

Receiver went Tango Uniform


radio need tuner board assy.

Jul 16, 2008 | Dewalt DC011 AM/FM Radio

Not finding what you are looking for?
Radio Communications Logo

Related Topics:

177 people viewed this question

Ask a Question

Usually answered in minutes!

Top Motorola Radio Communications Experts

eradiostore
eradiostore

Level 3 Expert

1646 Answers

OBHighflyer

Level 2 Expert

125 Answers

Greg Cann
Greg Cann

Level 3 Expert

1114 Answers

Are you a Motorola Radio Communication Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...