Question about Acer AL1711 17" Flat Panel LCD Monitor

3 Answers

Monitor stays on for a few seconds then goes out

My monitor stays on for a few seconds then goes out. Any idea what the problem might be? A spare monitor works fine with the computer and I've already tried swapping out the cable so I know it's the monitor itself.

Posted by on

3 Answers

  • Level 1:

    An expert who has achieved level 1.


    An expert that got 5 achievements.


    An expert who has written 20 answers of more than 400 characters.


    An expert who has answered 20 questions.

  • Contributor
  • 46 Answers
Re: monitor stays on for a few seconds then goes out

This problem is very often caused by dry electrolytic capacitors on the inverter board. If you have some skill with soldering you could try to change them. When buying new ones ask for LOW-ESR capacitors for switching mode power supplies (SMPS) and 105°C, they are a little bit more expensive than normal electrolytic capacitors, but are designed for this aplications so they lasts more. Normal el. caps will also works fine so when you cannot buy LOW-ESR for SMPS use normal ones.
This is a FIX ONLY for Rosewill R710E 17 inch Flat Panel LCD Monitor!

Symptoms: The LCD screes shows up for half second or more and turns black, but the LED light remains green and reflecting the light to the screen can be seen the screen working.

Changing the 1000uF condensator at 16V should make work your back lights like new. Usually when this problem occur you will see malformed (has to be flat at the top) at the top that peace of bad condensator. The board on work for this issue is the inverter located at the left side looking from the back. NOTE*** To prevent any accidental damage of other boards unscrew the inverter and work independently with it, specially the part with the soldering.
had same problem with my Sceptre X9S-Naga II 19", which I'd had to replace within a week of original purchase because of an apparently-identical problem at that time. Pissed me off that this second monitor had just 2 years' worth of use on it...I paid $500 in the day, now worth about $200 if new. I wonder if this lack of longevity is to be expected from LCDs, esp. considering the CRT I finally offed was 9 years old with never a problem.

In the end, it breaks out like this:
470uF/35VDC electrolytic capacitor from Radio Shack: $1.66
Hours here and there over the course of a week spent dissassembling, poking, prodding, and googling: incalculable
Satisfaction of resurrecting monitor: $200 plus landfill karma-credit

I had some assistance from a very public-spirited electronics repair website put up by a guy in Malaysia, without which I probably would have run the thing over with a truck by now. His pertinent web page is
There is a /lot/ of info there--sift through the maze of pages and see what he's got to share from his tech experience.

Details: In my case, I had no fancy meter to check almost anything while in place, just an aging DVM. There was a chance that one of the lamps was bad (an easy but possbily expensive replacement) so I decided to pull them out of the pockets they slide into (like...fission control rods at your nearby nuke plant) so that I could directly see what they were doing during the brief power-on time. These are amazing ultramini fluorescent tubes, or at least closely resemble them in color, proportions, and wiring. They're powered by an inverter circuit that feeds them chopped high-voltage, I believe. When I reconnected them, now out of their wells, and powered up, they ALL came just partway on--not the full length of each tube, much like a fluorescent tube does when it is struggling to start--and just before my power-indicator would quit. I swapped around the lamp connectors to see if the performance would change, and it remained the I knew it wasn't likely to be any lamp that was the problem.

The power supply was producing SOMETHING at some points on the board, but I had no idea what to expect or where. 80VDC at one point seemed wildly high, but turned out to be OK in the end.

On about day 67, brute force triumphed over lack of training and service data: I found the guilty cap by desoldering four of the 14 electrolytic caps on the board. I chose the caps I did to start with only because they were 'paired,' so I knew I'd be able to do crude side-by-side comparisons of resistance on them, in order to maybe-kinda-check if one was totally shorted or likely out of spec. The first pair checked out as approximately matching each other. The next pair...DIDN'T. It was ONLY then that I noticed that the cap with the substantially lower resistance (but not a full short) was, actually, BULGING a bit, as I'd hoped to notice from the outset, but it was very subtle. The bulge in the top was less pronounced than at the bottom, so it would never have jumped out at me without having desoldered them, so as to reveal them top and bottom.

A trip to Radio Shack netted me the $1.66 replacement. By this time, I was quite used to plugging and unplugging the AC power cord from the guts that were sprawled across my table, and I had laid out the board on a piece of insulating newspaper with the "cold-cathode" lamps splayed out haphazardly around it. During all testing, on powering up, the power light would come on in a blinking mode, apparently indicating the problem status. I'd hit the button to see if by chance it was going to stay lit solid for more than a few seconds, but every time it would resume the blinking status after a few seconds.

But now maybe it would be last. Beads of perspiration built up on my forehead as I completed the resoldering of the caps I'd pulled. I restored the minimal external connections to the power-board and hit the power button...and was sorely dissapointed to see that it did ALMOST what it had done before. Now it looked like the lamps lit fully--but still would quit after the same brief duration. WTF? How much MORE time could I possibly spend on this?!

It's impossible to make this a long-story-short at this point, but believe it or not, I'm editing a bit of the pain here. The next day, after several more hours of messing with it and hating that the dissassembled stuff had polluted my kitchen table to the point where I was forced to eat elsewhere, I decided I could at least put parts of it back together, even if I WOULD end up running it over with a truck or throwing it out on the freeway. Also, I wanted to see how the lamps looked now, during their brief "on" duration, but when back in place, shining through the actual screen. So I powered it up again after this partial reassembly, and saw...nothing. It was getting WORSE? Where was the lamp-light?

I began to reassess my technique. What connectors had I maybe been too willing to assume didn't matter for testing this power-supply? I reconnected the chassis-ground wire. No difference. WAIT A MINUTE. I had dislodged a wide, fine connector from the back of the screen when I had been taking the lamps out a few days prior. But that shouldn't matter--I'm not sending the thing any data. Still, I'll reconnect it since I have to anyway. The excitement built, but no, STILL no difference. So this was getting weirder--why no lamps NOW? OK, just to be thorough, I reinstalled the video connector cable, to my laptop as before, though I had not needed this during the testing of the lamps while they were out of their why should it matter now?

Well, it did, though I can't say why. The bright white lamp light, I was thrilled to notice, was peeking through two small holes in the back of the frame, WASN'T GOING OUT this time! So...the $1.66 cap really HAD cured the whole problem; the rest of the issues were artificial problems caused by my ignorance in testing and reassembly laziness.

Back to the basic bad-cap failure: I have NO idea what percentage of similar symptoms would be explained by this silly cap failure, but if I have this happen again, the first thing I will do is gat a bright light and a magnifying glass to inspect the caps for bulging. Even seeing nothing, I think I would remove the caps methodically, and either half-ass test them (as I did with less-than-optimal equipment) or simply replace them all. I'd guesstimate that you could buy all caps for about $20...though it would be a painful thing to do this and still not have a working monitor, I admit.

Posted on Nov 22, 2007

Re: monitor stays on for a few seconds then goes out

Swapped out my bulging capacitors - now it's all good. had heard it before and again. swappin' out bulging capacitors should be first.

Posted on Feb 15, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer
Re: monitor stays on for a few seconds then goes out

I fixed my ACER AL1711!!!!!

The problem was that I had to turn it on several times as every time the screen was going black. I bought this 17" screen for £13.00 because the previous owner was fed up with it...

At some point, I pressed the MENU button and looked all the functions. I pressed the RESET and the AUTO as well. That was it!!!!! Now I turn the screen on and stays on!!!!!!

I don't know if I was simply lucky, or if the other guy never did what I did.

It worked for me, I hope it will work for all of you frustrated Acer's out there!!!

Good Luck!!!

Posted on Jun 29, 2008

Add Your Answer

0 characters

Uploading: 0%


Complete. Click "Add" to insert your video. Add


3 Points

Related Questions:

1 Answer

My lcd is hpl1908w its display goes of 5 minutes on first starup and when its displays goes off i on and off the monitor display comes for fews seconds and then goes off again lcd light is green but...

well if your lcd has no bulge capacitors test your tft lamp both top & down of the screen( particularly top) with spare tft lamp. or use another screen to test it. secondly, test the c5607 transistors in the inverter section but if you know how to use spare tft lamp very well , you will easily detect between your screen & the inverter

Aug 06, 2015 | HP L1908W 19" LCD Monitor

1 Answer

Monitor stays on for a few seconds then goes black

could be your wires or your moniter itself check those replace the wires and see what happens if it doesnt work just pm me

Feb 26, 2012 | Dell E173FP 17" LCD Monitor

1 Answer

My Soyo monitor (DYLM1998) stays blank (black) except when it is turned on, the monitor shows a picture for 2 seconds and then goes blank again. If I turn the monitor off/on several times, it finally...

your power supply has a short in it this is comon ive seen this before try to replace cord if attatched take it to someone for repairs if not attatched its the cord most of the time loose wire..

Apr 10, 2011 | Soyo DYLM1998 Monitor

1 Answer

Monitor won't stay on.

is it an lcd? cause your backlight might be messing up or the crystals might be messed up. what condition is the monitor in?

Jun 25, 2009 | HP L1702 17" LCD Monitor

1 Answer

My screen goes black after a few seconds

Sounds like a bad solder joint on the printed circuit board. Once it heats up then it no longer makes good contact and the monitor goes black until it cools down and makes contact again. You could resolder it if you knew where it was but monitors are dangerous to go playing around with as they can hold very high charges of electricity in their capacitors that are very dangerous. It's a throw away world. Go buy a new one.

Jun 02, 2009 | Gateway FPD 1750 17" Flat Panel LCD...

1 Answer

The monitor turns on and connects to my computer then turn off but the power stays on. any ideas?

Make sure the external VGA port on your laptop is enabled. Not all laptops automatically detect a monitor connected and turn on the port. There will be a function key somewhere on the keyboard to control the port. Location varies by manufacturer and model. The usual sequence when you press the key is: laptop display on and external VGA off, laptop off and VGA on, both on.

Apr 17, 2009 | Envision 19" Widescreen Flat Panel LCD...

2 Answers

Monitor goes blank less than a second after turning on.

Beautiful screen, lasts about for a few minutes, goes black. Power button still green. If I turn it off, and then back on, it works again for a while. Any ideas?

May 11, 2008 | Mag Innovision LT982s 19" Flat Panel LCD...

1 Answer

Monitor goes blank less than a second after turning on.

I start my computer and turn it on, and everything looks fine for about 1/4 of a second and then it goes black while leaving the power light green. I can only see the screen again after turning it off and on, but that's only for another 1/4 second. What's up?
I got my rosewill flatscreen as a hand me down from my father. I've had it for several years now. Was working fine until a month ago. When I turn the computer on the screen goes black after 1/4 of a saecond. I have to turn it off and on anywhere from 10 to 20 times before it stays on. I have checked all plugs to the computer and outlets. I have absolutely no idea whats causing this.

Dec 28, 2007 | Rosewill R700J 17" Flat Panel LCD Monitor

Not finding what you are looking for?
Acer AL1711 17" Flat Panel LCD Monitor Logo

2,132 people viewed this question

Ask a Question

Usually answered in minutes!

Top Acer Computer Monitors Experts

Steven Wander
Steven Wander

Level 3 Expert

574 Answers

 Mike M
Mike M

Level 3 Expert

3320 Answers


Level 2 Expert

49 Answers

Are you an Acer Computer Monitor Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides